Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




11 posts

Geek


# 139346 5-Feb-2014 16:54
Send private message

Hi guys,

I understand this may not be the best place to ask, but I've lurked the web so much for an answer to this to no avail.

I am seemingly unable to connect my PS Vita to my PS4 via Remote Play over the internet. It searches and searches, before giving up and returning to an error screen. I've followed countless tutorials and other threads in more appropriate places (PS4/Vita forums), and still no luck. I'm assuming the problem comes down to a setting or something that I'm missing in the Fritz!box itself that is blocking the connection, and figure this may be the best place to ask (I'm on Snap VDSL, and not sure where else I could get help with this modem)

Has anyone here successfully connected a Vita to a PS4 over the internet via the Fritz!box?

I have UPnP enabled, the correct ports open and forwarding to my PS4, and all settings on both the PS4 and Vita are that from the official setup guide. The Fritz!box has to be blocking this somehow, I just have no clue how.. or why. Remote play works fine when both devices are on the same network, and I have no problems with any other internet functionality or connectivity.

Any help would be appreciated. :)

Cheers!
Ryan

Create new topic
256 posts

Ultimate Geek
+1 received by user: 43


  # 980863 5-Feb-2014 17:24
Send private message

Rather than opening ports have you tried the 'Exposed Host' option in the port forwarding section. This will let you know if it is the Fritz or not.




 

 

 


'That VDSL Cat'
10481 posts

Uber Geek
+1 received by user: 2520

Trusted
Spark
Subscriber

  # 980892 5-Feb-2014 17:51
Send private message

does your PS4 show the ports as open (assuming it uses a NAT detection system?)

on a whim, try disabling IPv6 and see if it works. there is a bug with NAT detection in games, where having IPv6 causes incorrect detections with the fritzbox.




#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


 
 
 
 


49 posts

Geek
+1 received by user: 1


  # 981440 6-Feb-2014 18:47
Send private message

Something I've found that works is to remove the port forwarding rules and disable UPnP.  Once that has been done create the rules again, and then enable UPnP.


'That VDSL Cat'
10481 posts

Uber Geek
+1 received by user: 2520

Trusted
Spark
Subscriber

  # 981444 6-Feb-2014 18:49
Send private message

Pinkfish: Something I've found that works is to remove the port forwarding rules and disable UPnP.  Once that has been done create the rules again, and then enable UPnP.



that seems like a very odd bug..


one thing i do find with the fritz is it isnt very clear. when you port forward, you actually need to click on apply in the list before it opens them..




#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.




11 posts

Geek


  # 981884 7-Feb-2014 15:05
Send private message

cjmchch: Rather than opening ports have you tried the 'Exposed Host' option in the port forwarding section. This will let you know if it is the Fritz or not.


Sorry, I'm a bit of a networking amateur. Just to confirm, enabling "exposed host" for the PS4 would mean that it accepts any and every connection request from the internet? If so, it sounds like that would be perfect to see if it is indeed the router or something else. I also assume this is strictly a diagnostic tool, and leaving it set as an exposed host would be a baaad idea. Correct?

Will give this a try tonight! I would do it now from work, but I disabled internet access to the Fritz!box this morning due to an email from AVM about some security issue they're having at the moment. I'll let you know if I have any success!

hio77: does your PS4 show the ports as open (assuming it uses a NAT detection system?) 

on a whim, try disabling IPv6 and see if it works. there is a bug with NAT detection in games, where having IPv6 causes incorrect detections with the fritzbox.


Yup, PS4 states that the NAT is Type 2, which means open/connectable through a router. I've disabled IPv6 (I think!?) but still no luck.
edit: Could you possibly confirm the steps to disable IPv6? I've disabled DHCPv6, but I'm not sure this is the same thing.

.. why can't electronics just get along!

'That VDSL Cat'
10481 posts

Uber Geek
+1 received by user: 2520

Trusted
Spark
Subscriber

  # 981897 7-Feb-2014 15:37
Send private message

by disable, im referring to actually unticking the IPv6 enabled button in the fritz, and rebooting everything to clear ipv6 prefixes.

(internet -> account information -> ipv6 -> tickbox)


its a long shot, but if the NAT detection is the same as what i have seen, should come right.




#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


449 posts

Ultimate Geek
+1 received by user: 249

Subscriber

  # 981902 7-Feb-2014 15:47
One person supports this post
Send private message

Sorry, I'm a bit of a networking amateur. Just to confirm, enabling "exposed host" for the PS4 would mean that it accepts any and every connection request from the internet? If so, it sounds like that would be perfect to see if it is indeed the router or something else. I also assume this is strictly a diagnostic tool, and leaving it set as an exposed host would be a baaad idea. Correct?


Some people consider NAT to be a security feature, but it *isn't*. The internet and all devices connected to it are supposed to have their own IP address (and IPv6 will bring this back), NAT is a relatively recent invention. For actual security, you need a firewall. This gives you all the security you need! (When properly configured. For a home user, this is easy - deny everything incoming.)

Luckily, Windows and OSX come with built in firewalls which deny by default incoming connections. (IIRC). I've had my computer as an exposed host for a while and there's no problem with that. However, it may interfere with port forwarding to other computers.

FritzBoxes have a hidden feature which allows you to capture all packets moving through the router, and download the result to your computer. If remote play works with exposed host enabled, this could allow you to determine which ports are actually in use. However, packet capture utilities like Wireshark are very advanced, so you'd have to get your elbows dirty to go this route. Much easier to google around for which ports you need to open.

Also, you refer to "searching and searching", but generally these autodiscover systems only work over local networks, not the internet. Did you have to type in the IP address of your LAN before searching, or log into an account? Are you sure you used the public IP of your whole network, not just your private IP of the PS4 itself?





 
 
 
 




11 posts

Geek


  # 985212 12-Feb-2014 15:55
Send private message

Hi all,

Sorry for the lack of updates. Just wanted to say that I've had zero luck with anything, including making the PS4 an exposed host. The idea is that both devices are signed into your PSN (Playstation Network) ID, and both authorized as your primary console. Once attempting Remote Play, it doesn't search for an IP specifically, it just connects you to the PS4 that you have connected to the internet and have authorized to use with your PSN ID.

It should work, it just doesn't. I've decided it's probably a feature I wouldn't even use, and will give it another try someways down the track when there have been updates to the Fritz!box, PS4 and Vita.. whoever is the culprit!

Thanks all for your help. :)
Ryan

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21


Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36


Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57


Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48


New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.