Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




253 posts

Ultimate Geek
+1 received by user: 11


Topic # 151752 4-Sep-2014 08:50
Send private message

Does anybody know the configuration of pfSense to enable IPv6 on the snap network?

Have tried a number of ipv6 settings in the WAN interface but am steering blind here so cannot get it to work.





Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3 | 4
111 posts

Master Geek
+1 received by user: 22

Trusted

  Reply # 1121785 4-Sep-2014 13:01
One person supports this post
Send private message

Hi,

You'll want to have "IPv6 Configuration Type" set to "DHCP6" in your WAN interface config.
Also, make sure you turn on V6 globally - that's in System/Advanced ("Networking" tab) - "Allow IPv6".

Static IPv6 is not yet available on Snap and I don't know when that is coming.




“I do not think there is any thrill that can go through the human heart like that felt by the inventor as he sees some creation of the brain unfolding to success... Such emotions make a man forget food, sleep, friends, love, everything.” - Nikola Tesla

 


Disclaimer: Views expressed in my posts do not necessarily reflect those views of my employer.

3422 posts

Uber Geek
+1 received by user: 410

Trusted

  Reply # 1121819 4-Sep-2014 13:36
3 people support this post
Send private message

quakeguy: Hi,

You'll want to have "IPv6 Configuration Type" set to "DHCP6" in your WAN interface config.
Also, make sure you turn on V6 globally - that's in System/Advanced ("Networking" tab) - "Allow IPv6".

Static IPv6 is not yet available on Snap and I don't know when that is coming.


Static would be a big help for users.





 
 
 
 




253 posts

Ultimate Geek
+1 received by user: 11


  Reply # 1122194 4-Sep-2014 22:07
Send private message

Thanks for that info quake guy.

I had actually already tried this suggestion myself with no luck.

All the IPv6 tests online fail and I cant see a IPv6 address being given in pfSense.

I read on this forum a IPv6 prefix is needed on Snap? I tried setting this also but no luck.





157 posts

Master Geek
+1 received by user: 10


  Reply # 1122683 5-Sep-2014 17:14
Send private message

pfSense IPv6 with NZ ISP I found it's flicky as hell, more digging found out that pfSense IPv6 atm doesn't likely to work or can be problematic under PPP connection, I would guess it's more of a firmware problem (within BSD).

for me I have got it working before but only for a brief moment and yes prefix need to be set to 48.

back on early 2.1 or even as early in snapshots of 2.1, there was a problem with ipv6 deamon not starting correctly with PPP connections and need to be done with command line.

and I am not sure if this is in the fix/todo list of pfSense team for 2.2

624 posts

Ultimate Geek
+1 received by user: 124


  Reply # 1122702 5-Sep-2014 18:25
Send private message

bonkas: Thanks for that info quake guy.

I had actually already tried this suggestion myself with no luck.

All the IPv6 tests online fail and I cant see a IPv6 address being given in pfSense.

I read on this forum a IPv6 prefix is needed on Snap? I tried setting this also but no luck.


Last time I looked you had to ring them and ask for IPv6. But that was a while ago now since I was a Snap customer. At the time if you enabled IPv6 I think that meant no IPv4. Things may have changed but it was a phone call to get IPv6.

'That VDSL Cat'
9066 posts

Uber Geek
+1 received by user: 1993

Trusted
Spark
Subscriber

  Reply # 1122711 5-Sep-2014 18:43
Send private message

kiwirock:
bonkas: Thanks for that info quake guy.

I had actually already tried this suggestion myself with no luck.

All the IPv6 tests online fail and I cant see a IPv6 address being given in pfSense.

I read on this forum a IPv6 prefix is needed on Snap? I tried setting this also but no luck.


Last time I looked you had to ring them and ask for IPv6. But that was a while ago now since I was a Snap customer. At the time if you enabled IPv6 I think that meant no IPv4. Things may have changed but it was a phone call to get IPv6.


snap hand out IPv6 by default.




#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.




253 posts

Ultimate Geek
+1 received by user: 11


  Reply # 1122824 5-Sep-2014 23:18
Send private message

D1NZ: pfSense IPv6 with NZ ISP I found it's flicky as hell, more digging found out that pfSense IPv6 atm doesn't likely to work or can be problematic under PPP connection, I would guess it's more of a firmware problem (within BSD).

for me I have got it working before but only for a brief moment and yes prefix need to be set to 48.

back on early 2.1 or even as early in snapshots of 2.1, there was a problem with ipv6 deamon not starting correctly with PPP connections and need to be done with command line.

and I am not sure if this is in the fix/todo list of pfSense team for 2.2


Yes i think you are exactly right on this one.

After a few hours tonight messing around with this I have given up.







253 posts

Ultimate Geek
+1 received by user: 11


  Reply # 1302706 12-May-2015 12:54
Send private message

Has anyone had any luck with this yet?

I have pfsense receiving a IPv6 address from Snap, but cannot get any clients to receive a IPv6 gateway to route traffic, clients can resolve IPv6 but no traffic.

Any ideas?





956 posts

Ultimate Geek
+1 received by user: 346
Inactive user


  Reply # 1302802 12-May-2015 14:05
Send private message

In your lan interface configure ipv6 configuration type to track interface:



Restart your WAN interface and clients should get an IPV6 address.

Check this thread for WAN configuration http://www.geekzone.co.nz/forums.asp?forumid=90&topicid=171955



253 posts

Ultimate Geek
+1 received by user: 11


  Reply # 1302915 12-May-2015 15:51
Send private message

Yes I have followed that post also and have the exact same configuration but when trying to ping an outside ipv6 address I get "Destination host unreachable."

pfsense is receiving a ipv6 address and gateway but does not seem to be routing, dns seems to be functioning OK though.

This is with a fresh install of pfsense, no other configuration set as-yet - same results as last time I tried this.. wierd

Plot thickens hmmmmmm....







253 posts

Ultimate Geek
+1 received by user: 11


  Reply # 1303015 12-May-2015 17:41
Send private message

It seems I can ping from within pfsense. This is a completed ping to google.com using ipv6 within the pfsense interface:

PING6(56=40+8+8 bytes) 2406:e000:e10c:0:20c:29ff:fec0:f7a7 --> 2404:6800:4003:c01::65
16 bytes from 2404:6800:4003:c01::65, icmp_seq=0 hlim=253 time=187.511 ms
16 bytes from 2404:6800:4003:c01::65, icmp_seq=1 hlim=253 time=187.408 ms
16 bytes from 2404:6800:4003:c01::65, icmp_seq=2 hlim=253 time=187.449 ms
16 bytes from 2404:6800:4003:c01::65, icmp_seq=3 hlim=253 time=187.298 ms

--- google.com ping6 statistics ---
4 packets transmitted, 4 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 187.298/187.416/187.511/0.078 ms

It's just times out when performing the same ping on a client PC...

This is the output of ipconfig/all of the network adapter on my PC - Does the gateway seem correct?

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
   Physical Address. . . . . . . . . : 40-16-7E-77-29-73
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::892b:a6f4:89e7:2e9a%4(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.106(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Tuesday, 12 May 2015 5:35:41 pm
   Lease Expires . . . . . . . . . . : Tuesday, 12 May 2015 7:35:42 pm
   Default Gateway . . . . . . . . . : fe80::1:1%4
                                       192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 54531710
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-C1-01-51-40-16-7E-77-29-73
   DNS Servers . . . . . . . . . . . : 2406:e000:e10c:0:20c:29ff:fec0:f7a7
                                       192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled





956 posts

Ultimate Geek
+1 received by user: 346
Inactive user


  Reply # 1303020 12-May-2015 18:01
Send private message

Did you remove the default IPV6 firewall rule from the LAN interface per chance?



Yes the gateway is correct as I believe its based on router advertisements.

Though from your screenshot it looks like your client hasn't obtained an IPV6 address as its still using a link local address.

This is mine for example:
Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
Physical Address. . . . . . . . . : x
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2406:e001:1:x:x:x:x:x(Preferred)
Temporary IPv6 Address. . . . . . : 2406:e001:1:x:x:x:x:x(Preferred)
Link-local IPv6 Address . . . . . : x(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.10(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : fe80::1:1%15
192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : x
DHCPv6 Client DUID. . . . . . . . : x

DNS Servers . . . . . . . . . . . : 192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Enabled




253 posts

Ultimate Geek
+1 received by user: 11


  Reply # 1303021 12-May-2015 18:05
Send private message

Nope it is present, I will attach screenshots of my config - I might have something out of place I am not seeing.

Config as below - Hope you guys an point out something im missing.

Click to see full size

Click to see full size

Click to see full size

Click to see full size

Click to see full size





956 posts

Ultimate Geek
+1 received by user: 346
Inactive user


  Reply # 1303027 12-May-2015 18:16
Send private message

Only thing I can think of is to restart pfsense as your configuration looks fine, mine looks the same.

My clients didn't pick up ipv6 addresses after I configured track interface until I disconnected the current pppoe connection and reconnected it



253 posts

Ultimate Geek
+1 received by user: 11


  Reply # 1303029 12-May-2015 18:21
Send private message

JamesL: Only thing I can think of is to restart pfsense as your configuration looks fine, mine looks the same.

My clients didn't pick up ipv6 addresses after I configured track interface until I disconnected the current pppoe connection and reconnected it


have restarted the pfsense box a few times with same result. Am setting up a new Windows 7 and 10 VM and seeing what happens there as it may be a client issue. I can ping ipv6 addresses fine from pfsense as above.





 1 | 2 | 3 | 4
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.