Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


93 posts

Master Geek
+1 received by user: 3


Topic # 152090 15-Sep-2014 20:51
Send private message

Hello,

Can someone who has this working post what settings they're using? I tried using IPv6 using a Draytek Vigor 130 over Snap VDSL.

The settings I'm using on the DV130 are:

 

"Connection Type: DHCPv6 Client";
"Identity Association: Prefix Delegation";
"IAID (Internet Association ID: <this field always seems to have a random number in here>"

The page looks like this: http://iforce.co.nz/i/qq2xx0ka.b23.png

I can't get it to pickup a IPv6 addres from Snap.

My end goal is to get this working with pfSense but for now I'll be happy if I can just get it working right on the Modme itself.


Create new topic
8025 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 1130034 16-Sep-2014 15:45
Send private message

DHCPv6 is the wrong connection type

Snap VDSL connection type is: PPPoE, VPI/VCI: 0//110, VLAN: 10 as per:
http://www.snap.net.nz/support/content/1/17/en/general-settings.html 

Your modem gets assigned ipv4 and ipv6 addresses from Snap's systems after/as part of the PPPoE connection.





93 posts

Master Geek
+1 received by user: 3


  Reply # 1130060 16-Sep-2014 16:46
Send private message

Hi Ragnor, I appreciate the reply.

The reason I was trying DHCPv6 with PD was because of some other posts here (specifically this one)

I have just tried it with PPP mode as you said, and it doesn't work. I've also e-mail snap who told me the DV130 is an 'unspported device' and that I was SoL.


[ Click for Full Res ]


The guy in the thread I have linked has it working, but he's using an Asus RT66N with Tomato fimware.

Any insights on how to get this going would be appreciated.

8025 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 1130366 17-Sep-2014 00:24
Send private message

Hmm that makes sense, so you need both the PPPoE connection for ipv4 and the DHCPv6 connection for ipv6 on Snap...

Someone must have a DV 130 on Snap or WxC with working ipv6.

xor

36 posts

Geek
+1 received by user: 6


  Reply # 1131737 18-Sep-2014 19:44
Send private message

The Vigor's arn't compatable with Snap IPv6, they pick up addresses but refuse to route.



93 posts

Master Geek
+1 received by user: 3


  Reply # 1131759 18-Sep-2014 20:01
Send private message

I can't even get mine to pick up an address. I've also got a pfSense here that isn't having much luck either.

8025 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 1132238 19-Sep-2014 16:18
Send private message

SnapperNet (no relation to Snap) are the main NZ distributor of Draytek maybe contact their support and see if they can help or advise if the DV130 will work on Snap VDSL2 w/ IPV6
https://www.snappernet.co.nz/ 

:)
2876 posts

Uber Geek
+1 received by user: 85

Subscriber

  Reply # 1133161 21-Sep-2014 16:15
Send private message

I never got my Vigor to pick up IPv6 directly from Snap! 

I was eventually able to get OpenWRT to negotiate a IPv6 prefix over PPPoE, when IPv4 connects, however, it's not the most reliable. I suspect it's to do with Snap!'s implementation of IPv6 (Read: useless)


It still makes no sense to me why they won't provide static IPv6 prefixes, either. What's up with that?! 


Long story short though; you may get IPv6 working in some form on Snap!, but it won't be very reliable. 







93 posts

Master Geek
+1 received by user: 3


  Reply # 1133201 21-Sep-2014 18:32
One person supports this post
Send private message

Right.. might give it a miss for now then.

Aaroona, just out of curiosity can you post the steps & settings you used to get your router to pickup IPv6? And when you say it was unreliable exactly what do you mean?

 

 

 

Thanks.

'That VDSL Cat'
8101 posts

Uber Geek
+1 received by user: 1693

Trusted
Spark
Subscriber

  Reply # 1133204 21-Sep-2014 18:40
Send private message

breakaway:And when you say it was unreliable exactly what do you mean?   Thanks.


This ild be interested in too. 

is it simply that your getting a new v6 ip often?




#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


:)
2876 posts

Uber Geek
+1 received by user: 85

Subscriber

  Reply # 1133971 22-Sep-2014 18:26
Send private message

To be honest, my issues could have been resolved by having a static IPv6 prefix.

I got round most of my issues by ensuring my DHCPv6 forced Stateful addresses only. 
the IPv6 issues I have are not caused solely by the implementation that Snap! has, but it certainly hasn't helped either. 
I.e. if PPP drops, for whatever reason and you have a Stateless assigned IP, when the internet comes back on, you for some reason still have your old stateless IP with the previous IPv6 prefix and IPv6 stops working, sometimes stopping internet traffic to IPv6 sites all together.

I noticed this issue across Mac and Windows, though iOS seemed to be unaffected.


I just wish Snap! would implement a seemingly normal implementation of IPv6 instead of what they have now.

... and give us static Ipv6 prefixes, so I could open ports happily, without having to use the security hole that UPnP is.


breakaway: Right.. might give it a miss for now then.

Aaroona, just out of curiosity can you post the steps & settings you used to get your router to pickup IPv6? And when you say it was unreliable exactly what do you mean?   Thanks.


There are actually no steps to provide... 
OpenWRT provides a native IPv6 stack, whereas previous versions didn't.

All I did was put my Vigor 130 into bridge mode, setup a PPPoE connection from OpenWRT to the modem, and off she went. (Negotiates the Ipv6 over the PPP connection, when IPv4 starts)
IPv6 was enabled by default, so no configuration was required. As long as your OS supports IPv6 you should be good to go.
One of the things I did notice though, was that because of Snap's implementation, you'll find the IPv6 (wan6) interface in OpenWRT doesn't actually get an IPv6 address assigned to it. It gets assigned to the LAN (br-lan) interface, then assigns out from there. Again, it works, but it's by no means a great setup.

I've recently disabled IPv6 completely, as it was causing grief (different issue)





Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft Dynamics 365 Business Central launches
Posted 10-Jul-2018 10:40


Spark completes first milestone in voice platform upgrade
Posted 10-Jul-2018 09:36


Microsoft ices heated developers
Posted 6-Jul-2018 20:16


PB Technologies charged for its extended warranties and warned for bait advertising
Posted 3-Jul-2018 15:45


Almost 20,000 people claim credits from Spark
Posted 29-Jun-2018 10:40


Cove sells NZ's first insurance policy via chatbot
Posted 25-Jun-2018 10:04


N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.