Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




54 posts

Master Geek
+1 received by user: 1


Topic # 166087 2-Mar-2015 14:15
Send private message

I have a HTC Wildfire S which was sold as a Telecom phone but which I only ever used on Vodafone. It worked fine (there was some anomaly about not getting 3G outside of major centres but it didn't worry me).

I've just switched to 2Degrees and I can't get the data to work at all.

I've read this http://www.geekzone.co.nz/forums.asp?forumid=85&topicid=66282 and I've had a couple of calls with 2D in which we recreated the APN a couple of times.

Just wondered if anyone on here knew of some idiosyncrasy with a phone that was originally intended for Telecom but which worked on Vodafone ?

Thanks


Filter this topic showing only the reply marked as answer Create new topic
BDFL - Memuneh
61757 posts

Uber Geek
+1 received by user: 12421

Administrator
Trusted
Geekzone
Lifetime subscriber

 
 
 
 




54 posts

Master Geek
+1 received by user: 1


  Reply # 1249488 2-Mar-2015 14:30
Send private message

Thanks for reply.

Yes voice and sms are both working and, fwiw, data works fine over wi-fi just not over the mobile network.

 

If you can place voice calls, have you asked them to check this?

 


No, thanks for pointing it out. I will do although the resolution described is a bit vague but nevertheless I'll point them at the thread.

The guy on the support call suggested that I try an alternate SIM which didn't seem very likely but I'm going to do that ... I just can't do it until tomorrow.



204 posts

Master Geek
+1 received by user: 5


  Reply # 1249491 2-Mar-2015 14:31
Send private message

try this?

 

Setting up the Device

 

     

  1. On the device, tap the Menu icon (or Applications > Menu).
  2. Select Settings > Wireless & networks (or Wireless Controls) > Mobile networks (> GSM/UMTS Options) >Access Point Names.
  3. Press the Menu key and select New APN.
  4. Select Name, enter 2degrees Web and tap OK.
  5. Select APN, enter internet and tap OK.
  6. Enter the Username and Password listed below. If no value is listed, leave the field blank.

     

    • Username:
    • Password:
  7. If required set Authentication Type to PAP
  8. Set the APN type to default or internet.
  9. Press the Menu key and select Save.
  10. If necessary, tap Access Point Names then tap the circle next to 2degrees Web to set the profile as default.
  11. Return to the Home screen and launch the Browser.
  12. Press the Menu key and select (More >) Settings (>General) > Set home page (or Page content settings).
  13. Enter http://m.2degreesmobile.co.nz/ as the Homepage andtap OK.

 

The settings are saved and the service is ready for use.




I would love to change the world, but they won't give me the source code

#BOFH



54 posts

Master Geek
+1 received by user: 1


  Reply # 1249531 2-Mar-2015 15:04
Send private message

Yes, thanks. I did follow those steps but still no mobile data.

BDFL - Memuneh
61757 posts

Uber Geek
+1 received by user: 12421

Administrator
Trusted
Geekzone
Lifetime subscriber



54 posts

Master Geek
+1 received by user: 1


  Reply # 1249533 2-Mar-2015 15:07
Send private message

No I haven't yet but I do have another handset I can try the SIM with ... just have to wait for my wife to come home.


BDFL - Memuneh
61757 posts

Uber Geek
+1 received by user: 12421

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 1249537 2-Mar-2015 15:10
Send private message

Please test. If it still doesn't work then check you have good coverage. If you have coverage then contact 2degrees, explain voice and SMS work but mobile data doesn't and ask to have your account checked.

On the other hand, if it does work then it is obviously something on your handset.





1527 posts

Uber Geek
+1 received by user: 269

Trusted
2degrees

  Reply # 1249702 2-Mar-2015 18:17
Send private message

It's possible it's the HSDPA 850/1900 version - HTC Wildfire S - in which case it will not connect to 3G but should do to 2G, albeit slow.

Can you try your SIM in another phone and PM us your number, location and what you see on the screen in terms of signal.

Regards
^POB



54 posts

Master Geek
+1 received by user: 1


  Reply # 1257785 13-Mar-2015 11:47
One person supports this post
Send private message

Sorry it's taken me so long to reply and thanks to those who replied.

It turned out I *didn't* have access to another 2D sim because my wife uses a 'mini-SIM' and I don't.

Instead of that I took it into the 2D shop on Willis Street in Wellington where a very helpful member of staff fixed my problem in about 60 seconds.

It did come down to the APN but he said the way it had been set by me and confirmed by 2D call centre was "correct" he just happened to know from several years of dealing with these problems that there was another way of setting the APN which sometimes made it work and that's what he did .

So for future reference (and I know this sounds weird) the change he made was to the 'APN Type' and the value that now appears for that property is (without the quotes) 'default, supl' .

I'm sure there's someone around here who can explain why that works but I'm just pleased it does. Although the Wildfire is old I really like it being small and it's hard to find a phone that is that small .


Filter this topic showing only the reply marked as answer Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.