Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

425 posts

Ultimate Geek
+1 received by user: 228


Topic # 201521 22-Aug-2016 12:12
Send private message

Hi all. For the past... 4? weeks now, all IPv6 connections time out for me. Multiple computers, Windows and Linux, Fritzbox 7490 or Asus routers, ethernet and wifi. Factory reset the fritzbox too. I get an IP fine, routes look fine, everything seems okay but no connections to IPv6 destinations work. No, it's not a DNS issue.




I'm hoping the wisdom of the crowds might be able to help me here. Here's the email I sent to 2degrees support a week ago (they haven't responded yet, funnily enough. It seemed like the tier2 support on the phone wanted to fob me of too...)





For the last week or two, all IPv6 connections time out on my


connection. There is no error message when pinging, packets silently


drop. SSHing to my IPv6 enabled VPS would take two minutes to connect,


because it was trying to connect over IPv6 and receiving no reply,


before giving up and connecting instantly over IPv4.



I test IPv6 using my VPS, and



This is not a DNS problem, DNS was returning both IPv4 and v6 addresses





This didn't actually break dual stack websites, so please don't ask me


to turn off IPv6 again.



I can make IPv6 connections inside my local network, for instance to my


fritz box.



I have tried to make connections on two different computers, one windows


10 and one linux. Both failed in the same way.



I have tried two routers, the 7490 and an ASUS RT-AC66U, with no change.


I also tried factory-resetting the fritzbox, no change.



Ethernet and Wifi, no change.



I have had extensive phone session with both Tier 1 and 2 support at


2degrees, niether were able to find the problem.



As I have replaced every component of my network locally with no change


to the problem, I can only conclude that there is some kind of


server-side issue at 2degrees.



Here is some sample console output:



$ ping6


PING (2404:6800:4006:802::200e): 56 data bytes



--- ping statistics ---


6 packets transmitted, 0 packets received, 100% packet loss






# ping6 2404:6800:4006:802::200e


PING 2404:6800:4006:802::200e (2404:6800:4006:802::200e): 56 data bytes



--- 2404:6800:4006:802::200e ping statistics ---


10 packets transmitted, 0 packets received, 100% packet loss






# traceroute6


traceroute to (2404:6800:4006:802::200e), 30 hops max, 16


byte packets


1 * * *


2 * * *


3 * * *


4 * * *


5 * * *


6 * * *


7 * * *





etc etc.


I'll add my IP settings:

2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether d0:50:99:2f:31:90 brd ff:ff:ff:ff:ff:ff
inet brd scope global dynamic enp5s0
valid_lft 817025sec preferred_lft 817025sec
inet6 2406:e001:2d22:1:9ab:2c7b:e187:c540/64 scope global noprefixroute dynamic
valid_lft 6971sec preferred_lft 3371sec
inet6 fd00::457b:543f:7e8f:a41/64 scope global deprecated noprefixroute dynamic
valid_lft 6971sec preferred_lft 0sec
inet6 fe80::8c5d:4dc1:b8f8:d1c9/64 scope link
valid_lft forever preferred_lft forever

Any ideas are very much appreciated!

Create new topic
1530 posts

Uber Geek
+1 received by user: 269


  Reply # 1615713 22-Aug-2016 12:31
Send private message

Hey Ripdog,


Something certainly looks odd there. Can you please message us your broadband customer number or username, we'll check it out for you.




Ralph ^JOB

930 posts

Ultimate Geek
+1 received by user: 292


  Reply # 1615724 22-Aug-2016 12:50
Send private message

IpV6 is a bit different to v4. Generally your router will run a v6 DHCP server, and issues IP's out of a ::/56 or sometimes a ::/48 range.


So it could be a problem with your router. The ISP Doesn't give you a single IP address, they give you a range for your network.


425 posts

Ultimate Geek
+1 received by user: 228


  Reply # 1615742 22-Aug-2016 13:01
Send private message

 PM sent @2degreescare.




@darylblake IP settings are fine. All settings are at defaults, and the fritzbox was factory reset. 2degrees offers fully supported v6, and that includes a preconfigured router. Both windows and linux PCs are at default IPv6 settings. The IP I get is valid, and if it wasn't, connections would fail outright rather than time out.

798 posts

Ultimate Geek
+1 received by user: 264


  Reply # 1615751 22-Aug-2016 13:13
Send private message

This sounds similar to the trouble I was having a week or so ago. Router would obtain a prefix, but neither the router or client devices could ping anything except the first 2degrees HOP. Thankfully for me it came right (seemingly) on its own.


I submitted a ticket, it came right, and support replied to me a few days later, to which I replied querying what happened. I haven't dared reboot the router, and am still waiting for a response from the support team on what's happening.


I have a suspicion something has changed, as I've previously had very reliable service, both v4 and v6.


My line connects through the Snap-37 BNG FWIW.

112 posts

Master Geek
+1 received by user: 5

  Reply # 1615809 22-Aug-2016 14:27
Send private message

Sorry to go slightly off topic but @2degreescare i have also sent you a PM regarding an issue i am having would appreciate any light you can shed on the situation.

425 posts

Ultimate Geek
+1 received by user: 228


  Reply # 1616470 23-Aug-2016 18:07
Send private message

All sorted, some kind of backend issue. Thanks @2degreescare!

1530 posts

Uber Geek
+1 received by user: 269


  Reply # 1616726 24-Aug-2016 10:55
Send private message

No worries at all, glad to help :)


Ralph ^JOB

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.