Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 
392 posts

Ultimate Geek
+1 received by user: 81


  Reply # 1677103 24-Nov-2016 23:34
Send private message

That is pretty clear - you successfully connected to the SMTP server and it sent back a 421 message and disconnected you.  So you do not seem permitted to use the SMTP server for some reason.


1528 posts

Uber Geek
+1 received by user: 269

Trusted
2degrees

  Reply # 1677242 25-Nov-2016 09:40
Send private message

Hi there Rayonline,

 

Can you please message us with your 2degrees account number so we can check this out for you?

 

Thanks,

 

Ralph ^JOB


 
 
 
 


148 posts

Master Geek
+1 received by user: 40


  Reply # 1677249 25-Nov-2016 09:53
Send private message

fe31nz:

 

That is pretty clear - you successfully connected to the SMTP server and it sent back a 421 message and disconnected you.  So you do not seem permitted to use the SMTP server for some reason.

 

 

SMTP is also used for receiving mail, so it needs to be open to the whole internet. It's unlikely that this message is coming from the server...


1304 posts

Uber Geek
+1 received by user: 299


  Reply # 1677260 25-Nov-2016 10:18
Send private message

You're not connecting through a work or personal VPN are you?



1556 posts

Uber Geek
+1 received by user: 39


  Reply # 1677265 25-Nov-2016 10:36
Send private message

No just at home.  I don't use VPN etc ... 


392 posts

Ultimate Geek
+1 received by user: 81


  Reply # 1677463 25-Nov-2016 14:58
Send private message

sorceror:

 

fe31nz:

 

That is pretty clear - you successfully connected to the SMTP server and it sent back a 421 message and disconnected you.  So you do not seem permitted to use the SMTP server for some reason.

 

 

SMTP is also used for receiving mail, so it needs to be open to the whole internet. It's unlikely that this message is coming from the server...

 

 

The telnet test showed that rayonline was indeed receiving the 421 message from the SMTP server.

 

Not all SMTP server are set up to receive emails - some are set up for sending only.  In any case, all the email servers I have ever met have configuration that allows the sending of emails to non-local addresses ("forwarding") to be restricted by various rules, so that the server can not be used for that except by authorised users.  If it is set up to receive emails, these days it will normally accept a connection from only sources that are likely to be legitimate SMTP servers, not spambots.  So, for example, it is likely to deny access to any address that seems to be an another ISP's customer IP address, rather than their SMTP server address.  When it comes to forwarding emails from IP addresses inside the SMTP server's own ISP network, different ISPs have different policies.  Some allow all their IP addresses to have access to the SMTP server - that is the most common setting as most customers have a need to send emails.  However, to help prevent spambots from malware infected customer PCs, some ISPs block connections to SMTP server port numbers other than their own SMTP servers.  This can be just inbound connections, or both directions.  So if you run your own SMTP server (as some businesses do), you would then need to ask to have the SMTP ports unblocked for your SMTP server IP address.  2Degrees does not do this - it allows access to all ports in both directions, which is one reason I chose to join Snap when I moved to a fibre connection and my old ISP could not do fibre for me.

 

I run my own SMTP server, which receives incoming emails directly on port 25, but blocks all attempts to forward emails through it to other email addresses.  Such attempts happen daily.  But I do not try to send emails directly from my own SMTP server, as the other SMTP servers around the world do not know that my static IP address is a legitmate SMTP server, and will tend to not accept emails from it.  So I have my SMTP server set up to forward all outgoing emails via smtp.snap.net.nz, which it does for me without any problems.  I do have SPF records in my DNS to say that emails from my domain are sent via smtp.snap.net.nz, which tells the rest of the world's SMTP servers that emails from my domain being sent from that server are legitimate.


362 posts

Ultimate Geek
+1 received by user: 92


  Reply # 1677548 25-Nov-2016 18:09
Send private message

sbiddle:

 

In all seriousness you should move away from STMP and POP3. There is no valid reason for still using 1970's protocols. Most people want their email on multiple devices these days and archaic protocols such as these simply can't offer that.

 

(And nobody mention keeping POP3 mail on a server - that *always* ends in tears at some point)

 

 

 

 

 

 

LOL wut? Maybe because that 1980s SMTP protocol is the still the standard for sending email? Just like that 1990s protocol used for web browsing.

 

 


27417 posts

Uber Geek
+1 received by user: 6866

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 1677602 25-Nov-2016 19:23
Send private message

vulcannz:

 

sbiddle:

 

In all seriousness you should move away from STMP and POP3. There is no valid reason for still using 1970's protocols. Most people want their email on multiple devices these days and archaic protocols such as these simply can't offer that.

 

(And nobody mention keeping POP3 mail on a server - that *always* ends in tears at some point)

 

 

 

 

 

 

LOL wut? Maybe because that 1980s SMTP protocol is the still the standard for sending email? Just like that 1990s protocol used for web browsing.

 

 

 

 

Standard for sending email? It really depends what you mean by that. The vast majority of people these days rely on webmail or are using services like Gmail, Yahoo or Outlook.

 

Yes I know SMTP is still the bearer of email across the internet. I work with that every day. It and POP3 should however be made obsolete as a way for individuals to connect to mail platforms because they cause so many issues and are incredibly inflexible in a world where people want mail across multiple devices.

 

 

 

 

 

 


148 posts

Master Geek
+1 received by user: 40


  Reply # 1677642 25-Nov-2016 20:49
Send private message

fe31nz:

 

sorceror:

 

fe31nz:

 

That is pretty clear - you successfully connected to the SMTP server and it sent back a 421 message and disconnected you.  So you do not seem permitted to use the SMTP server for some reason.

 

 

SMTP is also used for receiving mail, so it needs to be open to the whole internet. It's unlikely that this message is coming from the server...

 

 

The telnet test showed that rayonline was indeed receiving the 421 message from the SMTP server.

 

Not all SMTP server are set up to receive emails - some are set up for sending only.  In any case, all the email servers I have ever met have configuration that allows the sending of emails to non-local addresses ("forwarding") to be restricted by various rules, so that the server can not be used for that except by authorised users.  If it is set up to receive emails, these days it will normally accept a connection from only sources that are likely to be legitimate SMTP servers, not spambots.  So, for example, it is likely to deny access to any address that seems to be an another ISP's customer IP address, rather than their SMTP server address.  When it comes to forwarding emails from IP addresses inside the SMTP server's own ISP network, different ISPs have different policies.  Some allow all their IP addresses to have access to the SMTP server - that is the most common setting as most customers have a need to send emails.  However, to help prevent spambots from malware infected customer PCs, some ISPs block connections to SMTP server port numbers other than their own SMTP servers.  This can be just inbound connections, or both directions.  So if you run your own SMTP server (as some businesses do), you would then need to ask to have the SMTP ports unblocked for your SMTP server IP address.  2Degrees does not do this - it allows access to all ports in both directions, which is one reason I chose to join Snap when I moved to a fibre connection and my old ISP could not do fibre for me.

 

I run my own SMTP server, which receives incoming emails directly on port 25, but blocks all attempts to forward emails through it to other email addresses.  Such attempts happen daily.  But I do not try to send emails directly from my own SMTP server, as the other SMTP servers around the world do not know that my static IP address is a legitmate SMTP server, and will tend to not accept emails from it.  So I have my SMTP server set up to forward all outgoing emails via smtp.snap.net.nz, which it does for me without any problems.  I do have SPF records in my DNS to say that emails from my domain are sent via smtp.snap.net.nz, which tells the rest of the world's SMTP servers that emails from my domain being sent from that server are legitimate.

 

 

he would get a different error if the issue was with mail relaying - the server would allow the connection in the first place.

 

as I mentioned earlier, i don't believe the message is coming from the server as the message says the server refused the connection - if i was to guess i would say a load balancer generated it.

 

as to why - maybe he's been specifically blacklisted by 2degrees?


21712 posts

Uber Geek
+1 received by user: 4504

Trusted
Subscriber

  Reply # 1677645 25-Nov-2016 20:53
Send private message

Usual cause for 10061 when I was stuck helpdesking was antivirus going broken and partially intercepting things.




Richard rich.ms



1556 posts

Uber Geek
+1 received by user: 39


  Reply # 1681215 2-Dec-2016 12:05
Send private message

richms: Usual cause for 10061 when I was stuck helpdesking was antivirus going broken and partially intercepting things.

 

 

 

I will just use the Yahoo's outgoing server. 

 

I disabled AVAST for 1hr and it failed.  I disabled AVAST (permanently) and restarted the computer.  Still failed. 

 

I used smtp.snap.net.nz port 25 without encryption as well as port 465 with SLS.  

 

 

 

Edit.  Also disabled my Windows Firewall with AVAST disabled.  Same result.


1 | 2 
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.