Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


644 posts

Ultimate Geek
+1 received by user: 176


Topic # 230748 11-Mar-2018 19:37
Send private message

This is an oddball one, and unfortunately the person I spoke to at 2degrees wasn't technically clued up enough for me to get them to test from their end, so I come to geekzone to verify my sanity.

 

Can I get someone to download the latest GeForce Game Ready Driver for Windows 10 x64 (Version 391.01) from the GeForce website or using GeForce experience, and see how fast it goes?

 

Directly from nvidia's website I only hit 20KBps for 20MB worth of the 420MB file before the download stalled entirely, and using GeForce Experience I think I averaged around 100KBps, it seemed to run closer to 1MBps but stalled often.

 

Anyway, speeds elsewhere are fine (showing 880Mbit to 2Degrees Auckland on speedtest.net), and speeds to overseas servers are fine (over 200Mbps to random LA server provided by speedtest.net), so it seems to be something kooky specifically with the nvidia website - as to if it's 2degrees only or also other providers, I'm unsure, but if anyone wants to have a crack at downloading those files and let me know, I'd appreciate it.


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
14 posts

Geek
+1 received by user: 3

Trusted
2degrees

  Reply # 1972809 11-Mar-2018 19:45
Send private message

Was able to get 10MB/s download speeds when I tried myself just now. URL: http://us.download.nvidia.com/Windows/391.01/391.01-desktop-win10-64bit-international-whql.exe

 

This is on a 100/20 2degrees fibre connection over IPv4 in the Auckland CBD.

 

Might pay to check if when you download the file (eg in Command Prompt) if it's IPv4 or IPv6 - I've known there to be some issues where speeds are affected on v6 for downloads.

 

 





Any opinions are my own and do not represent those of 2degrees


94 posts

Master Geek


  Reply # 1972813 11-Mar-2018 19:53
Send private message

I dont have download issues, I have issue with the drivers taking ages to uninstall and install. When it does install, something the Experience part doesnt show much or any of my games.

 

 

 

Just downloaded it again 391.01. Took 20 seconds to download 431mb from their website




644 posts

Ultimate Geek
+1 received by user: 176


  Reply # 1972835 11-Mar-2018 20:47
Send private message

Hmm, good point, I haven't checked if it's running through v6 or v4, I'll give that a gander soon.


'That VDSL Cat'
8098 posts

Uber Geek
+1 received by user: 1693

Trusted
Spark
Subscriber

  Reply # 1972848 11-Mar-2018 21:12
Send private message

pegging lines here, both spark and vf v4+v6

 

 





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


Meow
7519 posts

Uber Geek
+1 received by user: 3632

Moderator
Trusted
Lifetime subscriber

  Reply # 1972855 11-Mar-2018 21:20
Send private message

@toejam316 There is a known issue with 2degrees IPv6 causing downloads to run incredibly slow. Over IPv4 I get 48MB/sec to that URL on my 2degrees Gigabit connection.







644 posts

Ultimate Geek
+1 received by user: 176


  Reply # 1972856 11-Mar-2018 21:21
Send private message

michaelmurfy:

 

@toejam316 There is a known issue with 2degrees IPv6 causing downloads to run incredibly slow. Over IPv4 I get 48MB/sec to that URL on my 2degrees Gigabit connection.

 

 

Ah, that may well be it - shame the technical support desk wasn't aware :-\


'That VDSL Cat'
8098 posts

Uber Geek
+1 received by user: 1693

Trusted
Spark
Subscriber

  Reply # 1972857 11-Mar-2018 21:21
Send private message

michaelmurfy:

 

@toejam316 There is a known issue with 2degrees IPv6 causing downloads to run incredibly slow. Over IPv4 I get 48MB/sec to that URL on my 2degrees Gigabit connection.

 

 

is that all? :/





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.




644 posts

Ultimate Geek
+1 received by user: 176


  Reply # 1972876 11-Mar-2018 22:29
Send private message

Yep, just got around to turning off IPv6 on my WAN and verifying, that is indeed the issue.

 

Seems like a really major issue for the helpdesk to NOT be aware, and hilariously they were implying the issue was that I wasn't using the fritz!box...


141 posts

Master Geek
+1 received by user: 40


  Reply # 1973103 12-Mar-2018 12:04
Send private message

toejam316:

 

Yep, just got around to turning off IPv6 on my WAN and verifying, that is indeed the issue.

 

Seems like a really major issue for the helpdesk to NOT be aware, and hilariously they were implying the issue was that I wasn't using the fritz!box...

 

 

 

 

turning IPv6 off is lazy advice. you still don't know if the issue was with 2degrees or your router or your PC or the server or w/e.

 

chances are the helpdesk was correct tbh




644 posts

Ultimate Geek
+1 received by user: 176


  Reply # 1973132 12-Mar-2018 12:35
Send private message

sorceror:

toejam316:


Yep, just got around to turning off IPv6 on my WAN and verifying, that is indeed the issue.


Seems like a really major issue for the helpdesk to NOT be aware, and hilariously they were implying the issue was that I wasn't using the fritz!box...



 


turning IPv6 off is lazy advice. you still don't know if the issue was with 2degrees or your router or your PC or the server or w/e.


chances are the helpdesk was correct tbh


I do know though, the issue is with 2degrees IPv6 implementation, it's been proven by my fault resolution and verified as a know issue by some well informed users previous to your post.
I'm not actually able to troubleshoot 2degrees core network, although if they'd pay me to go and do so, I might give it a swing and break things good and proper, so I'll call it solved for now.

351 posts

Ultimate Geek
+1 received by user: 71


  Reply # 1973575 12-Mar-2018 21:13
Send private message

It certainly seems to be a 2degrees network problem, or a network problem at auckland.megaport.com - is that a CDN?.  I have a 1000/500 connection with 2degrees from Palmerston North, using an Edgerouter Lite.  My PPPoE connection is using the overprovisioning, so I get full MTU 1500 packets over it.  These are what happens on my Linux box:

 

root@mypvr:~/temp# wget -4 http://us.download.nvidia.com/Windows/391.01/391.01-desktop-win10-64bit-international-whql.exe
--2018-03-12 20:23:25-- http://us.download.nvidia.com/Windows/391.01/391.01-desktop-win10-64bit-international-whql.exe
Resolving us.download.nvidia.com (us.download.nvidia.com)... 192.229.232.112
Connecting to us.download.nvidia.com (us.download.nvidia.com)|192.229.232.112|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 454628704 (434M) [application/octet-stream]
Saving to: ‘391.01-desktop-win10-64bit-international-whql.exe’

 

391.01-desktop-win10-64bit-international-whql.exe 100%[=========================================================================================================================>] 433.57M 16.8MB/s in 18s

 

2018-03-12 20:23:43 (23.8 MB/s) - ‘391.01-desktop-win10-64bit-international-whql.exe’ saved [454628704/454628704]

 

root@mypvr:~/temp# wget -6 http://us.download.nvidia.com/Windows/391.01/391.01-desktop-win10-64bit-international-whql.exe
--2018-03-12 20:24:43-- http://us.download.nvidia.com/Windows/391.01/391.01-desktop-win10-64bit-international-whql.exe
Resolving us.download.nvidia.com (us.download.nvidia.com)... 2606:2800:247:2063:46e:21d:825:102e
Connecting to us.download.nvidia.com (us.download.nvidia.com)|2606:2800:247:2063:46e:21d:825:102e|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 454628704 (434M) [application/octet-stream]
Saving to: ‘391.01-desktop-win10-64bit-international-whql.exe’

 

391.01-desktop-win10-64bit-international-whql.exe 0%[ ] 3.12M 285KB/s eta 25m 37s

 

Since I did not want to wait 25 minutes, I killed the download.

 

root@mypvr:~/temp# traceroute --resolve-hostnames us.download.nvidia.com
traceroute to cs5341561.wpc.phicdn.net (192.229.232.112), 64 hops max
1 10.0.2.251 (erlg.jsw.gen.nz) 0.297ms 0.290ms 0.262ms
2 111.69.7.104 (104.7.69.111.static.snap.net.nz) 1.541ms 1.112ms 0.828ms
3 43.243.22.16 (as23655.auckland.megaport.com) 14.096ms 13.662ms 14.522ms
4 43.243.22.48 (as15133.auckland.megaport.com) 14.580ms 14.174ms 14.259ms
5 192.229.232.112 (192.229.232.112) 14.322ms 14.210ms 14.317ms

 

root@mypvr:~/temp# traceroute6 us.download.nvidia.com
traceroute to cs5341561.wpc.phicdn.net (2606:2800:247:2063:46e:21d:825:102e) from 2406:e001:1:2802::4, port 33434, from port 37979, 30 hops max, 60 bytes packets
1 erlg.6.jsw.gen.nz (2406:e001:1:2802::251) 0.411 ms 0.320 ms 0.288 ms
2 2406:e000:2801:17::1 (2406:e000:2801:17::1) 1.311 ms 1.458 ms 1.915 ms
3 as23655.auckland.megaport.com (2001:dea:0:40::10) 14.445 ms 15.133 ms 15.209 ms
4 as15133.auckland.megaport.com (2001:dea:0:40::30) 15.014 ms 14.418 ms 14.122 ms
5 2606:2800:247:2063:46e:21d:825:102e (2606:2800:247:2063:46e:21d:825:102e) 14.223 ms 13.984 ms 14.081 ms

 

The ping times are almost identical, but the download speeds anything but!  The ping times suggest that the traffic originates in New Zealand - pings to as23655.sydney.megaport.com take 36 ms.


81 posts

Master Geek
+1 received by user: 9

Subscriber

  Reply # 1973623 12-Mar-2018 22:36
Send private message

FWIW, I'm seeing slow d/l from update.dbankcdn.com, which is also 1 hop beyond as15133.auckland.megaport.com on a traceroute. Equally slow on IPv4 and v6. This is updating a Huawei phone.

282 posts

Ultimate Geek
+1 received by user: 23

Lifetime subscriber

  Reply # 1973666 12-Mar-2018 23:29
Send private message

I have a ticket open regarding this issue that is currently being escalated. Support has been good to deal with so far.

 

I've been able to reproduce this problem with 2 routers and a direct PPPoE connection to a Windows 10 laptop. Testing has been done with both standard and 1500 MTU settings. I know of two other 2degrees customers that also have IPv6 downloads capped to around 3Mbps.

 

 

 

Here are a couple more examples of slow downloads - both NZ based:

 

http://mirror.fsmg.org.nz/centos/7/isos/x86_64/CentOS-7-x86_64-Everything-1708.iso

 

- Mentioned elsewhere on this forum
- Traffic transits AKL IX

 


https://downloads.pwnedpasswords.com/passwords/pwned-passwords-2.0.txt.7z

 

- Cloudflare via AKL IX
- Note that this isn't a dodgy download. It is a list of compromised passwords supplied by Troy Hunt @ https://haveibeenpwned.com

 

 

 

There is a speed test website hosted on the Cloudflare CDN that is a good way to show the performance difference. It is available at cfspeed.com

 

While it isn't the prettiest looking website, it clearly shows the performance difference when connecting via IPv4 vs IPv6. 


141 posts

Master Geek
+1 received by user: 40


  Reply # 1973988 13-Mar-2018 14:10
Send private message

toejam316:
sorceror:

 

toejam316:

 

 

 

Yep, just got around to turning off IPv6 on my WAN and verifying, that is indeed the issue.

 

 

 

Seems like a really major issue for the helpdesk to NOT be aware, and hilariously they were implying the issue was that I wasn't using the fritz!box...

 

 

 

 

 

 

 

 

 

 

turning IPv6 off is lazy advice. you still don't know if the issue was with 2degrees or your router or your PC or the server or w/e.

 

 

 

chances are the helpdesk was correct tbh

 


I do know though, the issue is with 2degrees IPv6 implementation, it's been proven by my fault resolution and verified as a know issue by some well informed users previous to your post.
I'm not actually able to troubleshoot 2degrees core network, although if they'd pay me to go and do so, I might give it a swing and break things good and proper, so I'll call it solved for now.

 

except it's not, because if it was an IPv6 implementation issue all traffic would be affected, not just IPv6 traffic going via AKL-IX. 

 

how does that saying go, everything looks like a nail if all you have is a hammer.




644 posts

Ultimate Geek
+1 received by user: 176


  Reply # 1974004 13-Mar-2018 14:22
Send private message

sorceror:


except it's not, because if it was an IPv6 implementation issue all traffic would be affected, not just IPv6 traffic going via AKL-IX. 


how does that saying go, everything looks like a nail if all you have is a hammer.


I feel like you're missing the bit where the error has been proven into the IPv6 implementation of 2Degrees and out of my local network, making it an issue outside the scope of what I can resolve.
As 2degrees aren't paying me to resolve the issue and I have a work around.
If you can make changes to 2degrees and their partners network, feel free to continue troubleshooting and implement a solution.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft Dynamics 365 Business Central launches
Posted 10-Jul-2018 10:40


Spark completes first milestone in voice platform upgrade
Posted 10-Jul-2018 09:36


Microsoft ices heated developers
Posted 6-Jul-2018 20:16


PB Technologies charged for its extended warranties and warned for bait advertising
Posted 3-Jul-2018 15:45


Almost 20,000 people claim credits from Spark
Posted 29-Jun-2018 10:40


Cove sells NZ's first insurance policy via chatbot
Posted 25-Jun-2018 10:04


N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.