Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 
2940 posts

Uber Geek
+1 received by user: 406


  # 2245434 25-May-2019 16:27
Send private message quote this post

I think there is a slight delay with wifi calling. I did a test call now over same wifi network from iPhone to a Huawei P30, took about 3 seconds before iPhone had the dial tone and then another 2 sec for the other phone to start ringing.

4892 posts

Uber Geek
+1 received by user: 2881

Trusted
Lifetime subscriber

  # 2245445 25-May-2019 16:56
Send private message quote this post

Think they meant delay in voice not call setup

 
 
 
 


3117 posts

Uber Geek
+1 received by user: 335

Subscriber

  # 2245446 25-May-2019 16:57
Send private message quote this post

CYaBro:
Linux: Just cause the iPhones don't have any other Wi-Fi issues means nothing as Wi-Fi calling sets up a VPN back into the 2degrees IMS platform and the AP might be dropping this connection

There is more to Wi-Fi calling than you think


Yes I know that, just thought I’d mention that there’s no other wifi issues with the phones.
So where does one find that setting you mentioned on a unifi controller?

 

 

 

Nevermind, found it and have enabled it now so will see how it goes.

 

Will report back.




352 posts

Ultimate Geek
+1 received by user: 146


  # 2245533 25-May-2019 21:09
Send private message quote this post

tardtasticx: I think there is a slight delay with wifi calling. I did a test call now over same wifi network from iPhone to a Huawei P30, took about 3 seconds before iPhone had the dial tone and then another 2 sec for the other phone to start ringing.

 

 

 

That is the issue.




352 posts

Ultimate Geek
+1 received by user: 146


  # 2245770 26-May-2019 08:56
Send private message quote this post

I am also getting this message quite a bit in the Fritzbox logs.....it was a copy and paste. I assume this is normal?

 

"

 

5-GHz band cannot be used for [number] min. because of check for higher-priority users (e.g. RADAR) on the selected channel (frequency [GHz])." 


449 posts

Ultimate Geek
+1 received by user: 98


  # 2246234 26-May-2019 22:57
Send private message quote this post

Bluntj:

 

I am also getting this message quite a bit in the Fritzbox logs.....it was a copy and paste. I assume this is normal?

 

"

 

5-GHz band cannot be used for [number] min. because of check for higher-priority users (e.g. RADAR) on the selected channel (frequency [GHz])." 

 

 

Quite a few or the 5 GHz channel frequencies are used for radar also, and it is a requirement of WiFi that is using those frequencies that they stop when they detect a radar in use.  NZ has a law setting out those requirements.  So if you have set your 5 GHz WiFi to use one of those channels, then you will see this happening.  It is better to use the other frequencies not allocated to radar, unless you know you are in an area where those radar frequencies are not used.  Or you can try just letting the router choose the frequency automatically so it can change frequency when it detects a radar.  But it really is better not to interfere with the radars at all - we really need them to be working properly.  Here is a table which shows the channel frequencies and how the channels are used when you use multiple channels (by setting your router to use greater than the standard 20 MHz bandwidth):

 

https://en.wikipedia.org/wiki/List_of_WLAN_channels#5_GHz_(802.11a/h/j/n/ac/ax)

 

All the radar channels are marked as "DFS" and should be avoided.  As 5 GHz does not travel nearly as far through things as 2.4 GHz, you will often find that you can use the same channels as your neighbours without any problems, as long as both of you are only using indoor WiFi.  With 2.4 GHz, you often need to avoid channels your neighbours are using.


3117 posts

Uber Geek
+1 received by user: 335

Subscriber

  # 2246236 26-May-2019 23:24
Send private message quote this post

So after a day of having that setting enabled it hasn’t made any difference.
Wifi calling still dropping off and have to turn the wifi on the iPhones off and on again to get it going again.

 
 
 
 


Mr Snotty
8728 posts

Uber Geek
+1 received by user: 4635

Moderator
Trusted
Lifetime subscriber

  # 2246239 26-May-2019 23:37
Send private message quote this post

CYaBro: So after a day of having that setting enabled it hasn’t made any difference.
Wifi calling still dropping off and have to turn the wifi on the iPhones off and on again to get it going again.

 

You running the latest UniFi controller version?

 

Under your wireless network settings for all SSID's ensure the following is enabled:
Enable Unscheduled Automatic Power Save Delivery
Connects high performance clients to 5 GHz only

 

Under the access point settings enable band steering to 5GHz is also enabled.

 

Also, for testing, create another SSID locked to 5GHz only. To do this just simply create a new SSID and under the access point settings itself disable it under the 2.4GHz band.

 

What router are you using also? I use this feature all the time on sites I've set up. I've even used WiFi Calling via Satellite in the middle of nowhere and never once had issues. All the issues I've seen have been caused on the clients side normally with misconfiguration of either their access point or their routers.

 

Also, despite me having near perfect mobile coverage at home I use it here also. I have multi-hour calls without any drop-outs and never once had a call not come through. I'm using an iPhone XS Max.





3117 posts

Uber Geek
+1 received by user: 335

Subscriber

  # 2246297 27-May-2019 09:25
Send private message quote this post

michaelmurfy:

 

CYaBro: So after a day of having that setting enabled it hasn’t made any difference.
Wifi calling still dropping off and have to turn the wifi on the iPhones off and on again to get it going again.

 

You running the latest UniFi controller version?

 

Under your wireless network settings for all SSID's ensure the following is enabled:
Enable Unscheduled Automatic Power Save Delivery
Connects high performance clients to 5 GHz only

 

Under the access point settings enable band steering to 5GHz is also enabled.

 

Also, for testing, create another SSID locked to 5GHz only. To do this just simply create a new SSID and under the access point settings itself disable it under the 2.4GHz band.

 

What router are you using also? I use this feature all the time on sites I've set up. I've even used WiFi Calling via Satellite in the middle of nowhere and never once had issues. All the issues I've seen have been caused on the clients side normally with misconfiguration of either their access point or their routers.

 

Also, despite me having near perfect mobile coverage at home I use it here also. I have multi-hour calls without any drop-outs and never once had a call not come through. I'm using an iPhone XS Max.

 

 

 

 

Thanks I've made those changes so will see how it goes today.

 

Unifi controller is running 5.10.20, haven't upgraded to 5.10.23 yet but did update the firmware on the devices the other day to the latest version offered.

 

We have no router as the WISP takes care of that with their Ubiquiti unit on the roof. We have no access to it.
They were the ones that recommended 2degrees for the wifi calling so I assume they, and other customer's of theirs, use it without any issues otherwise they wouldn't have recommended it.
We get around 10mbps down and 2mbps up.

 

When we're actually on a wifi call that connects correctly it works great and there are no dropouts, it's just when the iPhones are not in use that it seems to stop working.


350 posts

Ultimate Geek
+1 received by user: 90


  # 2246305 27-May-2019 09:38
One person supports this post
Send private message quote this post

have you patched the iphone? 12.3.1 notes say

 

  • Fixes an issue that could prevent making or receiving VoLTE calls

not wifi calling, but might use some of the same code.


3117 posts

Uber Geek
+1 received by user: 335

Subscriber

  # 2246310 27-May-2019 09:59
Send private message quote this post

bagheera:

 

have you patched the iphone? 12.3.1 notes say

 

  • Fixes an issue that could prevent making or receiving VoLTE calls

not wifi calling, but might use some of the same code.

 

 

I thought I had but computer says 'no' so doing that now too, thanks!


3117 posts

Uber Geek
+1 received by user: 335

Subscriber

  # 2247557 29-May-2019 09:50
Send private message quote this post

Update: So after making all the changes suggested the wifi calling is better but it does still drop off but not as much as it was.

 

What also seems to be happening now is that at least it appears to reconnect by itself if it does drop off.

 

Had an example of this yesterday where my wife tried calling my mobile but it went straight to voicemail.
She then called the desk phone, which is a 2talk voip line, and we spoke for a couple of minutes.
While on this call my mobile got the SMS that I'd missed a call from my wife.
We hung up but then she forgot something and called my mobile again and this time it rang and we were able to talk on that.

 

So thanks for the suggestions, hopefully it continues to work in this better state now.

 

Of course no drop outs at all would be better again.


3117 posts

Uber Geek
+1 received by user: 335

Subscriber

  # 2251259 4-Jun-2019 14:56
Send private message quote this post

Just another update on this.

 

I found a generic wifi router in the cupboard (Netgear) which I setup.

 

I've been running my iPhone on this AP today and the 2degrees wifi calling hasn't disconnected once so it looks like it's an issue with the Unifi APs.

 

Going to have to do some more troubleshooting with those and see if I can fix it.


3117 posts

Uber Geek
+1 received by user: 335

Subscriber

  # 2256520 12-Jun-2019 10:06
Send private message quote this post

Another update on this.

 

Staying at my parents place where they have a nice fast fibre connection.

 

Asus router with wifi.

 

Wifi calling hasn't dropped off (that I've noticed anyway) and incoming calls ring but I can't hear the caller. They could hear me.

 

Switch off wifi and to connect back to cell signal and incoming calls work fine again.

 

So don't think this is an issue with the Unifi APs I have at home.

 

Looks like unreliable wifi calling service for issues to be happening in more than one location and on more than one device.


1 | 2 
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21


Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36


Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57


Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48


New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.