Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


stocksp

523 posts

Ultimate Geek

Lifetime subscriber

#258537 8-Oct-2019 18:46
Send private message

Got 2degrees fibre today.  Good job by chorus who put the ONT exactly where I wanted it, and when I wasn't getting the right speeds, a quick call to 2D had the provisioning sorted within 5 mins (inclusive of call waiting times).  Loving this.

 

 

 

Now I have to try and cancel VF - 20 mins on hold so far.  THIS IS WHY PEOPLE LEAVE VF.  It's also clearly their way of not letting you.

 

 

 

What a contrast between the 2 providers.






Create new topic
stocksp

523 posts

Ultimate Geek

Lifetime subscriber

  #2333098 8-Oct-2019 22:24
Send private message

However I am having trouble getting IP6 working with my edgerouter 4    

 

 

 

Anyone have any suggestions?  Ive tried following michaelmurphys tutorial, and using the wizard - but no luck so far






Scott3
1149 posts

Uber Geek

Lifetime subscriber

  #2333100 8-Oct-2019 22:33
Send private message

Expect Vodafone to charge for another month, as per their terms and conditions.


 
 
 
 


stocksp

523 posts

Ultimate Geek

Lifetime subscriber

  #2333102 8-Oct-2019 22:51
Send private message

Its worth it to escape their grasp :)






NickMack
717 posts

Ultimate Geek

Trusted
Lifetime subscriber

  #2333450 9-Oct-2019 16:51
Send private message

stocksp:

 

However I am having trouble getting IP6 working with my edgerouter 4    

 

 

 

Anyone have any suggestions?  Ive tried following michaelmurphys tutorial, and using the wizard - but no luck so far

 

 

 

 

https://www.geekzone.co.nz/forums.asp?forumid=66&topicid=205740





stocksp

523 posts

Ultimate Geek

Lifetime subscriber

  #2333451 9-Oct-2019 16:54
Send private message

NickMack:

 

stocksp:

 

However I am having trouble getting IP6 working with my edgerouter 4    

 

 

 

Anyone have any suggestions?  Ive tried following michaelmurphys tutorial, and using the wizard - but no luck so far

 

 

 

 

https://www.geekzone.co.nz/forums.asp?forumid=66&topicid=205740

 

 

 

 

Thanks Nick. I tried following MichaelMurphys IPV6 instructions, but it didn’t seem to work and left we with no connectivity so had to revert (his guide is great but I am not)






NickMack
717 posts

Ultimate Geek

Trusted
Lifetime subscriber

  #2333452 9-Oct-2019 16:57
Send private message

Strange, many people have used this to configure, might be worth going through again to make sure you didn't miss anything. 





iamsammajor
280 posts

Ultimate Geek

Subscriber

  #2333690 10-Oct-2019 09:35
Send private message

stocksp:


NickMack:


stocksp:


However I am having trouble getting IP6 working with my edgerouter 4    


 


Anyone have any suggestions?  Ive tried following michaelmurphys tutorial, and using the wizard - but no luck so far



 


https://www.geekzone.co.nz/forums.asp?forumid=66&topicid=205740



 


Thanks Nick. I tried following MichaelMurphys IPV6 instructions, but it didn’t seem to work and left we with no connectivity so had to revert (his guide is great but I am not)



 


set interfaces ethernet eth0 vif 10 pppoe 0 ipv6 enable
edit interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd pd 0
set prefix-length /56
set interface eth1 host-address ::1
set interface eth1 prefix-id :0
set interface eth1 service slaac
top
set interfaces ethernet eth0 pppoe 0 dhcpv6-pd prefix-only (does this miss vif 10 for 2D config)
commit
save


maybe worth a look at this


 


 
 
 
 


evilonenz
/dev/urandom
152 posts

Master Geek

Lifetime subscriber

  #2333694 10-Oct-2019 09:47
Send private message

Looks like this is what I have on my ERLite-3 for IPv6, working perfectly.

 

 

set firewall ipv6-name WAN6_IN default-action drop
set firewall ipv6-name WAN6_IN description 'WAN6 to internal'
set firewall ipv6-name WAN6_IN rule 10 action accept
set firewall ipv6-name WAN6_IN rule 10 description 'Allow established/related'
set firewall ipv6-name WAN6_IN rule 10 state established enable
set firewall ipv6-name WAN6_IN rule 10 state related enable
set firewall ipv6-name WAN6_IN rule 20 action drop
set firewall ipv6-name WAN6_IN rule 20 description 'Drop invalid packets'
set firewall ipv6-name WAN6_IN rule 20 state invalid enable
set firewall ipv6-name WAN6_IN rule 30 action accept
set firewall ipv6-name WAN6_IN rule 30 description 'Allow ICMPv6'
set firewall ipv6-name WAN6_IN rule 30 protocol icmpv6
set firewall ipv6-name WAN6_LOCAL default-action drop
set firewall ipv6-name WAN6_LOCAL description 'WAN6 to router'
set firewall ipv6-name WAN6_LOCAL rule 10 action accept
set firewall ipv6-name WAN6_LOCAL rule 10 description 'Allow established/related'
set firewall ipv6-name WAN6_LOCAL rule 10 state established enable
set firewall ipv6-name WAN6_LOCAL rule 10 state related enable
set firewall ipv6-name WAN6_LOCAL rule 20 action drop
set firewall ipv6-name WAN6_LOCAL rule 20 description 'Drop invalid packets'
set firewall ipv6-name WAN6_LOCAL rule 20 state invalid enable
set firewall ipv6-name WAN6_LOCAL rule 30 action accept
set firewall ipv6-name WAN6_LOCAL rule 30 description 'Allow ICMPv6'
set firewall ipv6-name WAN6_LOCAL rule 30 protocol icmpv6
set firewall ipv6-name WAN6_LOCAL rule 40 action accept
set firewall ipv6-name WAN6_LOCAL rule 40 description 'Allow DHCPv6 client/server'
set firewall ipv6-name WAN6_LOCAL rule 40 destination port 546
set firewall ipv6-name WAN6_LOCAL rule 40 protocol udp
set firewall ipv6-name WAN6_LOCAL rule 40 source port 547
set firewall ipv6-receive-redirects disable
set firewall ipv6-src-route disable
set firewall ip-src-route disableset interfaces ethernet eth0 vif 10 pppoe 0 ipv6 enable
set interfaces ethernet eth0 vif 10 pppoe 0 ipv6 dup-addr-detect-transmits 1
set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd pd 0 interface eth1 host-address '::1'
set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd pd 0 interface eth1 prefix-id ':0'
set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd pd 0 interface eth1 service slaac
set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd pd 0 prefix-length 56
set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd prefix-only
set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd rapid-commit enable
set interfaces ethernet eth0 vif 10 pppoe 0 firewall in ipv6-name WAN6_IN
set interfaces ethernet eth0 vif 10 pppoe 0 firewall local ipv6-name WAN6_LOCAL


NickMack
717 posts

Ultimate Geek

Trusted
Lifetime subscriber

  #2333756 10-Oct-2019 10:07
Send private message

Are you both running the same firmware? :-) There is a bunch of bugs from memory on some firmwares for that device @MMurfy





stocksp

523 posts

Ultimate Geek

Lifetime subscriber

  #2335959 12-Oct-2019 13:54
Send private message

NickMack:

 

Are you both running the same firmware? :-) There is a bunch of bugs from memory on some firmwares for that device @MMurfy

 

 

 

 

Hmm 

 

 

 

tried all that.  The original issue was the missing VIF 10 as suggested above.  So I have IP4 connectivity, but no IP6 - I suspect its the firewall.

 

 

 

My firmware is EdgeRouter 4 v1.10.9






stocksp

523 posts

Ultimate Geek

Lifetime subscriber

  #2336208 13-Oct-2019 10:44
Send private message

And one more try this morning - and its working :).  Thanks to @MMurphy

 

 

 

 

 

One thing I did note, I had updated my mac to Catalina - and this seemed to disable ipv6 by default??  Only worked this out once a I tried other devices that were showing IPv6, and checked out the mac network settings.  






Create new topic





News »

Huawei launches IdeaHub Pro in New Zealand
Posted 27-Oct-2020 16:41


Southland-based IT specialist providing virtual services worldwide
Posted 27-Oct-2020 15:55


NASA discovers water on sunlit surface of Moon
Posted 27-Oct-2020 08:30


Huawei introduces new features to Petal Search, Maps and Docs
Posted 26-Oct-2020 18:05


Nokia selected by NASA to build first ever cellular network on the Moon
Posted 21-Oct-2020 08:34


Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.