Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


14208 posts

Uber Geek
+1 received by user: 2570

Trusted
Subscriber

Topic # 68823 28-Sep-2010 22:56
Send private message

I got the Huawei E585 today, primarily to let me go online with my iPod Touch from anywhere I like. It was originally purchased to be used on the 3 network in the UK, but it had been unlocked to work on any network before I purchased it. I got it for $200 from trademe, compared with $275 for the earlier model which can be sourced directly from 2degrees.

2degreees Setup
I had a 2 degrees SIM that i'd used before to send a couple of txts, but hadn't used for data. It took me a half hour or so and a phone call to sign up for their online service, add credit, and buy a data pack, which seems reasonable.

Device Setup
It took me an hour or so to get it working on my PC, and configure it for the 2degrees network. The main trick was to unplug my existing network connection, so all dns and data had to go through the USB modem. I did initially try with my only WiFi device, and iPod Touch, but you need to go into the full control panel to set up the mobile provider and that was much easier with a full keyboard and large screen. The setup menu isn't entirely intuitive, but it's not too bad either.

The key settings are:
 - No authorisation
 - Blank username and password
 - APN of "2degrees". The helpdesk told me to use "internet", but that didn't work, luckily I found the proper one here on Geekzone.

Performance
I've only used it a little, but so far the performance is great. For email, web browsing, facebook mobile app, and rss feeds the speed is comparable to the speed of my TelstraClear cable connection via my WiFi router. It might be a little slower, but it's barely noticeable.

Data is used more quickly than I expected. I opened NZHerald mobile and looked at one story, opened cnet news mobile, ran the facebook app and looked at one friends image, then updated my rss feeds (which wasn't done that long ago anyway) and I used 1MB of data. That's not much data, really, but given I bought a 512MB pack for $20 (doubled to 1GB as some online bonus) it might cost a little more than I expected to stay connected.

I also ran the www.speedtest.net test from my PC, while it was connected via USB2.0 to the router, the results are below (not that i'm in Wellington).




I ran the speed test iPhone app from my iPod Touch 2G, and got the following results:
 - Auckland server: 394ms ping, 1.27Mbps download, 0.31Mbps upload
 - Wellington server: 607ms ping, 1.66Mbps download, 0.29Mbps upload

Initial Conclusion (after about 15 minutes real world use)
So far i'm very happy with both the device and the performance of the 2degrees network. Once i've used it for a couple of weeks i'll post an update, if I remember.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2

n4

956 posts

Ultimate Geek
+1 received by user: 74


  Reply # 385691 28-Sep-2010 23:38
Send private message

The internet APN should work, 2degrees should only be necessary if you're trying to configure a proxy. The internet APN does not require/use the proxy.




Huawei Mate 7, on 2degrees



14208 posts

Uber Geek
+1 received by user: 2570

Trusted
Subscriber

  Reply # 385747 29-Sep-2010 09:40
Send private message

Would you mind explaining that a little more n4? The device I have the sim in is essentially a proxy itself, but whether I go direct or via another proxy doesn't seem too important.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


310 posts

Ultimate Geek

Trusted

  Reply # 385762 29-Sep-2010 10:18
Send private message

the "2degrees" APN is for when using 2degrees services such as WAP and MMS etc. you will be assigned a private IP address e.g. 192.168.X.X or 10.X.X.X it can also just be used for internet access but some things may not work that well as you are behind NAT.
the "internet" APN is for internet just like you would expect, you will be assigned a public IP e.g. 118.148.130.5 and you will have full unrestricted access to/from the internet to your device so things like P2P and VPN access to your device will not be an issue.

if you leave the APN as blank and are within 2degrees own network coverage you will be automatically connected to the "internet" APN, but if you start roaming on Vodafone you will not connect as they don't provide the auto complete service. Therefore it is best to set the APN to whichever service you want to use.







Any posts are personal comments and not that of my employer



14208 posts

Uber Geek
+1 received by user: 2570

Trusted
Subscriber

  Reply # 385769 29-Sep-2010 10:41
Send private message

Thanks pwner, I tried the "internet" apn and it works just as well. It just takes a little while to get to the first website, I guess it's doing initialisation or something. I'd edit my post but I don't think I can.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


310 posts

Ultimate Geek

Trusted

  Reply # 385775 29-Sep-2010 11:04
Send private message

timmmay: Thanks pwner, I tried the "internet" apn and it works just as well. It just takes a little while to get to the first website, I guess it's doing initialisation or something. I'd edit my post but I don't think I can.


if anything the internet APN should be faster, you may need to check to make sure you don't have any old DNS servers set up statically in the setup. apart from that i can't think why the first website would be slower apart from HSDPA code allocation but that is pretty quick.




Any posts are personal comments and not that of my employer



14208 posts

Uber Geek
+1 received by user: 2570

Trusted
Subscriber

  Reply # 386006 29-Sep-2010 19:21
Send private message

It was probably just my perception of the speed, that it was slower. It only takes about 20 seconds to turn the device on and have it ready to go on 2degrees.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


4025 posts

Uber Geek
+1 received by user: 1076

Trusted

  Reply # 386013 29-Sep-2010 19:38
Send private message

Interesting write up.

on XT when wifi tethering with my Desire (essentially the same effect as this) i get 70 ping nationally with 2mbit-4.5mbit depending on signal strength.
Your ping times seem very high in comparison.



14208 posts

Uber Geek
+1 received by user: 2570

Trusted
Subscriber

  Reply # 386025 29-Sep-2010 19:50
Send private message

I'm in Johnsonville at the moment, i'll try it next time i'm in central Wellington, maybe there's a difference.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


39 posts

Geek
+1 received by user: 3


  Reply # 389397 8-Oct-2010 01:22
Send private message

ok so the box says i can connect gaming consols via the router but on my nintendo ds, it says the routers security settings wont allow the connection. Can i get around it?



14208 posts

Uber Geek
+1 received by user: 2570

Trusted
Subscriber

  Reply # 389411 8-Oct-2010 07:59
Send private message

On the E585? I have no idea. It works perfect with my iPod Touch, and I expect it'd work fine with any WiFi device. I haven't seen any security settings that would limit gaming.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


39 posts

Geek
+1 received by user: 3


  Reply # 389421 8-Oct-2010 08:49
Send private message

Yes on the E585.

 I think it has something to do with WPA vs WEP but i have no idea how to change to WEP passkey

Any clues?



14208 posts

Uber Geek
+1 received by user: 2570

Trusted
Subscriber

  Reply # 389437 8-Oct-2010 09:29
Send private message

Just go into the control panel, find the advanced settings, and you can change any of the regular stuff you can change on a WiFi router - encrpytion type, password, etc. It takes a little digging, and it's easier on a computer with a big screen, I can't check the path to the preference right now as all I have handy is my iTouch and you can't change those preferences in the "lite" version of the control panel. You can get into the full version of the control panel on the iTouch, it's just annoying to use.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


39 posts

Geek
+1 received by user: 3


  Reply # 389440 8-Oct-2010 09:32
Send private message

Yeah I tried doing that but i must have done something wrong because then my laptop wouldnt connect and said the settings didnt match the connection or something lol Im rather vague but when ill get a chance Ill try and again and be a bit more descriptive with the problem



14208 posts

Uber Geek
+1 received by user: 2570

Trusted
Subscriber

  Reply # 389446 8-Oct-2010 09:40
Send private message

Once you can describe what you're trhing to do, the problem, and the error messages, I can probably help.

Try WEP as your security. It's pretty poor security, but good enough unless someone is actively trying to use your connection.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


39 posts

Geek
+1 received by user: 3


  Reply # 389452 8-Oct-2010 09:48
Send private message

ok so i need to switch to WEP security to connect my DS to the internet.

So i tried to change the settings via Wireless Network Properties and I changed security type WPA Personal to no authentication (open) and then I had problems with the network security settings.
 I changed it then my laptop wouldnt connect at all as the settings didnt match (Im not changeing it again to try and remember what exactly it said)
Is this what I meant to do? I was just playing around lol



Does doing anything here help?

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.