Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


8 posts

Wannabe Geek


Topic # 80769 4-Apr-2011 10:11
Send private message

After daylight savings changed I have the problem that all of my received messages have the received time wrong by one hour.
For example, if I receive a message at 10am it will appear to have been received at 9am, and will get sorted in a conversation before any messages I have sent after 9am.

Is this a problem that other 2degrees users are having? I have the time set to automatically update, but I tried changing it to manual mode which did not fix the problem.


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
13918 posts

Uber Geek
+1 received by user: 2471

Trusted
Subscriber

  Reply # 455022 4-Apr-2011 10:18
Send private message

Try setting the time zone of your phone. With my Nokia I went into settings and told it daylight savings was over and times appear correct on Vodafone.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


2627 posts

Uber Geek
+1 received by user: 503


  Reply # 455024 4-Apr-2011 10:21
Send private message

I turned my phone on this morning and then just turned the key guard on and thought no more of it.

I just unlocked it now to check the time and it said - the time has changed - do you want to update it - I selected ok and its showing the correct time now.

I did not have my phone on at the weekend. I assume their system is working.

Havent tried sending txts.




Nothing is impossible for the man who doesn't have to do it himself - A. H. Weiler



8 posts

Wannabe Geek


  Reply # 455028 4-Apr-2011 10:26
Send private message

Thanks for the advice. I can indeed fix the problem by changing the time zone, but it causes other problems.
The phone by default has the time zone correct. However, if I set it to the wrong time zone I can fix the sms issue but it causes
emails and calendar events to have the wrong time as their time is "correct" and the phone is then technically off by one hour.

BDFL - Memuneh
60603 posts

Uber Geek
+1 received by user: 11535

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 455030 4-Apr-2011 10:30
Send private message

You don't have to change the timezone, but just set DST on/off.

You didn't say what handset it is, what OS, etc, so not much more help can be provided...






8 posts

Wannabe Geek


  Reply # 455032 4-Apr-2011 10:35
Send private message

I had hoped that the problem was with the 2degrees time stamping but if others do not have the same problem then it must be the phone itself. It is a desire hd running android 2.2.

446 posts

Ultimate Geek
+1 received by user: 47


  Reply # 455042 4-Apr-2011 11:11
Send private message

I've had at least 2 others comment on the same issue, both on android devices



8 posts

Wannabe Geek


  Reply # 455048 4-Apr-2011 11:30
Send private message

Perhaps then it is an Android issue, but it also seems related to 2degrees. I have checked with people with the same phone and OS on vodafone and they do not have the problem. I know one person on 2degrees running 2.2 who has the problem and another running 2.3 on 2degrees who does not see the problem.

The time zone is correctly configured to gmt+12 (nzst is gmt+12 and daylight time is gmt+13). The texts arrive with the correct time if I manually turn the phone back to summer daylight saving time (gmt+13), but that is not a very good solution.

1020 posts

Uber Geek
+1 received by user: 106


  Reply # 455050 4-Apr-2011 11:35
Send private message

Mine's OK although I've got my Date and Time settings set to Automatic, can't think why you wouldn't.

Ideos X5 on 2Degrees



8 posts

Wannabe Geek


  Reply # 455053 4-Apr-2011 11:42
Send private message

Mine was set to automatic, but I experimented with other settings after I noticed this problem.

Which version of Android are you running? Perhaps there is an issue in 2.2 that is fixed in 2.3

1020 posts

Uber Geek
+1 received by user: 106


  Reply # 455057 4-Apr-2011 11:54
Send private message

2.2

2431 posts

Uber Geek
+1 received by user: 143


  Reply # 455059 4-Apr-2011 11:56
Send private message

My HTC Desire Z (running a custom 2.2 ROM, on vodafone) changed over just fine.

3 posts

Wannabe Geek


  Reply # 455068 4-Apr-2011 12:13
Send private message

Same issue here, really annoying trying to quickly read texts when they get placed far behind in the list.

HTC Desire running stock 2.2 on 2degrees



8 posts

Wannabe Geek


  Reply # 455072 4-Apr-2011 12:28
Send private message

Yes, it is a serious problem. I am not even sure why phones use the network time stamp for text messages. Why not just set the "time received" to the time the phone actually receives the message?

I see there is a market app called "SMS Time Fix" which appears to address this issue, though I haven't actually tried it.


446 posts

Ultimate Geek
+1 received by user: 47


  Reply # 455082 4-Apr-2011 12:43
Send private message

Just had a phone in my hand which was a boring old lg (not android) having the same issue - on 2degrees also

n4

955 posts

Ultimate Geek
+1 received by user: 73


  Reply # 455091 4-Apr-2011 13:11
Send private message

For those having the issue - is the phone time/date correct, is the timezone correct (GMT+12), have you restarted the phone since the daylight saving switch, and does it affect messages from all networks towards 2degrees, or just 2degrees-2degrees?

I'm not seeing a problem (Android 2.2), my phone gets the time/date/zone from the network.




Huawei Mate 7, on 2degrees

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07


All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21


Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54


Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15


IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.