Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




7 posts

Wannabe Geek


Topic # 82908 7-May-2011 15:02
Send private message

Hi

I just wondered if anyone could shed any light on a problem I have with my new phone.  I have an X10 Mini pro which was purchased from Vodafone and while I can use it for calls and texts it will not connect to the internet.
I have called 2 degrees and they have advised I have the APN settings correct and the phone is compatible and they think the phone may be faulty.   However, I just put a friends Vodafone sim in the phone and it worked perfectly upon turning it on without having to make any manual changes at all.
I really don't want to A: Get another phone or B: Go back to Vodafone.
I would really appreciate any tips anyone may have.

Thanks in advance
Ann

Create new topic
136 posts

Master Geek
+1 received by user: 11


  Reply # 466475 7-May-2011 15:15
Send private message

If the internet worked fine when you put a vodafone SIM in it without changing any settings, I'd say you have the APN set wrong.

Can you post what you've got it set to?



7 posts

Wannabe Geek


  Reply # 466480 7-May-2011 15:37
Send private message

Thank you for your reply.

This is what the guy on the phone at 2 deg gave me:

Name:  2degree internet
APN:     internet
Proxy:
Port:
Username:
Password:
Server:
MMSC:
MMS Proxy:
MMS Port:
MCC:    He said nothing in here but automatically comes up with 530
MNC:    Again said nothing but has 24
Authentication tpe:
APN type:  default

He also had me enter another APN as below:

Name:     2degreeWAP
APN:       2degrees
Proxy:     118.148.1.118
Port:       8080
Username:
Password:
Server:
MMSC:
MMS Proxy:
MMS Port:
MCC:    He said nothing in here but automatically comes up with 530
MNC:    Same as above - 24
Authentication type:
APN type:

I have seen on here the 2 degree APN and tried that as well but nothing entered seems to make a difference.   I thought the phone was the issue but after putting the Vodafone SIM in, now I am unsure what to do.

 
 
 
 


Aussie
3814 posts

Uber Geek
+1 received by user: 968

Trusted
Subscriber

  Reply # 466484 7-May-2011 15:55
Send private message


Yours are completely different and your spacing/missing letters  will make a difference


Name: 2degrees internet
APN: internet
Proxy:
Port:
Username:
Password:
Server:
MMSC:
MMS Proxy:
MMS Port:
MCC: 530
MNC: 24
Authentication Type:
APN Type: default (type this in)

Name: 2degrees MMS
APN: mms
Proxy:
Port:
Username:
Password:
Server:
MMSC: http://mms.2degreesmobile.net.nz:48090
MMS proxy: 118.148.001.118 (take care not to omit the leading zeros)
MMS port: 8080
MCC: 530
MNC: 24
Authentication Type:
APN type: mms (type this in lower case)



7 posts

Wannabe Geek


  Reply # 466488 7-May-2011 16:11
Send private message

Thanks for that.

I have entered the above and still doesnt work.  I turned the phone off after entering the settings and as soon as I turn it back on it comes up with the little symbol that says no connection.
When I click on browser it straight away comes up with a message saying No Internet Connection.

Could it be my SIM card or location???  I seem to get OK reception and had no problems at all with my old phone which was a Nokia E5.


Aussie
3814 posts

Uber Geek
+1 received by user: 968

Trusted
Subscriber

  Reply # 466492 7-May-2011 16:23
Send private message

What version of android is it running? is data turned off somewhere?



7 posts

Wannabe Geek


  Reply # 466494 7-May-2011 16:27
Send private message

Hi, its updated to Android 2.1 and under "Allow the Phone to send and receive data" It is enabled - is that what you mean?

Aussie
3814 posts

Uber Geek
+1 received by user: 968

Trusted
Subscriber

  Reply # 466497 7-May-2011 16:48
Send private message

settings> wireless and networks> mobile networks> data enabled


I cant remember on 2.1 but these are the settings for 2.2



7 posts

Wannabe Geek


  Reply # 466499 7-May-2011 16:57
Send private message

It has two Data settings.

1.  DATA TRAFFIC
Allow the phone to send and receive data - This is Enabled

2.   DATA ROAMING
Connect to data services when roaming - This is not enabled

However, I just tried enabling the data roamng and when it is enabled I can access the internet!  It comes up with a warning message that roaming will incur significant roaming charges.   Should I have the enabled at all times?  My understanding was not to.

Thanks again

Aussie
3814 posts

Uber Geek
+1 received by user: 968

Trusted
Subscriber

  Reply # 466503 7-May-2011 17:11
Send private message

Sounds like you may not be in a 2degrees 3g area

I'm not sure what the data charges are like for 2d running on vodafones network, sorry



7 posts

Wannabe Geek


Reply # 466507 7-May-2011 17:16
Send private message

That would make sense.

Thanks so much for your time

Aussie
3814 posts

Uber Geek
+1 received by user: 968

Trusted
Subscriber

  Reply # 466509 7-May-2011 17:23
Send private message

All good!
that's why we hang out on geekzone! To help and be helped! :D

1262 posts

Uber Geek
+1 received by user: 605


  Reply # 466522 7-May-2011 18:22
Send private message

blakamin: Sounds like you may not be in a 2degrees 3g area

I'm not sure what the data charges are like for 2d running on vodafones network, sorry

There's no extra charge for data when you are roaming onto the vodafone network from 2degrees.  You'll need to buy a national data pack (50MB or 100MB) if you use much data.  Don't forget to turn roaming off if you go overseas



7 posts

Wannabe Geek


  Reply # 466535 7-May-2011 19:06
Send private message

Thanks for that, I have certainly learnt a lot today!
Think I have it sussed now but thanks also or the tip on overseas as well.  That could be an expensive mistake!

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Symantec protects data everywhere with Information Centric Security
Posted 21-Sep-2017 15:33


FUJIFILM introduces X-E3 mirrorless camera with wireless connectivity
Posted 18-Sep-2017 13:53


Vodafone announces new plans with bigger data bundles
Posted 15-Sep-2017 10:51


Skinny launches phone with support for te reo Maori
Posted 14-Sep-2017 08:39


If Vodafone dropping mail worries you, you’re doing online wrong
Posted 11-Sep-2017 13:54


Vodafone New Zealand deploy live 400 gigabit system
Posted 11-Sep-2017 11:07


OPPO camera phones now available at PB Tech
Posted 11-Sep-2017 09:56


Norton Wi-Fi Privacy — Easy, flawed VPN
Posted 11-Sep-2017 09:48


Lenovo reveals new ThinkPad A Series
Posted 8-Sep-2017 14:37


Huawei passes Apple for the first time to capture the second spot globally
Posted 8-Sep-2017 10:45


Vodafone initiative enhances te reo Maori pronunciation on Google Maps
Posted 8-Sep-2017 10:40


Voyager Internet expand local internet phone services company with Conversant acquisition
Posted 6-Sep-2017 18:27


NOW Expands in to Tauranga
Posted 5-Sep-2017 18:16


Windows 10 Fall Creators Update coming Oct. 17
Posted 4-Sep-2017 14:10


Garmin introduce Garmin vivoactive 3
Posted 1-Sep-2017 18:38



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.