Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3 
105 posts

Master Geek
+1 received by user: 1


  Reply # 611567 18-Apr-2012 22:39
Send private message

Does anyone here have a Cisco config for IPv6 on snap? If you do please post it as i'd love to have a lookie :) also if you're running it over ethernet or ATM :)

6937 posts

Uber Geek
+1 received by user: 3232

Moderator
Trusted
Lifetime subscriber

  Reply # 612073 19-Apr-2012 18:48
Send private message

frizianz: Does anyone here have a Cisco config for IPv6 on snap? If you do please post it as i'd love to have a lookie :) also if you're running it over ethernet or ATM :)


I do, I will get this for you shortly!

Edit:

interface Ethernet0
description ipv6 address dhcp-prefix ::/64 eui-64
ip address 192.168.0.3 255.255.255.0
ip nat inside
ip virtual-reassembly
ipv6 address ASSIGNED-PREFIX ::1:0:0:0:1/64
ipv6 enable
ipv6 nd prefix default 180 120
ipv6 nd other-config-flag
ipv6 nd ra interval 10
ipv6 verify unicast reverse-path
ipv6 dhcp server v6dhcp-local
hold-queue 100 out
!
interface Dialer0
bandwidth 5000
ip address negotiated
no ip redirects
no ip unreachables
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ipv6 address autoconfig default
ipv6 enable
ipv6 verify unicast reverse-path
ipv6 dhcp client pd ASSIGNED-PREFIX
no cdp enable
ppp pap sent-username username@snap.net.nz password "password"
ppp ipcp dns request
!
ipv6 route ::/0 Dialer0
!
ip cef
ip domain name .local
ip name-server 202.37.101.1
ip name-server 202.37.101.2
ip ssh version 2
!
ipv6 unicast-routing
dns-server 2406:E000:300::100


Edit as required, add into your Cisco config, this is a snippet from my own Cisco 877 config.




Michael Murphy | https://murfy.nz
Want to be with an epic ISP? Want $20 to join them too? Well, use this link to sign up to BigPipe!
The Router GuideCommunity UniFi Cloud Controller | Ubiquiti Edgerouter Tutorial


 
 
 
 


105 posts

Master Geek
+1 received by user: 1


  Reply # 612567 20-Apr-2012 19:17
Send private message

Cheers :) Worked wonders

3111 posts

Uber Geek
+1 received by user: 533

Trusted

  Reply # 612587 20-Apr-2012 20:25
Send private message

gregb:

What size prefix are Snap looking to give out to customers? 


I am not exactly sure on the number, but APNIC has suggested that ISP's should be issuing a /64 to each customer tail.
That means you have millions and millions of addresses avaliable to you on a standard home connection because the remainder of the devices v6 address is made up of the devices mac address.

So its your isp's issued /64 + mac address = your device's v6 address.

The /64 could be a different number. The subnetting confuses me - im still trying to work out the best way to subnet my v4 space lol.




Ray Taylor
Taylor Broadband (rural hawkes bay)
www.ruralkiwi.com

There is no place like localhost
For my general guide to extending your wireless network Click Here




9 posts

Wannabe Geek


  Reply # 612620 20-Apr-2012 21:29
Send private message

raytaylor:
gregb:

What size prefix are Snap looking to give out to customers? 


I am not exactly sure on the number, but APNIC has suggested that ISP's should be issuing a /64 to each customer tail.
That means you have millions and millions of addresses avaliable to you on a standard home connection because the remainder of the devices v6 address is made up of the devices mac address.

So its your isp's issued /64 + mac address = your device's v6 address.

The /64 could be a different number. The subnetting confuses me - im still trying to work out the best way to subnet my v4 space lol.


Currently Snap are assigning a /48 using DHCPv6-PD, out of which you'd have each subnet as a /64 so that autoconfiguration works.

377 posts

Ultimate Geek
+1 received by user: 189

Subscriber

  Reply # 614707 25-Apr-2012 01:41
Send private message

Hi guys,

One of the reasons I just switched to snap was it's IPv6 support. It's also the primary reason I chose the D-Link DSL-2740B - it advertised support. It turns out it needed a very buggy firmware update to enable that... anyway.

Unfortunately, I've tried all the settings possible, and I can not get IPv6 to connect. I'm not nearly as knowledgeable as the other residents of this thread, but I'm pretty confident the settings it's on now are correct (they're basically the default anyway.)

I took some screenshots, but I'll have to mangle the URL because I'm a new user... nice spam protection guys.
imgur . com/a/9YSwy

So if someone who knows what they're doing could have a glance over my config and help if there's anything wrong, I'd very much appreciate it.

Thanks!

wjw

162 posts

Master Geek
+1 received by user: 3


  Reply # 614752 25-Apr-2012 08:51
Send private message

ripdog: Hi guys,

One of the reasons I just switched to snap was it's IPv6 support. It's also the primary reason I chose the D-Link DSL-2740B - it advertised support. It turns out it needed a very buggy firmware update to enable that... anyway.

Unfortunately, I've tried all the settings possible, and I can not get IPv6 to connect. I'm not nearly as knowledgeable as the other residents of this thread, but I'm pretty confident the settings it's on now are correct (they're basically the default anyway.)

I took some screenshots, but I'll have to mangle the URL because I'm a new user... nice spam protection guys.
imgur . com/a/9YSwy

So if someone who knows what they're doing could have a glance over my config and help if there's anything wrong, I'd very much appreciate it.

Thanks!


What other options do you have under IPv6 Connection Type?



2475 posts

Uber Geek
+1 received by user: 559


  Reply # 614766 25-Apr-2012 09:23
Send private message

ripdog: Hi guys,

One of the reasons I just switched to snap was it's IPv6 support. It's also the primary reason I chose the D-Link DSL-2740B - it advertised support. It turns out it needed a very buggy firmware update to enable that... anyway.

Unfortunately, I've tried all the settings possible, and I can not get IPv6 to connect. I'm not nearly as knowledgeable as the other residents of this thread, but I'm pretty confident the settings it's on now are correct (they're basically the default anyway.)

I took some screenshots, but I'll have to mangle the URL because I'm a new user... nice spam protection guys.
imgur . com/a/9YSwy

So if someone who knows what they're doing could have a glance over my config and help if there's anything wrong, I'd very much appreciate it.

Thanks!


check here first to make sure your ipv6 is enabled 

type about:config in the address bar and then look for network.dns.disableIPv6 if it says true , change it to false .

377 posts

Ultimate Geek
+1 received by user: 189

Subscriber

  Reply # 614882 25-Apr-2012 13:00
Send private message

wjw:

What other options do you have under IPv6 Connection Type?






vexxxboy:

check here first to make sure your ipv6 is enabled 

type about:config in the address bar and then look for network.dns.disableIPv6 if it says true , change it to false .


Hi, I think you misread my post. The problem is that my modem is not connecting to the IPv6 internet. It has nothing to do with Firefox.

Thanks anyway :)

105 posts

Master Geek
+1 received by user: 1


  Reply # 614901 25-Apr-2012 13:33
Send private message

ripdog:





Try changing that to Autoconfig :)

377 posts

Ultimate Geek
+1 received by user: 189

Subscriber

  Reply # 615081 25-Apr-2012 18:35
Send private message

frizianz:
Try changing that to Autoconfig :)


Thanks for the reply. So I did that, and immediately this JS message appeared:



Good english as always.

Anyway, afterwards, another row appeared in the connection status page:



Predictably, stuck on Connecting.

Do you think there's any point hitting up Snap support over this?





105 posts

Master Geek
+1 received by user: 1


  Reply # 615274 26-Apr-2012 08:47
Send private message

Hmmm not sure, i think that IPv6 support is only via email at support@snap.net.nz. I remember reading that somewhere.

3384 posts

Uber Geek
+1 received by user: 389

Trusted

  Reply # 615290 26-Apr-2012 09:31
Send private message

Most of the devices advertising "IPv6 ready" etc. aren't really. They are missing basic features for IPv6 or its buggy. My suggestion would be to get a bridging modem then a router like the upcoming PFsense 2.1 or smoothwall that you can run on any PC to do all of the IPv6 work.





1 | 2 | 3 
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Zealand's IT industry in 2018 and beyond
Posted 22-Jan-2018 12:50


Introducing your new workplace headache: Gen Z
Posted 22-Jan-2018 12:45


Jucy set to introduce electric campervan fleet
Posted 22-Jan-2018 12:41


Hawaiki cable system will be ready for service in June 2018
Posted 22-Jan-2018 12:32


New Zealand hits peak broadband data
Posted 18-Jan-2018 12:21


Amazon Echo devices coming to New Zealand early February 2018
Posted 18-Jan-2018 10:53


$3.74 million for new electric vehicles in New Zealand
Posted 17-Jan-2018 11:27


Nova 2i: Value, not excitement from Huawei
Posted 17-Jan-2018 09:02


Less news in Facebook News Feed revamp
Posted 15-Jan-2018 13:15


Australian Government contract awarded to Datacom Connect
Posted 11-Jan-2018 08:37


Why New Zealand needs a chief technology officer
Posted 6-Jan-2018 13:59


Amazon release Silk Browser and Firefox for Fire TV
Posted 21-Dec-2017 13:42


New Chief Technology Officer role created
Posted 19-Dec-2017 22:18


All I want for Christmas is a new EV
Posted 19-Dec-2017 19:54


How clever is this: AI will create 2.3 million jobs by 2020
Posted 19-Dec-2017 19:52



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.