Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




1258 posts

Uber Geek
+1 received by user: 260


Topic # 148797 1-Jul-2014 11:09
Send private message

Hi guys. I just setting up my 1st 2012 essentials server

The web browsing, on the sever, is very very laggy (but works) . It takes too long for the website to begin loading.
I even tried Firefox, but that just as bad as IE.
Ping to (say)  www.google.com is OK, but even google website is slow to begin loading.


Any ideas ? It makes going to sites to download drivers/firmware a very painfull experience .
Is this just the way 2012 esstentials is ?
I have 8.8.8.8 & opendns in the DNS Forwarders.
Workstations connected to this server/domain are OK


Create new topic
1888 posts

Uber Geek
+1 received by user: 316


  Reply # 1077733 1-Jul-2014 11:58
Send private message

Need more information...

Is the server up to spec for 2012 Essentials or are you running it on a Celeron with 256MB of RAM and 30GB hard disk?
When you say laggy, do you mean pages are slow to load?  Or is the actual application, regardless of the presents of an internet connection just down-right slow?

If it ends up being the internet connection, try a DNS that is provided by your internet service provider.

Cheers :)





Sometimes what you don't get is a blessing in disguise!

2489 posts

Uber Geek
+1 received by user: 919

Subscriber

  Reply # 1077745 1-Jul-2014 12:22
Send private message

If you haven't got all the drivers installed (chipset, graphics, network etc) that will not be helping.




Windows 7 x64 // i5-3570K // 16GB DDR3-1600 // GTX660Ti 2GB // Samsung 830 120GB SSD // OCZ Agility4 120GB SSD // Samsung U28D590D @ 3840x2160 & Asus PB278Q @ 2560x1440
Samsung Galaxy S5 SM-G900I w/Spark

 
 
 
 




1258 posts

Uber Geek
+1 received by user: 260


  Reply # 1077747 1-Jul-2014 12:24
Send private message

Its a new HP sever. All drivers are loaded .
The new workstations dont have the issue, they use the same DNS (DHCP from the server)

There is a lag before the webpage even starts to load . IE / FF run just fine, webpages have a lag.
The sever is OK apart from that .

I have turned off "IE Enhanced Security" as that stopped any download in IE . So I wonder if there is another default setting that needs to be changed .

Cheers

4937 posts

Uber Geek
+1 received by user: 1314

Trusted
Microsoft

  Reply # 1077748 1-Jul-2014 12:28
Send private message

got multiple NICs?



1258 posts

Uber Geek
+1 received by user: 260


  Reply # 1077751 1-Jul-2014 12:29
Send private message

nathan: got multiple NICs?


2 NIC's, only 1 is used

What does this tag do
864 posts

Ultimate Geek
+1 received by user: 163

Subscriber

  Reply # 1077764 1-Jul-2014 12:40
Send private message

A pro tip would be to download drivers/firmware on another computer. IE Enhanced Security is turned on by default for a good reason - web browsing on a server is not good practice.
Missing drivers could certainly slow things down..
Otherwise would suggest trying using ISP DNS servers instead (unless you have a requirement for content filtering), and disable DNS recursion (DNS, Advanced, Server Options, Disable recursion)



1258 posts

Uber Geek
+1 received by user: 260


  Reply # 1077810 1-Jul-2014 13:03
Send private message

There are no missing drivers. All drivers are installed .
:-)

Using google's DNS is only temporary until its moved onsite .
Googles DNS isnt a real issue with workstations or other servers, in the setup stages, but I'll try changing that next.

Sometimes , its just not practical to use workstations to download drivers etc , need to use the server .
Using the server's web browser will be a very rare occurrence once onsite , but I do expect it to work properly.

I'll try disabling DNS recursion & let you know if that helps.

Cheers


What does this tag do
864 posts

Ultimate Geek
+1 received by user: 163

Subscriber

  Reply # 1077816 1-Jul-2014 13:10
Send private message

Ah sorry to misread you!
I can't remember what the defaults are on Server 2012, but it may be trying to recurse by default and only using the forwarders if the recursion times out.
Although if the workstations are using the SBS server as their DNS, and the server is using itself for DNS, it may not be a DNS issue...



1258 posts

Uber Geek
+1 received by user: 260


  Reply # 1077821 1-Jul-2014 13:14
Send private message

jnimmo: Ah sorry to misread you!


No problemo...
:-)   I know its quite often just a quick read of postings


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Zealand government to create digital advisory group
Posted 16-Dec-2017 08:47


Australia datum changes means whole country moving 1.8 metres north-east
Posted 16-Dec-2017 08:39


UAV Traffic Management Trial launching today in New Zealand
Posted 12-Dec-2017 16:06


UFB connections pass 460,000
Posted 11-Dec-2017 11:26


The Warehouse Group to adopt IBM Cloud to support digital transformation
Posted 11-Dec-2017 11:22


Dimension Data peeks into digital business 2018
Posted 11-Dec-2017 10:55


2018 Cyber Security Predictions
Posted 7-Dec-2017 14:55


Global Govtech Accelerator to drive public sector innovation in Wellington
Posted 7-Dec-2017 11:21


Stuff Pix media strategy a new direction
Posted 7-Dec-2017 09:37


Digital transformation is dead
Posted 7-Dec-2017 09:31


Fake news and cyber security
Posted 7-Dec-2017 09:27


Dimension Data New Zealand strengthens cybersecurity practice
Posted 5-Dec-2017 20:27


Epson NZ launches new Expression Premium Photo range
Posted 5-Dec-2017 20:26


Eventbrite and Twickets launch integration partnership in Australia and New Zealand
Posted 5-Dec-2017 20:23


New Fujifilm macro lens lands in New Zealand
Posted 5-Dec-2017 20:16



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.