Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




200 posts

Master Geek


Topic # 56569 17-Jan-2010 17:53
Send private message

I have a website www.nzmotorhome.co.nz.
One user (only) gets a 404 error when trying to use the righthand sidebar menu.
Their favourites link takes them directly to the Forum page but if they try to navigate to any of the other pages they get "Host Gator 404 Page not found".
They are using Windows 7 and both IE and Fx (same problem with both.
If they use an alternative computer (XP Pro and Fx) then it works fine.

Any suggestions about what sort of thing could be causing this??

TIA

Create new topic
BDFL - Memuneh
59058 posts

Uber Geek
+1 received by user: 10340

Administrator
Trusted
Geekzone
Subscriber

  Reply # 290734 17-Jan-2010 17:57
Send private message

I'd suggest you start checking what's the DNS he's using on this specific PC - seeing other PCs work fine. Then make sure that DNS resolves your site correctly.

Also check that both www and non-www are defined in your DNS records. And on your webserver virtual hosts header.




217 posts

Master Geek
+1 received by user: 2


  Reply # 291083 19-Jan-2010 09:01
Send private message

If the user can get to the Forum page then DNS shouldn't be an issue; it looks like all the pages are hosted under the same domain.

Have a look at the following for some more into on the "HostGator" 404 errors - it looks like someone (most likely the people hosting your website or his ISP) are using HostGator to try and make money out of problem links: http://hostingfu.com/article/hostgator-monetize-with-default-404-page

 
 
 
 




200 posts

Master Geek


Reply # 291097 19-Jan-2010 09:25
Send private message

That may be so, Buzzy, but I don't think that they are going as far as to create bogus 404 errors, so there is still a real problem (despite them trying to make money out of it).

If the user types in the URL's of each of the pages from the website, they open perfectly - it is only when the try to use the menu (which has exectly the same links) that they get the error 404's.

BTW thet are using DHCP and so aquire the DNS automatically on each of their machines.

I'm out of my depth

217 posts

Master Geek
+1 received by user: 2


  Reply # 291266 19-Jan-2010 18:18
Send private message

Yah sorry - I was replying at work and ran out of time to put together a better reply.

The links in the HTML look fine. If the user can manually type in a URL and it works then there's no problem with DNS or HTTP requests to retrieve the pages.

I'd suggest having a look at the Favourite link that the user's using - it's possible that the Favourite is actually a link to HostGator or another proxy service, which is then retrieving the page initial and displaying it; this would mean when the user clicks a relative link, something breaks because the link's not explicitly referring to the NZmotorhome site (your links are "relative" in the sense that they link to "/NZMotorhome/whatever/something.html" as opposed to linking to "http://www.nzmotorhome.co.nz/NZmotorhome/whatever/something.html" - there's nothing wrong with relative links and I"m not suggesting you need to change them; they're fine as they are).

Lastly, you could also ask the user to check the proxy settings on the PC (Control Panel -> Internet Options -> Connections Tab -> LAN Settings -> Automatic Settings or Proxy). I wouldn't suggest changing these unless you know what you're doing, but it might be worth getting a screenshot of that page and posting it so we can see what he's using as a proxy.

Cheers
Buzzy

53 posts

Master Geek


  Reply # 292265 22-Jan-2010 16:39
Send private message

Small suggestion... has the user tried logging onto the PC with a different account, prefarably a new account with new local profile etc? Corrupt local profiles can cause so many different problems....


53 posts

Master Geek


  Reply # 294402 29-Jan-2010 17:04
Send private message

Hi there, how did you get on?

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Netatmo launches smart home products in New Zealand
Posted 20-Nov-2017 20:06


Huawei Mate 10: Punchy, long battery life, artificial intelligence
Posted 20-Nov-2017 16:30


Propel launch Disney Star Wars Laser Battle Drones
Posted 19-Nov-2017 21:26


UFB killer app: Speed
Posted 17-Nov-2017 17:01


The case for RSS — MacSparky
Posted 13-Nov-2017 14:35


WordPress and Indieweb: Take control of your online presence — 6:30 GridAKL Nov 30
Posted 11-Nov-2017 13:43


Chorus reveals technology upgrade for schools, students
Posted 10-Nov-2017 10:28


Vodafone says Internet of Things (IoT) crucial for digital transformation
Posted 10-Nov-2017 10:06


Police and Facebook launch AMBER Alerts system in NZ
Posted 9-Nov-2017 10:49


Amazon debuts Fire TV Stick Basic Edition in over 100 new countries
Posted 8-Nov-2017 05:34


Vodafone VoIP transition to start this month
Posted 7-Nov-2017 12:33


Spark enhances IoT network capability
Posted 7-Nov-2017 11:33


Vocus NZ sale and broadband competition
Posted 6-Nov-2017 14:36


Hawaiki reaches key milestone in landmark deep-sea fibre project
Posted 4-Nov-2017 13:53


Countdown launches new proximity online shopping app
Posted 4-Nov-2017 13:50



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.