Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




4 posts

Wannabe Geek


Topic # 86667 11-Jul-2011 23:59
Send private message

Hi,
I've spent a lot of time looking in to setting up an SPF record and I thought I had it properly setup but when I send test emails to spf-test@openspf.org i get a "none" reply for the spf test.  I also tried sa-test@sendmail.net and I get a "no result present" .


My domain is raise-networks.org.uk and the SPF record I have configured is:

raise-networks.org.uk TXT v=spf1 a mx mx:mail.raise-networks.org.uk -all 

Any help greatly appreciated! 

Create new topic
8020 posts

Uber Geek
+1 received by user: 386

Trusted
Subscriber

  Reply # 492272 12-Jul-2011 03:34
Send private message

I think in the TXT record instead of normal space characters you may have copied and pasted some odd character encoding.

Fix up the spaces in a plain text editor, then update the TXT record and wait for TTL to expire and retest.



4 posts

Wannabe Geek


  Reply # 492275 12-Jul-2011 03:47
Send private message

HI,
Thanks for taking the time to reply.  I'm not sure I understand what you're saying...

I composed my spf string in Notepad and then pasted the SPF in to my dns server:

v=spf1 a mx mx:mail.raise-networks.org.uk -all

Thanks
 

 
 
 
 


146 posts

Master Geek
+1 received by user: 1


  Reply # 492279 12-Jul-2011 07:01
Send private message

Its not working, looks like your missing spaces in the syntax

Microsoft have a online tool to create them here

http://www.microsoft.com/mscorp/safety/content/technologies/senderid/wizard/

Use MXToolbox to test

http://www.mxtoolbox.com/spf.aspx
 

571 posts

Ultimate Geek
+1 received by user: 76


  Reply # 492292 12-Jul-2011 08:17
Send private message

If I query DNS (using nslookup in Windows) for a domain that I know has SPF configured correctly, the result looks like this:

xyz.com text =
"v=spf1 a mx ip4:x.x.x.x -all"

Your result looks like this:

raise-networks.org.uk text =
"v=spf1"
"a"
"mx"
"ptr"
"ip4:93.174.137.88"
"mx:mail.raise-networks.org.uk"
"mx:raise-networks.co.uk"
"-all"

It seems to be split over multiple lines. I would suggest contacting your DNS host for the correct way to set these up, they should be able to help as it's a standard configuration requirement now.



4 posts

Wannabe Geek


  Reply # 492294 12-Jul-2011 08:21
Send private message

Thanks for your help.  I have logged a support call with my DNS hosting company as the record that I have added has correct spacing but as you highlight it is showing incorrectly on external sites.

Kate



4 posts

Wannabe Geek


  Reply # 492301 12-Jul-2011 08:45
Send private message

The spacing problems have now been resolved.  I needed to put " " around my record.

I can now see it showing correctly on MXToolbox.  However, I still get "no result present" when I send a test email to sa-test@sendmail.net

Thanks for your help so far.

8020 posts

Uber Geek
+1 received by user: 386

Trusted
Subscriber

  Reply # 492339 12-Jul-2011 10:13
Send private message

Might take awhile for their dns servers to pickup the change, depending on your TTL for the domain, TTL for your domain seems to be set to 24hrs 
http://www.openspf.org/FAQ/Common_mistakes#caching

This online dig still showing the old record just right at the moment
http://tools.bevhost.com/cgi-bin/dnslookup?data=raise-networks.org.uk

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Zealand hits peak broadband data
Posted 18-Jan-2018 12:21


Amazon Echo devices coming to New Zealand early February 2018
Posted 18-Jan-2018 10:53


$3.74 million for new electric vehicles in New Zealand
Posted 17-Jan-2018 11:27


Nova 2i: Value, not excitement from Huawei
Posted 17-Jan-2018 09:02


Less news in Facebook News Feed revamp
Posted 15-Jan-2018 13:15


Australian Government contract awarded to Datacom Connect
Posted 11-Jan-2018 08:37


Why New Zealand needs a chief technology officer
Posted 6-Jan-2018 13:59


Amazon release Silk Browser and Firefox for Fire TV
Posted 21-Dec-2017 13:42


New Chief Technology Officer role created
Posted 19-Dec-2017 22:18


All I want for Christmas is a new EV
Posted 19-Dec-2017 19:54


How clever is this: AI will create 2.3 million jobs by 2020
Posted 19-Dec-2017 19:52


NOW to deploy SD-WAN to regional councils
Posted 19-Dec-2017 19:46


Mobile market competition issues ComCom should watch
Posted 18-Dec-2017 10:52


New Zealand government to create digital advisory group
Posted 16-Dec-2017 08:47


Australia datum changes means whole country moving 1.8 metres north-east
Posted 16-Dec-2017 08:39



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.