Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

4025 posts

Uber Geek
+1 received by user: 1076


# 106311 21-Jul-2012 19:59
Send private message

So for some reason the XDA forums for the i9000 are messy and not very straightforward at all - theres a mishmash of information with everything from flashing a kernel via odin, some stuff that says you need to change the modem, plenty of conflicting information.
I think I must be too spoiled with how straightforward everything is on my HTC Desire. Stuff like samsung kies to get the adb drivers etc is just ugghhhhhh.

Anyway. Telecom 2.3.3 rom. this means i9000TDOJV4 baseband.
End goal is to get CM9 on here and get rid of this touchwiz and telecom rubbish.

I have sucessfully rooted with superoneclick but it appears rom manager can't touch the recovery - signature verification fails when you flash it and then reobot to recovery which shows the stock one.

So where do i go from here? Anything special i need to do because its an i9000T? I need to get CWM recovery on here, and i assume from there its the same as per usual?

Create new topic
2106 posts

Uber Geek
+1 received by user: 34

  # 659755 22-Jul-2012 00:18
Send private message

Tried the 3 button combo to get to recovery instead?

- Telstra HTC Touch Pro2 - Energy ROM WM6.5.5 20 Oct/Cyanogen Mod Froyo 2.2 - R.I.P
- AT&T Galaxy S Captivate 16GB on XT (now with brother)
- Samsung Galaxy S2 on XT- Runs ICS 4.0.3 Resurrection Remix 9.2
- Business Hours - Work In The Electricity Industry, After Hours - DJ/Turntablist - Will Scratch Vinyl For Free'
- What's next??? S3?

335 posts

Ultimate Geek
+1 received by user: 19

  # 659826 22-Jul-2012 10:56
Send private message

You can follow guides for the I9000, just flash the I9000T modem when you are finished as you will not get consistent coverage otherwise. (This is done by flashing the modem.bin file in Odin, I use UGJL2 for the I9000T)

In terms of the recovery, you will need to flash an older/insecure kernel with a 2e recovery. This will enable you to flash a new recovery over top as it does not get the signature verification fail error.

I have bookmarked a page on this on a different computer, I'll update this post when I can find it for you.

Update -

CF root kernels here


352 posts

Ultimate Geek

  # 659840 22-Jul-2012 11:03
Send private message

I have a SGS GT-I9000T from Telecom. Was on stock ROM 2.3.3.
I upgraded mine to CyanogenMod 7.2 last weekend. It was a huge learning curve involving a lot of trial and error. I'm new to Android, rooting, ROM'ing and all that.

First thing, the instructions on the CM website didn't work for me. The Heimdall tool wouldn't detect my device. Whether this is because I am on Windows 7 64 or not I don't know.
I used Odin 1.7 throughout the process using the s1_odin_20100512.pit partition file.

Before you start you should also make a backup of your stock ROM by using checkfus and the checkfus downloader. It's handy to know you can go back if things don't work out, but also because, as you'll read, I needed it as a starting point for the remaining steps.
So my backup file from checkfus download was jv4_jv3_jv4.tar
I wasn't able to restore back to stock initially *sweats*. When I tried, the boot sequence complained about a missing dbdata.rfs file. I downloaded a dbdata.tar file from the Internet and that did the trick. I don't know what the significance of this file is but I needed it in addition to the stock ROM file.

So the restore to stock the process looked like this:

Open Odin
Click PIT - Select s1_odin_20100512.pit
Click PDA - Select jv4_jv3_jv4.tar
Options: Re-Partition = Ticked, Auto Reboot = Unticked, F. Reset Time = Ticked
Click Start
Click Reset
Click PDA, Select dbdata.tar
Options: Re-Partition = Unticked, Auto Reboot = Ticked, F. Reset Time = Ticked

A few hours of trial and error was my learning curve. I wasn't able to get a ClockWorkMod that would run the CM update despite trying many many ROM options.

I suspect CM9 would be similar to CM7.2. The process for getting to CM7.2 was as follows:

Using Odin, set PDA to CF-Root-XX_OXA_JVK-v2.7-CWM3RFS.tar and Start - but (if I recall correctly) leave PIT blank.
This "roots" the phone and you get a ROM Manager app installed in your list of applications.
Use ROM Manager to install CM7.2

Note I still wasn't able to install because of a "status 7" assert error. Apparently the name of my device wasn't GT-I9000T, but probably rebadged as "I9000 for XT network" or something.
So, I had to open the ROM tar file, find \META-INF\com\google\android\updater-script and remove the assert statement at the top of the file.

From then on it worked perfect.

Hope that helps!

329 posts

Ultimate Geek
+1 received by user: 7

  # 659854 22-Jul-2012 11:57
Send private message

As far as I know the I9000T is exactly the same as the I9000 apart from the modem. That is the bootloaders and main ROM are interchangeable, though the Telecom ROMs will have their branding etc.

Be very careful not to accidentally install firmware meant for any Galaxy S model other than the I9000, this is the leading cause of bricks because the bootloaders are different. In CM this model is also known as "galaxysmtd". Use the modem that matches your current one from this thread:

Some suggestions:
The easiest way to root and install CWM recovery at the same time is to flash the correct Chainfire kernel for your current firmware from . Once you have done this:

Backup your EFS folder . This contains your IMEI and the phone will not work as a phone without it. Do this before going to CM.

Make an app backup using Titanium Backup (pro version is much easier to reinstall from). 

Follow the Cyanogenmod install guide

Keep the CM zip files on your internal SD card after installation, don't delete them, this way if something goes wrong after the install you can re-flash CM from recovery without having to reinstall the stock 2.x.x first. You could also try making Nandroid backups from CWM recovery but my experience with restoring these has not been good.

If you get into a boot loop and can't get to recovery, download FixRecovery from and flash it with Odin (instructions on the site), again this saves having to go back to 2.x.x.

587 posts

Ultimate Geek
+1 received by user: 47

  # 659918 22-Jul-2012 14:58
Send private message

rvangelder: I wasn't able to restore back to stock initially *sweats*. When I tried, the boot sequence complained about a missing dbdata.rfs file. I downloaded a dbdata.tar file from the Internet and that did the trick. I don't know what the significance of this file is but I needed it in addition to the stock ROM file.

The dbdata.rfs file contains a partition dump of a pretty-much blank /data partition. If you flash a ROM that doesn't contain this, and you've used the repartition option in Odin, you'll end up with an unbootable phone.

The reason it's missing is because there are 2 types of firmware package: a full package, and an upgrade package. It's hard to tell which kind you've got unless you open it up and see if it has the dbdata file. If you have this problem, you either need to find a TAR file that just has the dbdata part (don't use repartition in Odin while flashing), or find a full rom that has the file.

4025 posts

Uber Geek
+1 received by user: 1076


  # 660067 22-Jul-2012 21:15
Send private message

Okay got it working. CM9 RC2 installed - brillaint, the samsung trash is gone!

Still running the standard modem. Is there any benefit to changing to UGJL2? Improved signal/battery life/compatibility?
Looking at the last few pages of this thread, people seem to think various other ones work better.

Can i simply flash the CWM3 one on the CWM6 thats installed?

Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21

Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36

Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57

Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48

New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35

Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00

Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34

OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28

Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56

Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20

New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09

ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05

New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35

Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39

TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.