Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




60 posts

Master Geek
Inactive user


# 109756 25-Sep-2012 23:45

Hi all.

I have a SG3 and had it for about 6months now so reasonably new..

Everything was fine until this morning when I tried to connect to my wi-fi and suddenly it doesnt work.

The wifi connection at the top right hand corner comes up and it says its all connected but whenever I try to browse or just generally use the internet on my phone, it just doesnt work at all...

This is really weird because it worked until this morning and when I got back from work it keeps playing up.

I use a hotspot from my laptop to use my wifi...no settings have been changed...

I even reset my phone erased everything and it still doesnt work...

Can you guys help?


Thanks :(

Create new topic
21428 posts

Uber Geek

Trusted
Lifetime subscriber

  # 691462 26-Sep-2012 01:43
Send private message

Yup it's a common fault. Reset to factory defaults and if that doesn't work it will need to be repaired.

224 posts

Master Geek


  # 691464 26-Sep-2012 02:30
Send private message

Try reset your modem/router

 
 
 
 


368 posts

Ultimate Geek


  # 691465 26-Sep-2012 02:32
Send private message

yochankr:

The wifi connection at the top right hand corner comes up and it says its all connected but whenever I try to browse or just generally use the internet on my phone, it just doesnt work at all...


Thanks :(


And was the hotspot on the Laptop restarted, the ARP cache cleared and the DHCP server reset?

It's not something like a 'stale' DHCP address or DNS server 'hanging' the service.

Maybe try reducing the DHCP renew time.

Were you able to use WiFi on another access point with the SGSIII?

Was a power restart of the SGS3 unsuccessful in re-establishing WiFi?

I lose access to my WiFi sometimes when my phone is scheduled to disable carrier (GSM,3G) service each night (reactivated in the morning) and I happen to be far enough away from the AP to lose signal. When WiFi is started again, it attempts to start, but shows as disconnected and nothing is accessible even when I'm right next to the WiFi AP.
Once or twice only a power restart would re-establish a WiFi connection. I've seriously messed with my XPERIA phone so I can accept the odd few quirks (Over-clocked and CPU governors tweaked, change wifi.ko install process..etc).

I'd be a bit freaked if I had to reset the phone to recover WiFi on a standard (non-rooted) device though.







597 posts

Ultimate Geek


  # 691533 26-Sep-2012 09:13
Send private message

Try setting static IP address settings on the phone, rather than letting it get settings via DHCP. If that doesn't work, delete the access point and join to it again and see if that helps.

I've had times where my SGS2 said it was connected to my home WiFi network, but couldn't connect to anything. I checked the IP address that the phone said it was using, and it was in the 169.x.x.x range. Having an IP in this range indicates that DHCP did not work.

I think I tried setting static IP info, and that worked, but it wasn't what I wanted. I think that I ended up deleting the access point, rebooting, and adding the access point again.

If your phone is rooted, there is a file that contains the DHCP lease information that you can delete. I can't remember where it is though, so you might need to search for what the file name might be.

21428 posts

Uber Geek

Trusted
Lifetime subscriber

  # 691540 26-Sep-2012 09:32
Send private message



I'd be a bit freaked if I had to reset the phone to recover WiFi on a standard (non-rooted) device though.



To be fair I felt it was a reasonable guess that he would have tried the obvious troubleshooting steps first. 

1779 posts

Uber Geek


  # 691584 26-Sep-2012 10:58
Send private message

My SG3 sometimes can't connect to my router at home and at work (both routers are Dynalink RTA-1025W). This happens maybe once in every 5 connections. When the problem happens I go into WIFI Settings and it says it's connected to the router but if I tap the Advanced button it says it was unable to get an IP address. Rebooting the router always fixes the problem.

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41


Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30


BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14


Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24


2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35


New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13


OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32


Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27


D-Link launches Wave 2 Unified Access Points
Posted 24-Oct-2019 15:07


LG Electronics begins distributing the G8X THINQ
Posted 24-Oct-2019 10:58



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.