Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


6 posts

Wannabe Geek


Topic # 154826 9-Nov-2014 12:47
Send private message

I have a Xoom, bought 3 years ago at Heathrow flying back to NZ. It was then the first commercially available 3G Android Tablet.

It seems stuck on Android 4.0.4, and always worked pretty well here in NZ, using a Vodafone SIM, as well as the UK, using a Vodafone or O2 SIM there. However, I gained a newer Samsung Tab2 6 months ago, which is more portable and newer, so I haven't used the Xoom much for a while. Mainly just reading e-mails and browsing.

I figured that because of the dock with the HDMI port, I'd use it to feed a TV in the kitchen to watch On Demand and News and so on while cooking. I hit a brick wall. Nothing using flash works anymore. If I try TV3 or TVNZ On Demand using a browser, I get a message I need to download their apps from the Play Store. Play store says these Apps won't run on my device. The closest I got was installing photon browser, which plays TV3 OD, but as soon as I select full-screen mode, all I get is a white screen and the thing locks up.

I used to watch BBC & AL Jazeera News on it, but the live streams don't play. The only video I can get is BBC News stories, YouTube clips, and so on. It seems Flash has gone from the device (I know it used to be there), and I know this stuff used to work.

Even though the USA saw an upgrade to Android 4.1,2 18 months ago, this hasn't shown up on mine here as yet. The TVNZ OnDemand sites says they only support Samsung devices, and suggest there may be updates available over the next year for other manufacturer devices (no idea what the time scale is, as not dated, nor which devices). I don't get why things that did work are not only not working, but some seem to be being disabled, and the provider seems to be increasing the restriction to access to content, even for legitimate usage.

I tried out the UK OD stuff via VPN, and it is also pretty unusable now, with the same sorts of issues - in fact, iPlayer app is also now gone too. That used to work when in the UK, and via VPN.

So, it seems my Xoom is turning into a brick before my eyes.

My question is, has anybody got any suggestions as to what I could do with it?

I have looked at rooting it and installing a system upgrade mod - but would prefer not to have to do that, as it looks fiddly. The risk of bricking is less of an issue, as it is heading that way anyway by the looks of it. I'd like to just be able to run something linux on it, as I much prefer that to android, and have a fair bit of experience with linux. Ha anybody got linux running on a Xoom? I'm not worried about losing 3G, as long as the WiFi works. It only needs to feed out an HDMI signal, run video and access stuff via a browser. Which distro's have releases that support ARM that could be installed? What is the procedure? I'm familiar with Debian as well as Ubuntu, and I'd imagine Unity or Gnome 3 shells would be best for a touch-screen device. Anybody know how far they are with ARM ports that take advantage of that functionality?

Is there anything I've missed as options? Any other advice? Am I missing something trivial and obvious?

Mish


Create new topic
4955 posts

Uber Geek
+1 received by user: 103

Trusted

  Reply # 1171651 9-Nov-2014 14:25
Send private message

I have the same unit I think. It was purchased from Telecom (Spark) so had 3G. It got really slow and I rooted it and then applied this ROM

http://forum.xda-developers.com/showthread.php?t=2088717

The update kept 3G and it made a world of difference to it. You can either do that or just ditch the device and upgrade.

Since I have purchased a Nexus 7 now, I just use my Xoom as a media player and also a clock in the family room. When it's not being used it shows the time of day and I can play music on it through my network (connected to my HiFi system) or from Google Music.  Good device in its day, superceded now really.




System One: Popcorn Hour A200,  PS3 SuperSlim, NPVR and Plex Server running on Gigabyte Brix (Windows 10 Pro), Sony BDP-S390 BD player, Pioneer AVR, Raspberry Pi running Kodi and Plex, Panasonic 60" 3D plasma, Google Chromecast

System Two: Popcorn Hour A200 ,  Oppo BDP-80 BluRay Player with hardware mode to be region free, Vivitek HD1080P 1080P DLP projector with 100" screen. Harman Kardon HK AVR 254 7.1 receiver, Samsung 4K player, Google Chromecast

 


My Google+ page 

 

 

 

https://plus.google.com/+laurencechiu

 

 


14216 posts

Uber Geek
+1 received by user: 2572

Trusted
Subscriber

  Reply # 1171662 9-Nov-2014 15:03
Send private message

I have a TF101, which is the same era and almost identical insides. Just get a custom ROM as suggested above. They're still pretty slow, but I use mine for reading RSS feeds and the occasional web page in front of the TV. It's just fast enough for Facebook, but takes ages to start, and can't multi task even though it's a multicore processor.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.