Hi guys

Just sharing some issues I've been having with the latest version of Google Hangouts
I was quite happy with it and used it as my default messaging / texting app.

However, since the new version 4.0 it's been a complete disaster.
First of all I had to uninstall hangouts dialer as it would always default to making a hangouts toll call rather than simply using standard cellular call. Tried to find a setting to change this but failed.

Second. I have completely lost ability to text short-code numbers.
I tried to use text-a-park the other day. I had the 7275 number conveniently in my addressbook.
However every text was being sent to +647275, and therefore failing.
There was no way of me changing this and number was entered without the leading +64 in contacts.
I tried removing the number and simply creating a new SMS using Hangouts dialogues and options.
But after selecting new SMS and typing 7275 nothing shows up.
The option of texting only show up after you enter a full NZ mobile number, not a single short code works!!!

I submitted feedback and bug reports.
Just checking some of you are having similar experience or a work-around.

For now I have reverted to the stock Messenger app.
This is on stock 5.1.1 on a Nexus

Thanks,
Damian