Got a problem with my SU6.

Last night i noticed a notification about Lollipop UI. When I went to look further it disappeared.
Odd, i thought, as it has updated to 5.1.1, but the phone kept working fine.

Charged it overnight, and the alarm went off as normal. The phone was working fine till I restarted it. It then wouldn't recognize the sim card. There were no errors except that there was no reception and cellular network options were greyed out in settings. The phone was still working but it would randomly restart. Startup seemed very slow.

Another issue that I noticed was that when I asked it to shutdown or reboot it wouldn't, it just sat there 'rebooting' till i held down the power button to restart it.

I've had the phone for 2 years now and never done a factory reset so I backed up my files and tried that. Same as shutting down or rebooting it wouldn't do that. Still cell service.

So I went into recovery and wiped cache and did a factory reset from there.

Rebooted the phone and started setting it up, it asks for a sim card to be inserted. I have tried the sim in another phone, works fine.

I skipped that and conneted to my wifi, it connects and then checks for updates, and this is where google play services stops working and I can't get any further.

My phone is standard, nonrooted, with a vodafone sim.

Kind of at a loss as to where to go from here.

Any suggestions or help would be greatly appreciated.