Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




2 posts

Wannabe Geek


Topic # 85286 16-Jun-2011 13:48
Send private message

I brought a Samsung Galaxy S I9000 a month ago, un updated, on the telecom network and all was good. Then 7 days ago some apps i downloaded from Android market stated that i needed a new firmware update to run them, so i looked on the internet for updates, there were a few but the latest was identified it as Gingerbread Android 2.3.2. So after this i loaded up Samsung Kies to update my phone. But Kies said that my phone was up to date. So i checked to see if Kies was up to date and also figured out it wasnt so i tried to update it and this time the app said it was the latest version. So then i went onto androidadvices.com which had the Gingerbread 2.3.2 update and downloaded it via there and loaded it onto my phone as it specified. 
I thought all was working well until i could no longer access the internet through my phone, only wifi, but i thought it was only cause the settings changed a bit cause everything else worked. Then over the past 2 days i lost the ability to text and call, and yesterday i was unable to find the Telecom network, which i am still unable to locate.
Are these problems because of the Gingerbread update and are they fixable while maintaining the Gingerbread 2.3.2 firmware update or will i have to downgrade to the previous update?

Create new topic

n4

955 posts

Ultimate Geek
+1 received by user: 73


  Reply # 481849 16-Jun-2011 13:58
Send private message

Assuming you flashed the new firmware via Odin? In which case you likely flashed a non-XT compatible, UMTS 2100/900 (not 850) firmware. Therefore it would work when inside XT UMTS 2100 coverage but not outside in the more extensive UMTS850 coverage. If that's the case you can flash just an XT compatible UMTS-850 modem without flashing new firmware, check xda-developers for appropriate downloads, or search the SGS thread here on Geekzone.




Huawei Mate 7, on 2degrees

2548 posts

Uber Geek
+1 received by user: 264


  Reply # 481850 16-Jun-2011 13:58
Send private message

Happy to report you have likely bunged it.

The other SGS updaters here will be able to tell you how to get out of it, But telecom has not released the update yet to Samsung (so Kies won't find it).

The base GB model does not take into account the 850mhz UMTS 3G that telecom use. Hence it being a GT-I9000T

Jumping into self firmware updates without knowing what you were doing was possibly not the smartest move.

Until one of the guys here point out the modem update you need, You have a brick :)

/edit.. and as I hit reply. Someone has done just that

 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software
551 posts

Ultimate Geek
+1 received by user: 18


  Reply # 481852 16-Jun-2011 14:01
Send private message

You might have the incorrect modem in the Gingerbread 2.3.2 update, The modem file you need is one that will work on the XT 3G frequency 850, most of the Galaxy S sold internationally work on the Vodafone/2D 3G frequency band of 2100 and/or 900.

Some of the guys here on GZ may be able to help.

Go to your dial pad and enter *#1234# and post the information, it should be something like:

PDA: I9000xxxxx

Phone: I9000xxxxx

CSC: I9000xxxxx

The information is for others to ascertain what firmware version of the Gingerbread you have updated on your phone.

752 posts

Ultimate Geek
+1 received by user: 33


  Reply # 481853 16-Jun-2011 14:03
Send private message

http://androidforums.com/samsung-galaxy-s/258859-how-enable-850mhz-3g-network-frequency-your-samsung-i9000-galaxy-s.html

You will want to make sure that WCDMA 850MHz and 2100MHz are selected and deselect 900MHz.

n4's suggestion will more than likely yield better peformance if you are using a modem tuned for 850MHz though.



2 posts

Wannabe Geek


  Reply # 481888 16-Jun-2011 14:43
Send private message

Thanks

PDA : I9000XXJVO

PHONE : I9000XXJVO

CSC : I9000XAJVO

Yes i flashed it through Odin. IT is unable to select the WCDMA 850 (FDD V) band so im going to flash on a UMTS-850 modem. 

333 posts

Ultimate Geek
+1 received by user: 19


  Reply # 481930 16-Jun-2011 16:17
Send private message

UGJL2 seems to be the best modem to use with XT. Download the zip file and extract it, then you can flash the modem.bin file with odin. Either that or flash the zip through recovery.

1 post

Wannabe Geek


Reply # 485269 24-Jun-2011 00:46
Send private message

Hi Guys

For those interested if you have upgraded your Samsung to 2.3.3 and cant find the Telecom network enter in the following via your dialer

*#*#4636#*#*

and than once into the next screen, press the menu button and select radio network option and than select AUS2 once you have a list appear.

This will allow you to find Telecom under your network option through your settings.


Thanks


Meow
7363 posts

Uber Geek
+1 received by user: 3538

Moderator
Trusted
Lifetime subscriber

  Reply # 485273 24-Jun-2011 01:16
Send private message

Lesson:

Don't flash your phone manually unless you know what you are doing and also know you are voiding the warranty if you don't know how to put it back to stock.

Read, Read and do more Reading until you are certain that you know what you are doing - Then if you stuff it up, you should be able to fix it.

Me? I have spent countless hours restoring my phone due to a messup, but I am a "Android Power User" so that is normal for my kind.

Your solution in this case? Download the following file from here - Install it using Clockwork Recovery.

You now owe me a pie. 




Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

ASB first bank in New Zealand to step out with Garmin Pay
Posted 23-May-2018 00:10


Umbrellar becomes Microsoft Cloud Solution Provider
Posted 22-May-2018 15:43


Three New Zealand projects shortlisted in IDC Asia Pacific Smart Cities Awards
Posted 22-May-2018 15:14


UpStarters - the New Zealand tech and innovation story
Posted 21-May-2018 09:55


Lightbox updates platform with new streaming options
Posted 17-May-2018 13:09


Norton Core router launches with high-performance, IoT security in New Zealand
Posted 16-May-2018 02:00


D-Link ANZ launches new 4G LTE Dual SIM M2M VPN Router
Posted 15-May-2018 19:30


New Panasonic LUMIX FT7 ideal for outdoor: waterproof, dustproof
Posted 15-May-2018 19:17


Ryanair Goes All-In on AWS
Posted 15-May-2018 19:14


Te Papa and EQC Minecraft Mod shakes up earthquake education
Posted 15-May-2018 19:12


Framing Facebook: It’s not about technology
Posted 14-May-2018 16:02


Vocus works with NZ Police and telcos to stop scam calls
Posted 12-May-2018 11:12


Vista Group signs Aeon Entertainment, largest cinema chain in Japan
Posted 11-May-2018 21:41


New Privacy Trust Mark certifies privacy and customer control
Posted 10-May-2018 14:16


New app FIXR connects vehicle owners to top Mechanics at best prices
Posted 10-May-2018 14:13



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.