Hi Guys,

I have a Cisco 877 router that I set up with a Hurricane Electric tunnel some time ago, except I decided I might do a full wipe and start off fresh with SIXXS (Latency + Speed improvements) - I can't for the life of me remember the best way to pass over the IPv6 /48 subnet off to my network for each of the computers to have a address.

I have got the actual tunnel set up as so:

interface Tunnel0
description IPv6 to SixXS
no ip address
ipv6 address 2001:4428:200:DA::2/64
ipv6 enable
ipv6 traffic-filter V6-FILTER in
ipv6 mtu 1280
ipv6 inspect V6-INSPECT out
ipv6 virtual-reassembly
tunnel source Dialer0
tunnel destination 202.21.136.122
tunnel mode ipv6ip

which works fine, I can ping IPv6 enabled sites, but my vlan1 interface (that's the one for the "local lan") needs some TLC to pass along the subnet along to the network:

interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ipv6 enable
ipv6 address 2001:4428:279::1/48
ipv6 nd prefix 2001:4428:279::/48
ipv6 nd ra lifetime 180
ipv6 nd ra interval 60

I know I am just missing something simple here, anyone got any pointers? I know at least 1 of you are running a SIXXS tunnel on a Cisco IOS device.

Also I have got ipv6 route ::/0 Tunnel0, ipv6 unicast-routing & ipv6 cef in the config.