Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




23 posts

Geek


Topic # 143409 14-Apr-2014 12:21
Send private message

Hi there,

I got a Draytek Vigor 130 and a SonicWall tz 210 and would like to set it up so that the Vigor 130 is acting as a VDSL modem only and the SonicWall is my router/firewall/VPN client.
I followed the instructions in another thread (http://www.geekzone.co.nz/forums.asp?forumid=66&topicid=138546&page_no=2) and was able to set it up so that the SonicWall is connecting via PPPoE using the Vigor as a modem via PPPoE passthrough ("wired LAN" option), but it's not stable. In this setup the SonicWall reconnects about once a minute, and it seems that there is a conflict where the Vigor and the SonicWall both try to establish a connection and block each other.
I disabled the "Always On" option and ticked "For Wired LAN" to allow PPPoE pass through, so what I don't understand is why the Vigor is still trying to connect. I can actually still use the Vigor as my main modem/router in this mode. Right now I have it set up exactly as per screenshot below and the SonicWall is connected to the Vigor as a normal DHCP client rather than via PPPoE.


I also tried removing the authentication details from this screen, but then I just get a message saying authentication failed, so it still tries to connect for some reason.
Anybody know how I can tell my Vigor to "shut up" and not connect to my Telecom VDSL connection and let the SonicWall handle the PPPoE connection?

Thanks, Frederik

Create new topic
Professional yak shaver
1599 posts

Uber Geek
+1 received by user: 8

Trusted
BitSignal
Subscriber

  Reply # 1024837 14-Apr-2014 12:26
Send private message

I think that's a bug from the Vigor interface. Mine is set to Always-ON and keeps trying to reconnect (according to the interface), but doesn't really interfere with the router.




"Roads? Where we're going, we don't need roads." - Doc Emmet Brown



23 posts

Geek


  Reply # 1024841 14-Apr-2014 12:33
Send private message

What do you mean with bug in interface? Doesn't seem like it is a UI issue only because it actually connects as well.
I would have thought this should not happen/be possible for passthrough?!

 
 
 
 


Professional yak shaver
1599 posts

Uber Geek
+1 received by user: 8

Trusted
BitSignal
Subscriber

  Reply # 1024925 14-Apr-2014 14:44
Send private message

I have entered an invalid password for mine, so it doesn't attempt to connect. ;)




"Roads? Where we're going, we don't need roads." - Doc Emmet Brown

571 posts

Ultimate Geek
+1 received by user: 76


  Reply # 1024968 14-Apr-2014 15:58
Send private message

The instructions on the local Draytek support pages worked for me when bridging to a Mikrotik:

http://www.draytek.net.nz/draytek/support/

These were written by SnapperNet (who import the Drayteks into NZ) and are specific for Chorus VDSL.



23 posts

Geek


  Reply # 1024977 14-Apr-2014 16:17
Send private message

Thanks Kraven. I saw the Snappernet doc and tried that as well but with no luck. What I didn't quite get from that document is how the PPPoE client is supposed to be configured.
When I enable MPoA on the Vigor then my SonicWall can no longer establish a PPPoE connection. The PDF in the link you provided shows a configuration with a static IP, but I assume that's not correct for Telecom. I tried with exactly the config as per documentation and with dynamic IP and neither worked. Also tried to tick the "Enable Bridge Mode" item which I would have thought is required but that can't even be ticked. It immediately unticks itself again (firmware 3.7.5).

What does your configuration on the Mikrotik side look like? Anything special there or just username/password?

2075 posts

Uber Geek
+1 received by user: 228

Subscriber

  Reply # 1025017 14-Apr-2014 17:12
Send private message

You need to follow these instructions: http://downloads.snappernet.co.nz/draytek/dv130/Draytek%20DV130%20Chorus%20VDSL%20Bridged%20Sample%20Configuration.pdf

I
 am using firmware version 3.7.5 and it works, most earlier versions didn't.


Edit:  Sorry, I've just seen your earlier post, it took me a while to write this one.

I had a few problems setting up PPPoE, the biggest one was the firmware version on the modem.  Make sure it is on the latest version.

The only other thing you need to sort out is are you going to do the VLAN tagging at the modem or on the router.  If it's the modem then the router setup is easy.

571 posts

Ultimate Geek
+1 received by user: 76


  Reply # 1025026 14-Apr-2014 17:29
Send private message

Looking at the MPoA config I have "Obtain an IP address automatically" selected with the default router name of Vigor and domain name blank. Enable Bridge Mode is unticked. I also have DSL Mode forced to VDSL2 only under General Setup. These are the only settings I have that are different from those docs.

Nothing special on the Mikrotik, just the standard PPPoE client.

Another thing to check is that the VLAN tagging setting under General Setup has "stuck" - I recall having difficulty getting this to save correctly when I first set this up but I put it down to a brain fart on my part.



23 posts

Geek


  Reply # 1025034 14-Apr-2014 17:41
Send private message

Hey graemeh & Kraven,

Thanks for the additional detail.
I double/tripple checked the VLAN id and it is set and has "stuck" on the Vigor 130. I actually didn't have an issue with that. It saved with the first attempt. And I did install the new firmware (3.7.5) and did a factory reset.
Forcing the mode to VDSL only in the "General" tab also didn't change anything for me.

The strange thing is that with PPPoA/PPPoE settings (as per my initial setup) it "works" but only for 30 seconds at a time until it disconnects again and reconnects immediately. With MPoA I don't even get a response at all. I'm just wondering whether my SonicWall is somehow not capable of connecting properly, but if only a "normal" PPPoE connection is required then that should work. Not really sure what I can try next...



23 posts

Geek


  Reply # 1025059 14-Apr-2014 18:20
Send private message

Here a few more screenshots that might help.
The SonicWall configuration for PPPoE is pretty simple/basic:


Here my MPoA configuration:

And lastly my "General" configuration on the Draytek:

Is there anything obviously wrong with it?

1213 posts

Uber Geek
+1 received by user: 148


  Reply # 1025082 14-Apr-2014 19:47
Send private message

Try setting as 1483 bridged IP LLC & then clicking the bridge button. Retry you PPPoE initiator.

Worked for me.

Credit to http://www.geekzone.co.nz/user_public.asp?user_id=37733

From this thread http://www.geekzone.co.nz/forums.asp?forumid=66&topicid=138546

295 posts

Ultimate Geek
+1 received by user: 20


  Reply # 1025085 14-Apr-2014 19:54
Send private message

nitrotech: Try setting as 1483 bridged IP LLC & then clicking the bridge button. Retry you PPPoE initiator.

Worked for me.

Credit to http://www.geekzone.co.nz/user_public.asp?user_id=37733

From this thread http://www.geekzone.co.nz/forums.asp?forumid=66&topicid=138546



This worked for me too! disable the PPPoE/PPPoA Client Mode tab and use the MPoA Static or Dynamic IP.

2075 posts

Uber Geek
+1 received by user: 228

Subscriber

  Reply # 1025132 14-Apr-2014 20:54
Send private message

Looks like it should work.  Have you got the PPPoE client disabled on the modem?

Can you check the error log on the Sonicwall for clues? Are there any relevant error messages?



23 posts

Geek


  Reply # 1025382 15-Apr-2014 09:02
Send private message

nitrotech: Try setting as 1483 bridged IP LLC & then clicking the bridge button. Retry you PPPoE initiator.

Worked for me.

Credit to http://www.geekzone.co.nz/user_public.asp?user_id=37733

From this thread http://www.geekzone.co.nz/forums.asp?forumid=66&topicid=138546

Thanks, that worked (sort of). The SonicWall connects now but again disconnects about once a minute. This is actually the same as when I set it into PPPoE passthrough mode. Then the SonicWall also can connect but disconnects very frequently.


graemeh: Looks like it should work. Have you got the PPPoE client disabled on the modem?

Can you check the error log on the Sonicwall for clues? Are there any relevant error messages?

As per above I had to change it to 1483 bridged IP LLC for it to work, but still not fully functional. PPPoE client in the modem is definitely disabled. The Vigor 130 automatically disabled PPPoE when you enable MPoA and vice versa but I did it manually first just to be sure.
The log files on the SonicWall don't say much, or rather it doesn't tell me much. Not sure whether you guys can see anything special in there (see screenshot below). All I can see is that it disconnects after 30 seconds and immediately reconnects to disconnect again after 30 seconds. It's so quick we don't even notice the downtime while browsing but anything with an established session (remote desktop, skype, lync etc.) obviously disconnects.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

CPTPP text and National Interest Analysis released for public scrutiny
Posted 21-Feb-2018 19:43


Foodstuffs to trial digitised shopping trolleys
Posted 21-Feb-2018 18:27


2018: The year of zero-login, smart cars & the biometrics of things
Posted 21-Feb-2018 18:25


Intel reimagines data centre storage with new 3D NAND SSDs
Posted 16-Feb-2018 15:21


Ground-breaking business programme begins in Hamilton
Posted 16-Feb-2018 10:18


Government to continue search for first Chief Technology Officer
Posted 12-Feb-2018 20:30


Time to take Appleā€™s iPad Pro seriously
Posted 12-Feb-2018 16:54


New Fujifilm X-A5 brings selfie features to mirrorless camera
Posted 9-Feb-2018 09:12


D-Link ANZ expands connected smart home with new HD Wi-Fi cameras
Posted 9-Feb-2018 09:01


Dragon Professional for Mac V6: Near perfect dictation
Posted 9-Feb-2018 08:26


OPPO announces R11s with claims to be the picture perfect smartphone
Posted 2-Feb-2018 13:28


Vocus Communications wins a place on the TaaS panel
Posted 26-Jan-2018 15:16


SwipedOn raises $1 million capital
Posted 26-Jan-2018 15:15


Slingshot offers unlimited gigabit fibre for under a ton
Posted 25-Jan-2018 13:51


Spark doubles down on wireless broadband
Posted 24-Jan-2018 15:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.