Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

1726 posts

Uber Geek
+1 received by user: 180


Topic # 98459 28-Feb-2012 21:54 Send private message

I have an Apacer Class4 16FB microSDHC card, for my ideos x5. Recently it has been playing up, sometimes my music app has been unable to find tracks on the card, gallery unable to find photos, etc. Its pretty much full, so I was hoping that a format would give it a fresh start.

However, I cant figure out how to succesfully format the thing!

The format function built into the phone seems to format happily - doesnt give any error - but in the end doesnt change the card.

Under disk utilities in OSX, it either seems to format happily, without giving any error, and again making no difference, or it gives a write protected error. Ditto under windows 7.

Im thinking that it could be a write protect error, but surely this shouldnt be a problem when inside the phone 'naked' without a SD - MicroSD adapter. I have been trying as well with microSD adapter, but get the same errors, and have tried toggling the write protect 'switch' on the SD adapter.

The card was bought new from notebookcity, and has been filled up with usable media in the past, I dont think it is a dodgy card (in the sense that it has less capacity than is printed on the casing).

Has anyone else experienced this before, or have any hints? Ive tried googling a number of the issues here but I'm yet to find a successful solution. The card is under warranty, but I would like to format my data before I send it off!


Create new topic


8545 posts

Uber Geek
+1 received by user: 1061

  Reply # 588077 28-Feb-2012 22:46 Send private message

Tried using any utilities that report on the disk ?

Try deleting the partion etc rather than format

1726 posts

Uber Geek
+1 received by user: 180


  Reply # 588172 29-Feb-2012 09:21 Send private message

The OSX disk utility returns the error "Free space in FSInfo block (29243) not correct (29242)" when attempting to verify the disk. After attempting to repair in the same utility, it says that it has been successful, however if I verify the disk again, the same error is given.

Ive also tried a full overwrite & quick format using the SD association formatting tool, which claims to be successful (and takes a long time in the case of a full overwrite!) but still makes no difference.

Ive tried to delete the partition under OSX disk utility, but that doesnt work (although it doesnt provide an error in the process). Under Windows disk management, it wont let me change the partition - all options are greyed out.




8545 posts

Uber Geek
+1 received by user: 1061

  Reply # 588264 29-Feb-2012 12:13 Send private message

gparted boot disc should sort it out

1348 posts

Uber Geek
+1 received by user: 15

  Reply # 588267 29-Feb-2012 12:21 Send private message

gzt: gparted boot disc should sort it out


1726 posts

Uber Geek
+1 received by user: 180


  Reply # 588299 29-Feb-2012 13:17 Send private message

Awesome, thanks, Im downloading gparted now and will give it hoon and let you all know how it goes

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

National AI group launching next month
Posted 25-May-2017 09:54

New Zealand Digital Future, according to tech companies
Posted 25-May-2017 09:51

New Microsoft Surface Pro delivers outstanding battery life, performance
Posted 25-May-2017 09:34

Garmin VIRB 360 brings immersive 360-degree 5.7K camera experience
Posted 25-May-2017 09:30

Telecommunications monitoring report: Are you being served?
Posted 24-May-2017 11:54

NetValue partners with CRM Provider SugarCRM
Posted 23-May-2017 20:04

Terabyte looms as Vocus users download 430GB a month
Posted 19-May-2017 14:51

2degrees tips into profit after seven lean years
Posted 19-May-2017 09:47

2degrees growth story continues
Posted 17-May-2017 15:25

Symantec Blocks 22 Million Attempted WannaCry Ransomware Attacks Globally
Posted 17-May-2017 12:41

HPE Unveils Computer Built for the Era of Big Data
Posted 17-May-2017 12:39

Samsung Galaxy S8 Plus review: Beautiful, feature-packed
Posted 16-May-2017 20:14

After ten years of mail pain Spark is done with Yahoo
Posted 15-May-2017 13:12

Warnings from security firms: do not click that link or risk your computer being infected
Posted 15-May-2017 10:11

Pushpay named NZ Hi-Tech Company of the Year 2017
Posted 15-May-2017 09:59

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.