Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




130 posts

Master Geek


Topic # 225443 19-Nov-2017 13:03
Send private message

Does anyone know anything about Mitsubishi heatpumps? We had one come with our house and it appears to be playing up. When we turn it on, it pushes our for about 10 min then stops. Once stopped the front fins stay open and the top green led blinks, 14 times pauses then keeps going in the same loop blinking. Any ideas?

Filter this topic showing only the reply marked as answer Create new topic
2018 posts

Uber Geek
+1 received by user: 1129


  Reply # 1904008 19-Nov-2017 13:09
Send private message

What model heatpump?




Location: Dunedin



130 posts

Master Geek


  Reply # 1904011 19-Nov-2017 13:13
Send private message

Msz-ge50vad2-a1

 
 
 
 


2018 posts

Uber Geek
+1 received by user: 1129


  Reply # 1904013 19-Nov-2017 13:18
Send private message




Location: Dunedin

1696 posts

Uber Geek
+1 received by user: 190

Subscriber

  Reply # 1904014 19-Nov-2017 13:22
Send private message

Have you tried;

 

 

 

1) switch off outdoor unit, walk around the house and then switch it back on

 

2) go back to heatpump and turn it on and see what happens

 

3) When was the last time the outdoor and indoor units were serviced / cleaned?

 

 

 

 




130 posts

Master Geek


  Reply # 1904015 19-Nov-2017 13:25
Send private message

Tried 1 and 2 a few times. It's only a month old

475 posts

Ultimate Geek
+1 received by user: 146


  Reply # 1904047 19-Nov-2017 15:21
6 people support this post

"It's only a month old " Contact the installer.


1660 posts

Uber Geek
+1 received by user: 424


  Reply # 1904057 19-Nov-2017 15:31
Send private message

Turn off the indoor unit, then turn off the outdoor unit using the outdoor isolator switch.  Leave both off for a few minutes then turn on the outdoor isolator before trying the indoor unit again.  +1 for getting it serviced however, even if you do get it going again.


1696 posts

Uber Geek
+1 received by user: 190

Subscriber

  Reply # 1904173 19-Nov-2017 18:27
2 people support this post
Send private message

k1w1k1d:

"It's only a month old " Contact the installer.



Eh best you call installer.
Details should be in the electrical cert of compliance or on a sticker on the unit.

1865 posts

Uber Geek
+1 received by user: 143

Trusted

  Reply # 1904176 19-Nov-2017 18:41
Send private message

Don't muck around yourself with a new unit ... call installer and/or retailer who sold the unit !!!   Immediately tongue-out




130 posts

Master Geek


  Reply # 1906550 23-Nov-2017 16:32
Send private message

Issue resolved, we had the installer come over and apparently something wasn't properly connected on the outside unit. Working now!


Filter this topic showing only the reply marked as answer Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.