Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

177 posts

Master Geek

# 170963 31-Mar-2015 19:45
Send private message

Has anyone got the netflix android app working with Orcon Global Mode?

If I disable global mode, it works fine.
With global mode on, connections timeout.
Blocking/redirecting the Google DNS addresses in my router still results in a timeout.

I am lead to believe this has only started with the more recent versions of the app, however even getting an older APK hasn't solved the issue.

anyone able to provide a solution?

Create new topic
895 posts

Ultimate Geek

  # 1274788 31-Mar-2015 20:38
Send private message

I believe it is due to the Netflix app being forced to use Google's DNS over the Orcon one.

You could see if your router has an option to either block google's DNS IP addreses or redirect them.

177 posts

Master Geek

  # 1274790 31-Mar-2015 20:43
Send private message

Yes... As I said above, I have tried blocking or redirecting the google DNS in my router. The netflex app just times out


847 posts

Ultimate Geek


  # 1274846 31-Mar-2015 22:31
Send private message

It "just works" for me.  Orcon UFB, Global mode on, Nexus 4, CM12 (Lollipop-based custom rom) Netflix v3.10.2 build 4360.  Just tested with House of Cards, so I know it's the US netflix site.

P.S. Genius White (i.e. Netcomm) router.

177 posts

Master Geek

  # 1275156 1-Apr-2015 12:12
Send private message

jamesrt: It "just works" for me.  Orcon UFB, Global mode on, Nexus 4, CM12 (Lollipop-based custom rom) Netflix v3.10.2 build 4360.  Just tested with House of Cards, so I know it's the US netflix site.

P.S. Genius White (i.e. Netcomm) router.

Hmm, still no luck for me.

As soon as I connect on a non 'Global Mode' connection, all is well (obviously just on the NZ library), but as soon as I switch to my Global mode connection, the whole thing just times out.

I have no issues on PC, PS4, XboxOne, iPhone or WiiU...

1534 posts

Uber Geek


  # 1275223 1-Apr-2015 13:00
Send private message

Yep no problem for me either. Orcon UFB + White Genius. Have several Android devices and all have no issues at all. Havent changed and router settings.

177 posts

Master Geek

  # 1275548 1-Apr-2015 17:25
Send private message

Well for a brief moment this afternoon I was able to login on my phone and see the US library. Attempting to play a video though resulted in 2-3 minutes of 'loading' and an eventual error message "Sorry we could not reach the Netflix service"

Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Microsoft New Zealand Partner Awards results
Posted 18-Oct-2019 10:18

Logitech introduces new Made for Google keyboard and mouse devices
Posted 16-Oct-2019 13:36

MATTR launches to accelerate decentralised identity
Posted 16-Oct-2019 10:28

Vodafone X-Squad powers up for customers
Posted 16-Oct-2019 08:15

D Link ANZ launches EXO Smart Mesh Wi Fi Routers with McAfee protection
Posted 15-Oct-2019 11:31

Major Japanese retailer partners with smart New Zealand technology IMAGR
Posted 14-Oct-2019 10:29

Ola pioneers one-time passcode feature to fight rideshare fraud
Posted 14-Oct-2019 10:24

Spark Sport new home of NZC matches from 2020
Posted 10-Oct-2019 09:59

Meet Nola, Noel Leeming's new digital employee
Posted 4-Oct-2019 08:07

Registrations for Sprout Accelerator open for 2020 season
Posted 4-Oct-2019 08:02

Teletrac Navman welcomes AI tech leader Jens Meggers as new President
Posted 4-Oct-2019 07:41

Vodafone makes voice of 4G (VoLTE) official
Posted 4-Oct-2019 07:36

2degrees Reaches Milestone of 100,000 Broadband Customers
Posted 1-Oct-2019 09:17

Nokia 1 Plus available in New Zealand from 2nd October
Posted 30-Sep-2019 17:46

Ola integrates Apple Pay as payment method in New Zealand
Posted 25-Sep-2019 09:51

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.