Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




8 posts

Wannabe Geek


Topic # 179365 5-Sep-2015 16:51

Hi, first time asking for help on here. All help very much appreciated. I couldn't find this exact subject anywhere else.

I have a Roku 3 and an LG Smart TV. I have been using Amazon Prime & Netflix USA for about a year now. I was with Slingshot.
Since the Global Mode stopped I am now trialing Unotelly. Now I have Amazon  Netflix USA working on my pc, yahh.

My problem is I can't get Amazon working on my Roku 3 - Geographic restrictions. Also I get Netflix NZ, not USA.

I have changed the DNS in my pc & my Netcomm Router. Also done the 8.8.8.8 / 8.8.4.4 thing

I am not a geek, nor a newbie. Somewhere in the middle. So I should be able to fix this.

I cannot change the country setting in my TV as it doesn't have USA as an option, tho I thought this wouldn't matter as I have been watching Amazon & Netflix USA for about a year now with Global Mode.

I have tried resetting the Roku back to factory default after signing up with Unotelly but that didn't help.
I have been researching this, but can't find a solution.
Not sure what to try next. I figure there must be a few people out there that have had the same problem.

Again, all help muchly appreciated...



Create new topic
272 posts

Ultimate Geek
+1 received by user: 22


  Reply # 1380354 5-Sep-2015 18:04
Send private message

Change the primary and secondary DNS of your router to the one provided by unotelly. you might also need to set something up on the unotelly address, like your IP address. not sure since I havent used Unotelly.



8 posts

Wannabe Geek


  Reply # 1380355 5-Sep-2015 18:07

Thanks. I have already changed the DNS address, primary & secondary to the unotelly ones on my router & my pc & my tv
It works on my laptop just not the Roku

 
 
 
 




8 posts

Wannabe Geek


  Reply # 1380356 5-Sep-2015 18:08

Also Unotelly said that there IP address would show up instead of mine

717 posts

Ultimate Geek
+1 received by user: 127


  Reply # 1380363 5-Sep-2015 18:42
One person supports this post
Send private message

Some suggestions to work through:

1) Try "unchanging" the DNS on your PC so that your PC is relying on the router settings. If you are then unable to access US netflix/Amazon on your PC then your router is not setup properly.

2) Are you sure static routes are set up properly? Confirm that you can't successfully ping 8.8.8.8 or 8.8.4.4. That said, AFAIK the public DNS are only used by the Netflix app on Roku, not Amazon.

3) Make sure your current (dynamic) IP address is registered and correct with Unotelly. "Update IP" is needed on Unotelly's site or via their app.

4) Are you sure your Roku account was setup correctly as though you were in the USA?

5) If your Roku menu doesn't show "Movies" or "TV Shows", then your Roku itself thinks its not in the USA - which in turn reflects why Amazon, Netflix and Hulu also remain geo-blocked to you.



8 posts

Wannabe Geek


  Reply # 1380378 5-Sep-2015 19:17

Thanks for all the suggestions sultanoswing. I will answer the most interesting one last.

2)  When I was talking with Unotelly today they did a ping test for 8.8.8.8 and 8.8.4.4 which didn't ping. So all good there
3)  I have an autoupdate for my IP with Unotelly I also check it
4)  Yes the Roku is definitely set up for the USA & I have been using it for nearly a year. I have a USA address & Entropay card etc. 
5)  Yes I think you are quite right, my Roku thinks it isn't in the USA. I have been using it for a year & it is only Global Mode that has changed for me. Is there something I need to change with the Roku?

1)  The most interesting & telling results.  I set the DNS back to Slingshot on my laptop & I got the geo block for Amazon! Set my laptop back to Unotelly DNS & it's working again

Conclusion is my router is not set up properly. I have changed the DNS primary & secondary address in it. Earlier this year my Roku wouldn't work, which is when I put the static routes of 8.8.8.8 / 8.8.4.4 in & then it worked. So I assume I got it right, but maybe not?? This is where maybe I'm gonna struggle as I'm not real savvy about this. I'm not bad, just not right up there with static routes etc...

I spent an hour skyping Unotelly today & we went through the router settings & they seemed to think it was ok, but I don't think it is

Any suggestions or ideas on what I need to do or check?? The DNS is correct. Just remembered when we did the ping I think I had OpenDNS settings on my laptop, so even if the router wasn't set up properly the ping would've failed. I think??

Thank you for helping me with this, my Amazon account is due to expire in a couple of days & I don't want to pay for a year if I cant get it going on my BIG tv. lol
Thank you, thank you, thank you



8 posts

Wannabe Geek


  Reply # 1380385 5-Sep-2015 19:56

Thanks to all your wonderful help sultanoswing I went and checked my router settings.

I found the problem & I feel a little silly. I had changed the DNS under DNS Server Configuration but the old DNS address was still in the LAN setup. Didn't know I had to do that.
I changed that & everything WORKS!!!!!!! I am so happy.
Maybe this might help someone else as well.

I wouldn't have thought that for a while without your suggestions. So THANKS again. You are a legend :-)

717 posts

Ultimate Geek
+1 received by user: 127


  Reply # 1380451 5-Sep-2015 22:44
Send private message

You're most welcome - great to read that you got it all working. As I have a similar set up with a Roku, and not infrequent episodes of geoblock challenges (mainly due to my interminable desire to tweak), I am pretty familar with what goes wrong with a Roku and geoblocks.

You'll find Unotelly much more functional than Ye Olde Global Mode. For example, you can set your Netflix to different regions and have the global catalog available. Well worth the extra couple of bucks/month.



8 posts

Wannabe Geek


  Reply # 1380454 5-Sep-2015 23:03

I have noticed already that the movies load faster on Amazon, still having a few issues with Netflix freezing at 25% & then "Can't play this right now". Usually after 3 tries it works, but not always. Looking forward to trying other countries too. I try not to tweak once it's working as too scared to muck it up.

On the 7th of this month I am changing ISPs from Slingshot to Unlimited Internet. Slingshot sometimes goes as slow as 10mb dl. Normally I get 30/40mb(VDSL). When it's that slow the Roku won't work. Also Slingshot is $117 mnth (with landline) Unlimited Internet is $76mnth (with viop phone). So heaps cheaper, just hope they have good speeds & I can run my Roku!! No contract, so I can change if no good.

When I change ISP's I shouldn't have to change any of my settings, should I?

If it's ok to ask, who are you with?? Do you get good speeds for the Roku?

Also as I have a near new laptop I HAVE to upgrade to Windows10 soon. Are there any known issues with my setup, that will affect Amazon & Netflix?
Although I think I might drop Amazon & just have Netflix.

Again cheers for all your help. First world problems, but I'd really miss my Roku if it didn't work, lol

717 posts

Ultimate Geek
+1 received by user: 127


  Reply # 1380456 5-Sep-2015 23:12
Send private message

No known issues with Win 10 in terms of your PC working to play Netflix.

The errors / unreliability of Netflix can be due to myriad causes....including static routes not set up (although not being able to ping the google DNS's should be a good sign). I'm with Bigpipe....the spawn / off cut of Spark. Cheap, good speeds for me, but email only helpdesk, if that's important to you. No frills - think Jetstar. Only real annoyance is their glacial roll out of UFB - still waiting here in Palmy North.



8 posts

Wannabe Geek


  Reply # 1380461 5-Sep-2015 23:37

Hadn't heard of Bigpipe. Looks similar to unlimmited internet, no frills also, but they do have phone support in NZ!
Don'y usually need helpdesk so could be worth a try if Unlimited Internet are no good.

As for UFB, it's a pipedream for me out here in Dafield. VDSL is as good as it gets. It's fast enough for Roku, so I'm happy

Cheers to you sultanoswing, you've been great. Watching Star Trek Voyager, thanks to you

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone TV — television in the cloud
Posted 17-Oct-2017 19:29


Nokia 8 review: Classy midrange pure Android phone
Posted 16-Oct-2017 07:27


Why carriers might want to embrace Commerce Commission study, MVNOs
Posted 13-Oct-2017 09:42


Fitbit launches Ionic, its health and fitness smartwatch
Posted 12-Oct-2017 15:52


Xero launches machine learning automation to improve coding accuracy for small businesses
Posted 12-Oct-2017 15:45


Bank of New Zealand uses Intel AI to detect financial crime
Posted 12-Oct-2017 15:39


Sony launches Xperia XZ1, a smartphone with real-time 3D capture
Posted 11-Oct-2017 10:26


Notes on Nokia’s phone comeback
Posted 10-Oct-2017 10:06


Air New Zealand begins Inflight Wi-Fi rollout
Posted 9-Oct-2017 20:16


The latest mobile phones in perspective
Posted 9-Oct-2017 18:34


Review: Acronis True Image 2018 — serious backup
Posted 8-Oct-2017 11:22


Lenovo launches ThinkPad Anniversary Edition 25
Posted 7-Oct-2017 23:16


Less fone, more tech as Vodafone gets brand make-over
Posted 6-Oct-2017 08:16


API Talent Achieves AWS MSP Partner Status
Posted 5-Oct-2017 21:20


Stellar Consulting Group now a Domo Partner
Posted 5-Oct-2017 21:03



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.