Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




19 posts

Geek


#270522 13-May-2020 16:40
Send private message quote this post

Hi all,

 

Just wondering if anyone else has come across issues trying to get Plex out passed the router to the real internet.

 

I am running Plex on my QNAP NAS with a static IP, and I cannot get remote access working really at all.

 

I have tried manually configuring for port 32400 as Plex suggest, and setting this up via NAT > Virtual Servers Setup on the router, but I still get an error when doing the check in Plex (well it shows green for 1 sec than returns to red/failed).

 

Does anyone else have Plex + Orcon working reliably for remote access I could rubber duckie this with?

 

Chur!


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
9728 posts

Uber Geek

Lifetime subscriber

  #2482887 13-May-2020 16:42
Send private message quote this post

do you have a public IP (Dynamic or static) address or are you on CGNAT?


14 posts

Geek


  #2482897 13-May-2020 16:54
Send private message quote this post

I would avoid exposing these types of services and instead use a VPN/Wireguard to connect that way.
Helps you avoid vulnerabilities from the services and means you to only need to have a single port open.

+ If you want a Plex alternative, take a look at Jellyfin. It's awesome free and opensource.


 
 
 
 


1797 posts

Uber Geek

Trusted
Lifetime subscriber

  #2482905 13-May-2020 17:07
Send private message quote this post

rh2600:

 

Hi all,

 

Just wondering if anyone else has come across issues trying to get Plex out passed the router to the real internet.

 

I am running Plex on my QNAP NAS with a static IP, and I cannot get remote access working really at all.

 

I have tried manually configuring for port 32400 as Plex suggest, and setting this up via NAT > Virtual Servers Setup on the router, but I still get an error when doing the check in Plex (well it shows green for 1 sec than returns to red/failed).

 

Does anyone else have Plex + Orcon working reliably for remote access I could rubber duckie this with?

 

Chur!

 

 

 

 

It will be CGNAT, Plex used to work for me, but an ISP change killed remote access (they use CG NAT). Learn to live without remote access.

 

 


'That VDSL Cat'
12343 posts

Uber Geek

Trusted
Spark
Subscriber

  #2482906 13-May-2020 17:09
Send private message quote this post

i don't recall orcon doing CGNAT. @Sounddude would be able to confirm...





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.

 


4544 posts

Uber Geek

Trusted

  #2482907 13-May-2020 17:11
Send private message quote this post

How are you actually accessing Plex remotly?

 

Trying to just hit your public IP? Or using Plex Pass with it all linked through the account?


106 posts

Master Geek


  #2482909 13-May-2020 17:11
Send private message quote this post

The answer to my CG-NAT question which was asked directly to Orcon a couple of weeks ago was that they do not use CG-NAT.




19 posts

Geek


  #2482911 13-May-2020 17:13
Send private message quote this post

Jase2985:

 

do you have a public IP (Dynamic or static) address or are you on CGNAT?

 

 

I do not have a static IP from Orcon, I simply have the dynamic one - I'm not sure if it is truly public - the one my router and plex reports is also the same as what I see on 'whatismyip' type websites - does that make it public?


 
 
 
 


903 posts

Ultimate Geek

Subscriber

  #2482918 13-May-2020 17:25
Send private message quote this post

There has been an interface bug for the last few months (across multiple updates) where the settings screen in Plex Server will show that it is unavailable externally. Only way to test is to turn off Wi-Fi on your phone and see if it works. It might be working fine.







326 posts

Ultimate Geek

Lifetime subscriber

  #2482921 13-May-2020 17:28
Send private message quote this post

rh2600:

 

JHi all,

 

Just wondering if anyone else has come across issues trying to get Plex out passed the router to the real internet.

 

I am running Plex on my QNAP NAS with a static IP, and I cannot get remote access working really at all.

 

I have tried manually configuring for port 32400 as Plex suggest, and setting this up via NAT > Virtual Servers Setup on the router, but I still get an error when doing the check in Plex (well it shows green for 1 sec than returns to red/failed).

 

Does anyone else have Plex + Orcon working reliably for remote access I could rubber duckie this with?

 

Chur!

 

 

Silly question - even with the red remote access icon have you tried accessing from outside your network?

 

Reason I ask is my Plex shows a red no-go remote access yet my family and friends up and down the country access Plex every day no issues.

 

Just a thought 





Pop OS!


326 posts

Ultimate Geek

Lifetime subscriber

  #2482922 13-May-2020 17:29
Send private message quote this post

gbwelly: There has been an interface bug for the last few months (across multiple updates) where the settings screen in Plex Server will show that it is unavailable externally. Only way to test is to turn off Wi-Fi on your phone and see if it works. It might be working fine.

 

yep that’s the one 





Pop OS!


4705 posts

Uber Geek


  #2482927 13-May-2020 17:32
Send private message quote this post

In addition to any CGNAT issues, you may have an issue with DNS rebinding protection. 

 

Google it..DNS rebinding plex

 

Depends on your router. I don't know if this is an issue for you but it gave me some problems on my fritzbox and I needed to configure the settings to allow Plex rebinding.

 

 

 

 


874 posts

Ultimate Geek


  #2482954 13-May-2020 18:00
Send private message quote this post

With regards to the green tick. I often have to wait a bit for it to turn green. In the past I had chased changing settings when it was actually working and all I had to do was patiently wait!

 

As mentioned earlier, best way to check is to test with your phone. Wifi off, play something and make sure its using direct play.

 

Even when external access tick is not green you can still view remotely. The thing is it then goes via the Plex servers and you'll usually get a degraded experience (lower quality). Hence making sure its direct play with a phone.

 

With regards to ports... usually your Plex server will be listening on a random port. You will need to NAT 32400 to this random port. For example; my server is listening on port 13428.  If your router support UPnP then this will auto forward 32400 to your servers port. If you want it to listen on 32400 thats fine, you'll still need to NAT it :)




19 posts

Geek


  #2482979 13-May-2020 18:21
Send private message quote this post

Shucks I'm embarrassed... it works :-)


492 posts

Ultimate Geek

Lifetime subscriber

  #2483029 13-May-2020 19:05
Send private message quote this post

rh2600:

 

Shucks I'm embarrassed... it works :-)

 

 

I have two daughters that use my Plex from remote a lot.  It may work from remote even with the Red Not available status but this is indirect access going through Plex servers where it is restricted to 1Mb/s or 2Mb/s for Plex Pass users and it will be transcoding the vids down to match that bandwidth restriction (and a much lower resolution). 

 

I've had this issue for some time, used to work now it doersn't and it's not my setup, my ISP, Server version, router or anything, its Plex.  If I get my daughters to connect direct to my public IP xx.xx.xx.xx:32400 (instead of going through plex.tv) it work's perfectly and without bandwidth restrictions, I can see in the Plex status and it does not transcode.

 

The red status means you cannot get direct access and it tranists through Plex's servers, not what you want done.


1015 posts

Uber Geek

Trusted

  #2483038 13-May-2020 19:17
Send private message quote this post

On orcon gig fibre. Its not CGNAT they have a real ip address (Dynamic by default).

 

You wont need static for plex.

 

I port forward publicIP:32400 -> 32400 on my internal plex lan. 

 

Got remote users using it now.

 

Click to see full size


 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic





Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Chorus completes the build and commissioning of two new core Ethernet switches
Posted 8-Jul-2020 09:48


National Institute for Health Innovation develops treatment app for gambling
Posted 6-Jul-2020 16:25


Nokia 2.3 to be available in New Zealand
Posted 6-Jul-2020 12:30


Menulog change colours as parent company merges with Dutch food delivery service
Posted 2-Jul-2020 07:53


Techweek2020 goes digital to make it easier for Kiwis to connect and learn
Posted 2-Jul-2020 07:48


Catalyst Cloud launches new Solutions Hub to support their kiwi Partners and Customers
Posted 2-Jul-2020 07:44


Microsoft to help New Zealand job seekers acquire new digital skills needed for the COVID-19 economy
Posted 2-Jul-2020 07:41


Hewlett Packard Enterprise introduces new HPE GreenLake cloud services
Posted 24-Jun-2020 08:07


New cloud data protection services from Hewlett Packard Enterprise
Posted 24-Jun-2020 07:58


Hewlett Packard Enterprise unveils HPE Ezmeral, new software portfolio and brand
Posted 24-Jun-2020 07:10


Apple reveals new developer technologies to foster the next generation of apps
Posted 23-Jun-2020 15:30


Poly introduces solutions for Microsoft Teams Rooms
Posted 23-Jun-2020 15:14


Lenovo launches new ThinkPad P Series mobile workstations
Posted 23-Jun-2020 09:17


Lenovo brings Linux certification to ThinkPad and ThinkStation Workstation portfolio
Posted 23-Jun-2020 08:56


Apple introduces new features for iPhone iOS14 and iPadOS 14
Posted 23-Jun-2020 08:28



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.