I have a popcorn A100 and I have it set up like so pc->wireless router, wireless router->nmt via network cable
I realise many of you disagree with that but for my needs its fine. Even streams well and I have never experienced any stuttering etc.

I am not very good at definitions like samba nfs etc but I have set it up as a networked drive in windows xp and can access it fine.
I use filezilla to ftp files across to it no problem at all.

Most of the time I have no issues but something is not right with the set up somewhere and I am unsure how to diagnose the issues.

2 issues I have come across so far are copying movie files from the popcorn to my pc across the network, I cannot get a file to successfully copy. ie when I write it to a dvd or usb drive it is never complete and will not play. However copying files in the opposite direction is not a problem.

Also, recently I tried to install some jukebox mods to the popcorn, in particular a music browser based on yet another movie jukebox and to install it, it required me to change file and folder permissions. I used filezilla to do this but it seems to have worked but when I try to run the music browser set up it says request cannot be processed and givews me a permissions error.

I tried to install telnet on the popcorn also but in order to do that I had to change its file permissions to make it installable and obviously that didn't work either.

So if something springs to mind could you help me out? or else give me an alternative method of installing telnet on the pch.