Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

31 posts


#27477 27-Oct-2008 19:30
Send private message

Further to previous posts I'm still encountering issues with MP and audio.  Rebuilt system, inc OS (Vista) and MP a week ago.  I'm just about to get to a stable state, with all that's needed to finalise the PVR is to get the blaster working to integrate Sky STB, then for no reason I loose audio in MP (only).  There's no problem with audio to other programs (such as Real or VMC).  I know how to sort again, re-install OS and MP, but this isn't a way to move forward with the system requiring a weekly re-build!  I'm about to tear my hair out!!  Any suggestions welcome.

Create new topic
1091 posts

Uber Geek

  #173918 27-Oct-2008 19:36
Send private message

Does it work for a while then stop working? Have you tried runing MP in non fullscreen then opening the mixer and examining it? In vista each app has it's own volume control, maybe something to do with this, combined with how you have your volume configured in MP configuration?

Do you not even get any sound effects? or is just playing media? Just with TV or with Music, My Videos etc?

Does it stop working just after you install something?

31 posts


  #173925 27-Oct-2008 19:56
Send private message

it's been working for about 5 days with no issues, was using today and when I switched channels audio just dissappeared!  Audio still present in all other applications and had not been tinkering with any settings.  That's the frustrating thing, I don't mind if I have to re-build because I've been tinkering and stuffed it up, but when I have no control of when I loose functionality is when it pushes my buttons.

I'm sure it has something to with the IR, that's when I lost it last time when setting up IR suite.  I had installed IR suite yesterday (but MP still working today) the blaster wasn't working fully.  Today I tried to access the Blaster plugin from MP GUI, an error message came thru that there was no blaster XML file present in the MP TV Server folder. MP still worked for some time afterwards, so this may be coincidental.  However, you've probably seen that I had EPG XML problems when I followed your guide but managed to get it sorted with "MrAlan's" file which has worked fine for me.

Next step is to re-install and leave the remote out and run with mouse / keyboard for a week and see if no problems.

I haven't broke it to the wife yet that it needs re-building :)


98 posts

Master Geek

  #173927 27-Oct-2008 20:03
Send private message

Are you still using HDMI for audio? Considering it's just MP playing up I'd file a bug report in the MP forums. In the meantime move to optical out if you have that option.

31 posts


  #173932 27-Oct-2008 20:21
Send private message

Hi Alan, yep was still using the HDMI, was going to move away from the HDMI but when I re-installed MP the it seemed to be working fine.  Has been ago for round a week and the HDMI still works for all other programs which is what's driving me mad!  I don't have optical on the amp in my living room, 9yr old Bose, and the only option is stereo out.

Your EPG was still going well, and that's what's frustrating as I'd re-inputted all the channel and itlooked all good.  When I re-install I'll have to do it all again.

98 posts

Master Geek

  #173942 27-Oct-2008 20:50
Send private message

Definately file a bug report then. Hazarding a guess I'd say that when the tv enters standby or is turned off it ends the HDCP handshake between it and the computer. When the tv is turned back on the Windows OS reinitiates the HDCP handshake but MP doesn't and assumes the old one is still valid thus Windows sounds work and MP's sounds don't. 

Edit* Probably a good idea to try another audio renderer in the MP Configuration as well just to rule out that possibility.

31 posts


  #173946 27-Oct-2008 20:57
Send private message

it gets even worse because today I lost audio when changing channels, not turning TV on/off or in/out of MP. I know that I'm not going to get audio back without a re-build which I may start tonight, after sending the bug report. The most frustrating thing is knowing how so many people have got MP working so well, which is why I'm persevering

1091 posts

Uber Geek

  #173958 27-Oct-2008 21:55
Send private message

Why rebuild? Either way you're goig to need to find out what's causing it. If you answer all the questions we'll be able to help you beter:

  • When it stops working does it. Does ALL audio stop working as not sound blips or anything in MP?
  • What about other parts of MP music, movies etc?
  • I presume you have MP set to use HDMI audio renderer? What happens if you chose a different one? Speakers/headphone?
  • Have you tried to use graphedit to observe the graph that MP creates?
  • Does the problem only come when you use TV? If so, only when you use analog TV?
  • Do you use DVB-T? 


31 posts


  #173997 28-Oct-2008 09:19
Send private message

Why re-build? I have encountered one or another form of audio issue since embarking on my MP journey and put a couple of posts out.  The most recent being , I lose all audio, including acknowledgement blips, which means to me (not too technical) that it's not just isolated to the processing of a/v output?  Any way back to why re-build?  You're right in the ideal world I shouldn't / wouldn't but from my previous post someone else had encountered similar problems and the only way they could resolve was a full re-build, including formating their hard drive.  I haven't quite had to go that far, but almost, last time I lost the audio the only way I could get it back was to re-install OS (VISTA). I tried uninstalling and re-installing MP on its own but still no audio.  This time I intend to re-install and see how long I can keep audio without installing IR blaster, that's when it turned to custard last time and this time.  I intend to give two weeks as it's never lasted that long so far.

I can't get ANY audio in MP, but full audio with other applications, REAL, VMC etc

Yep Audio renderer set to HDMI.

Tried changing audio out but no good.

Have not tried "graphedit"

Using DVB-T and analog for processing Sky STB input.

Pretty frustrating as you can gather.

291 posts

Ultimate Geek

  #174005 28-Oct-2008 10:24
Send private message

There is another option which might be worth trying.  Go back to a "Windows Restore Point" prior to when the audio stopped working.

"There is no way to Peace -Peace is the Way" (A. J. Muste)


1091 posts

Uber Geek

  #174045 28-Oct-2008 12:54
Send private message

Ok, well I suggest you try MP in non-fullscreen / not always on top, then fire up graphedit, start watching a channel, and in graphedit connect to the remote graph and see if you can see whats happening.

While you're at it fire the windows mixer and make sure evertyhing is ok there.

722 posts

Ultimate Geek

  #174721 30-Oct-2008 19:56
Send private message

One thing I'd recommend is to get some image snapshot software like Ghost or Trueimage. It won't sort your issue but will at least save major time in restoring back to a working image. It is invaluable for building systems and/or tweaking them.

I find that system restore points aren't of much value if you install software into partitions other than the one the OS is on.

Silverstone LC14 HTPC Case/Intel E4600 CPU/GA-EP35-DS3 MOBO/Asus EN9500GT graphics/2GB RAM/total 2TB HDD space/HVR-2200 & 2X 150MCE tuner cards/LG GGC-H20L BD Drive/MCE2005/Mediaportal/TVServer 1.1.0Final/LG 55"3D LED-TV/Denon AVR-1803 receiver/X1 projector

31 posts


  #175877 4-Nov-2008 20:58
Send private message

thanks for the advise and link, looking at the various restore options. cheers

Create new topic

News »

Freeview On Demand app launches on Sony Android TVs
Posted 6-Aug-2020 13:35

UFB hits more than one million connections
Posted 6-Aug-2020 09:42

D-Link A/NZ extends COVR Wi-Fi EasyMesh System series with new three-pack
Posted 4-Aug-2020 15:01

New Zealand software Rfider tracks coffee from Colombia all the way to New Zealand businesses
Posted 3-Aug-2020 10:35

Logitech G launches Pro X Wireless gaming headset
Posted 3-Aug-2020 10:21

Sony Alpha 7S III provides supreme imaging performance
Posted 3-Aug-2020 10:11

Sony introduces first CFexpress Type A memory card
Posted 3-Aug-2020 10:05

Marsello acquires Goody consolidating online and in-store marketing position
Posted 30-Jul-2020 16:26

Fonterra first major customer for Microsoft's New Zealand datacentre
Posted 30-Jul-2020 08:07

Everything we learnt at the IBM Cloud Forum 2020
Posted 29-Jul-2020 14:45

Dropbox launches native HelloSign workflow and data residency in Australia
Posted 29-Jul-2020 12:48

Spark launches 5G in Palmerston North
Posted 29-Jul-2020 09:50

Lenovo brings speed and smarter features to new 5G mobile gaming phone
Posted 28-Jul-2020 22:00

Withings raises $60 million to enable bridge between patients and healthcare
Posted 28-Jul-2020 21:51

QNAP integrates Catalyst Cloud Object Storage into Hybrid Backup solution
Posted 28-Jul-2020 21:40

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.