Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


ezbee

1162 posts

Uber Geek


#289434 5-Sep-2021 16:41
Send private message

In case anyone been hit by this and wondering whats going on.
Google has very helpfully revoked all older widevine versions, and their newest binary does not work with the glibc that osmc and (apparently) rasberypi is uses.
https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=318893&p=1909757&hilit=widevine#p1909757

 

So busted as it were. My 2G RPI4 stopped playing DRM content.

 

Not sure what the easiest and most expeditious way around this. 

 

If anyone has found distributions or more convenient ways around this please add your suggestions of what works.

 

Might have to swapout my RPI4 for an old Laptop, which I have temporarily setup.


Filter this topic showing only the reply marked as answer Create new topic
Affiliate link
 
 
 

Affiliate link: LastPass securely stores your passwords and other personal data.
Behodar
8299 posts

Uber Geek

Trusted
Lifetime subscriber

  #2772563 5-Sep-2021 16:50
Send private message

While I suspect this won't accomplish anything, I'd suggest that you contact Neon support (and Netflix if there's a way to do so...) and ask for suggestions. It would be good to at least make them aware that people are using RPi to watch, and that they should test with it.


  #2772584 5-Sep-2021 18:30
Send private message

Just out of interest have you updated to the latest software or is it broken even with the latest updates?


ezbee

1162 posts

Uber Geek


  #2772622 5-Sep-2021 21:12
Send private message

Thanks for the suggestions.

 

Oh yes updates to PI-OS don't help. 
Appears it can't be solved until they move PI-OS to Debian Bullseye which is some time away. 

 

LibreELEC, OSMC, CoreELEC, Xbian are ok in latest versions of these media specific Kodi distributions were able to update their core.
Its not streaming service ready out of box there is a bit of setup as not target platforms.

 

AndroidTV I just tested for PI4 and that works, though you have to Sideload Netflix app etc, as the PI version does not pick up all apps in Play.
https://konstakang.com/devices/rpi4/

I had a Linage 17.1 I was playing with but dumped as AndroidTV does not play well with mice and keyboards I have,
and sideloading app hassle and stuff.

 

I presume the Android non TV versions there will also work and may solve some of above issues.
Picture is not as good as Win10 Laptop, maybe I need to grab new APK version or its the software decoding ?

 

Otherwise another RPI distribution that is on newer Linux core, that is easy to install widevine will do just have to find one.

 

If I get time to muck about and get good results with something I'll post here. 
Otherwise I guess its the old Win10 laptop and RPI will need to find another job to do.




Wakrak
957 posts

Ultimate Geek


  #2772637 6-Sep-2021 01:46
Send private message

Got this issue today when I went to go watch the Warriors via Sky Go on my minix neo u9-h box running CoreElec (Kodi 18).

 

I follow the SlyGuy repository stuff on Reddit so thankfully Matt.H had some solutions on his website (like you mentioned OP). Had to teach myself how to do SSH manual updates since for the life of me I could not figure out Samba share. Figured it out just in time to watch the Titans put on a couple more tries 😄.

 

 

 

 


ezbee

1162 posts

Uber Geek


  #2774966 8-Sep-2021 20:59
Send private message

Raspberry PI PI-OS DRM issues has been solved and usual update will fix things.
I have tried out 

 

sudo apt update
sudo apt full-upgrade

 

Again and this time there is new update applied and everything is golden.
Netflix is back and all ok.

 

RPI Forums
https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=318893&p=1910851#p1910748

 

On other possible solutions in case info is any use to anyone else.
Oh I found the issue with Netflix on AndroidTV Linage for Pi was that sideload gives you SD resolution only.
Actually it was a worse hack as it was sideload of normal Android App, the AndroidTV one won't load, for me.
TVNZ and Neon looked full HD. Netflix more fussy that Pi is not official platform for AndroidTV.

 

I did also look at RaspEX with Kodi, but turned out to be a bit of a process to get running, and then Netflix setup a bit too much for me.

 

Anyway Pi-OS is all ok now. 


Filter this topic showing only the reply marked as answer Create new topic





News and reviews »

D-Link G415 4G Smart Router Review
Posted 27-Jun-2022 17:24


New Zealand Video Game Sales Reaches $540 Million
Posted 26-Jun-2022 14:49


Github Copilot Generally Available to All Developers
Posted 26-Jun-2022 14:37


Logitech G Introduces the New Astro A10 Headset
Posted 26-Jun-2022 14:20


Fitbit introduces Sleep Profiles
Posted 26-Jun-2022 14:11


Synology Introduces FlashStation FS3410
Posted 26-Jun-2022 14:04


Intel Arc A380 Graphics First Available in China
Posted 15-Jun-2022 17:08


JBL Introduces PartyBox Encore Essential Speaker
Posted 15-Jun-2022 17:05


New TVNZ+ streaming brand launches
Posted 13-Jun-2022 08:35


Chromecast With Google TV Review
Posted 10-Jun-2022 17:10


Xbox Gaming on Your Samsung Smart TV No Console Required
Posted 10-Jun-2022 00:01


Xbox Cloud Gaming Now Available in New Zealand
Posted 10-Jun-2022 00:01


HP Envy Inspire 7900e Review
Posted 9-Jun-2022 20:31


Philips Hue Starter Kit Review
Posted 4-Jun-2022 11:10


Sony Expands Its Wireless Speaker X-series Range
Posted 4-Jun-2022 10:25









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.