Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


rev

rev

26 posts

Geek


#91918 23-Oct-2011 08:49
Send private message

Hi

I have an old Sony STR-DE525 amp that's not been used for a few years so has gathered a bit of dust and other crud on the top cover and also down inside.

I connected it up to some Tannoy M3 speakers and and played a CD, and although there's plenty of power there is also quite a bit of crackle in the background, but only when changing the volume and only through the right speaker (I changed speakers to check that it was the channel not the speaker). I then connected the freeview box to see what happens and there is continuous low volume background crackle and a low volume overall, but no noticeable static noise when changing volume.

I know the speakers are fine, and the cd player and freeview box cause no trouble when connected to other equipment, so I'm wondering if the dust that has fallen through the grills has settled where it shouldn't be and maybe causing problems between components? It doesn't appear to have the lacquer finish over the circuit board like some other equipment has.

Is there an aerosol cleaner that would be suitable to give the board a good clean? and any other suggestions appreciated. 

Cheers
rev 

Create new topic
sbiddle
30853 posts

Uber Geek

Retired Mod
Trusted
Biddle Corp
Lifetime subscriber

  #536636 23-Oct-2011 08:54
Send private message

Don't know if it would fix the issue but CO Cleaner is great for all electronic components and PCB's.


 
 
 

Shop Mighty Ape for electronics, games, computers books and more (affiliate link).
Azzura
583 posts

Ultimate Geek

ID Verified

  #536637 23-Oct-2011 08:55
Send private message

Sounds like the volume shaft needs some tuner cleaner (what we call it in Canada) used on it. Assuming it is analog volume tuner.

rev

rev

26 posts

Geek


  #539277 30-Oct-2011 13:48
Send private message

Gave the CO Cleaner a go and probably has made a positive difference, hasn't cured the crackle completely but it is less noticeable when changing volume, so it's now a usable amp, happy with the result.

Cheers
rev 



Radiotron
152 posts

Master Geek


  #539707 31-Oct-2011 20:35
Send private message

If you are handy with a soldering iron, get hold of some good quality 60/40 lead/tin solder and look towards the UPC2581 amp driver ICs on bottom board that is opposite the power amp board (linked with pluggable pcb assemblies. They run rather hot and will go a bit dry jointed, reflow in situ with fresh solder may cure some noises - have fixed these for friends. If the IC pins won't tin due to oxidation then they have to be removed and the pins cleaned and separately tinned - don't do this unless you have good soldering skills and the tools to safely remove and refit the ICs without damage to PCB tracks. Also look for dry joints on the speaker relay pins...

rev

rev

26 posts

Geek


  #539718 31-Oct-2011 20:57
Send private message

More than happy wielding a soldering iron, so will give that a crack.

An observation - when I had the cover off and was spraying the CO cleaner around, there were four rather large IC's, two of which had brownish discolouration around the solder on the underside of the PCB, didn't pay too much attention to as it looked like a sound joint but will take the top off and give it another coat of looking at.

It's mainly been used as a two channel music amp over the 5.1 stuff so has seen long and loud sessions in it's time. What you describe matches the repairs I've done on the M3 speakers smaller bookshelf versions, M2s, which I have in a different set-up, the crossover has quite a large resistor, 10x10x20mm, can't remember off-hand any numbers but it was quite easy to replace due to it's size, maybe the amp's problem is something as easy to fix as that? Will give it a go at the weekend.

Cheers
rev
 

Radiotron
152 posts

Master Geek


  #539733 31-Oct-2011 21:41
Send private message

Sounds like you're good to go, take a look and see what you find, PM me if you a get a bit stuck, good luck!

Create new topic





News and reviews »

Synology Introduces BeeStation
Posted 23-Feb-2024 14:14


New One UI 6.1 Update Brings Galaxy AI to More Galaxy Devices
Posted 23-Feb-2024 10:50


Amazon Echo Hub Available in New Zealand
Posted 23-Feb-2024 10:40


InternetNZ Releases Internet Insights 2023
Posted 20-Feb-2024 10:31


Seagate Adds 24TB IronWolf Pro Hard Drives for Multi-user Commercial and Enterprise RAID Storage Solutions
Posted 19-Feb-2024 16:54


Seagate Skyhawk AI 24TB Elevates Edge Security Capacity and Performance
Posted 9-Feb-2024 17:18


GoPro Releases Quik Desktop App for macOS and Introduces Premium+ Subscription Tier
Posted 9-Feb-2024 17:14


Ring Introduces New Ring Battery Video Doorbell Pro
Posted 9-Feb-2024 16:51


Galaxy AI Transforms the new Galaxy S24 Series
Posted 18-Jan-2024 07:00


D-Link launches AI-Powered Aquila Pro M30 Wi-Fi 6 Mesh Systems
Posted 17-Jan-2024 20:02


Newest LG 4K Lifestyle Projector Doubles as Art Objet
Posted 9-Jan-2024 15:50


More LG Smart TV Owners Set To Enjoy the Latest webOS Upgrade
Posted 9-Jan-2024 15:45


Panasonic Announces the Z95A and Z93A With Fire TV Built In
Posted 9-Jan-2024 15:30


Amazon Echo Pop Review
Posted 8-Jan-2024 14:22


Samsung Tab S9 FE Review
Posted 17-Dec-2023 08:26









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.







Backblaze unlimited backup