Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




47 posts

Geek


Topic # 98556 1-Mar-2012 17:38
Send private message

Hi, I got my second TV Tuner this afternoon (another Hauppage WinTV-HVR 3000). Put it in and fired up DVBLink set it all up in DVBLink. Retuned WMC. Copied ACamd from my plugins folder of first tv tuner and pasted into second tuner. In the second tuners cardclient.conf I changed to viewer2 and password2. Made sure OSCam had 2 viewers set up. Cranked open WMC tried to view a Sky channel and nothing, blank screen and no viewer connected on OSCam.

So it is obviously a problem with ACamd or DVBLink. It's stopped talking to OSCam since I put the second tuner in.

What are your config files like when running two tuners? 

Create new topic


47 posts

Geek


  Reply # 589000 1-Mar-2012 17:50
Send private message

Getting this error constantly in the DVBLink_server log


2012-Mar-01 17:46:02: [E] hauppauge KSPROPERTY_HP_PILOT failed!

This only happens why trying to view a SkyTV channel. Can view all Freeview channels. 

1084 posts

Uber Geek
+1 received by user: 63

Trusted

  Reply # 589027 1-Mar-2012 18:58
Send private message

That error probably just refers to the fact that the HVR-3000 doesn't support DVB-S2 properties like pilot and roll-off. If this were a tuning problem (ie. tuner can't lock on frequencies) which it doesn't seem to be since you can tune Freeview fine then I'd be paying attention to that message. Otherwise, completely ignore it and move on. That message has nothing to do with ACAMD.

 
 
 
 




47 posts

Geek


  Reply # 589036 1-Mar-2012 19:18
Send private message

Okay. I just did a HCWClear to get rid of everything Hauppauge.

Reinstalled the drivers and setup DVBLink again along with ACamd and now I can't even get one tuner to work. It just won't talk to OSCam. Not sure what I've done or where I am going wrong.

It is bringing down all the EPG fine. I've just messed something up with ACamd. 

2985 posts

Uber Geek
+1 received by user: 293


  Reply # 589068 1-Mar-2012 20:49
Send private message

Post your oscam and acamd settings so we can have a look.
Have you tested tuning channels in DVBLink to rule out a WMC problem?






47 posts

Geek


  Reply # 589077 1-Mar-2012 21:09
Send private message

There shouldn't be any problem with OSCam. It reads the card and sits there waiting for a viewer.

There isn't a problem with the TV Tuners themselves as they can both tune into Freeview on WMC through DVBLink.

[CODE: ACamd]
newcamd:127.0.0.1:15001:1/096A/ff00:viewer1:password1:0102030405060708091011121314
[/CODE]

[CODE: OSCam]
# oscam.conf generated automatically by Streamboard OSCAM 1.10rc-svn build #5954
# Read more: http://streamboard.gmc.to/svn/oscam/trunk/Distribution/doc/txt/oscam.conf.txt

[global]
logfile = /dev/tty
nice = -1
saveinithistory = 1

[monitor]
hideclient_to = 15
appendchaninfo = 0

[newcamd]
port = 15000@096A:000000
serverip = 127.0.0.1
key = 0102030405060708091011121314
allowed = 127.0.0.1

[webif]
httpport = 16000
httpuser = admin
httppwd = admin
httprefresh = 5
httpallowed = 127.0.0.1
httphideidleclients = 1
[/CODE] 

Not sure if you want the user or server files from OSCam. 

2985 posts

Uber Geek
+1 received by user: 293


  Reply # 589081 1-Mar-2012 21:31
Send private message

darkraid: There shouldn't be any problem with OSCam. It reads the card and sits there waiting for a viewer.

There isn't a problem with the TV Tuners themselves as they can both tune into Freeview on WMC through DVBLink.

[CODE: ACamd]
newcamd:127.0.0.1:15001:1/096A/ff00:viewer1:password1:0102030405060708091011121314
[/CODE]

[CODE: OSCam]


[newcamd]
port = 15000@096A:000000
serverip = 127.0.0.1
key = 0102030405060708091011121314
allowed = 127.0.0.1



Just looking at those two parts of each config file and it looks like you need to change the acamd line to 127.0.0.1:15000:1.
You have it as 15001:1.






47 posts

Geek


  Reply # 589112 1-Mar-2012 22:39
Send private message

Hmmm that's an odd mistake. I changed it but still no luck. ACamd still ain't talking to OSCam.

Why did I have to play with it! Now it's ruined.

2985 posts

Uber Geek
+1 received by user: 293


  Reply # 589116 1-Mar-2012 22:48
Send private message

Post the oscam.user and server files as well.

One other thing ny acamd config has 15000:1/096A/ffff rather than yours which is 096A/ff00.
Maybe try that too.

And just noticed the Allowed line in the oscam config file.
I have 127.0.0.1,192.168.2.0-192.168.2.255

From memory I had to add my local network because I had problems with just the 127.0.0.1.
Maybe something else to try.  Obviously use your own local network IP range.

What card reader are you using?

If you like I could connect in to your machine remotely and have a look.






47 posts

Geek


  Reply # 589120 1-Mar-2012 23:20
Send private message

Tried all of that. Didn't work. Not sure if ACamd is working properly. Open up your ACamd monitor and then start your WMC and go to tv and copy paste your dump here.

BTW I am using a HID Omnikey 1021. 

2985 posts

Uber Geek
+1 received by user: 293


  Reply # 589123 1-Mar-2012 23:35
Send private message

Is oscam actually working - You can access it via the web admin on port 16000?






47 posts

Geek


  Reply # 589136 1-Mar-2012 23:54
Send private message

Yeap. It recognizes the card and all. OSCam is sitting there waiting for viewers to connect and give its decoding goodness but ACamd just ain't playing ball.

2985 posts

Uber Geek
+1 received by user: 293


  Reply # 589139 2-Mar-2012 00:01
Send private message

You haven't got a new firewall program installed?
Maybe disable the firewall and try again.
Firewall shouldn't block connections being made on the same machine but I have seen it happen.






47 posts

Geek


  Reply # 589553 2-Mar-2012 19:31
Send private message

Not sure what changed but it started working when I tried it before so I added the second tuner and now they are both working. Now I shall proceed to leave the settings alone and just watch t.v. Thanks!

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.