Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


64 posts

Master Geek
+1 received by user: 1


Topic # 116455 29-Apr-2013 18:17
Send private message

The Telecom Broadband settings for Non Telecom modems(http://telecom.custhelp.com/app/answers/detail/a_id/1180/~/telecom-broadband-settings-for-non-telecom-modems) tells me to set my MTU at 1500 (as opposed to the 1492 that was auto-set during my NetComm 'Basic setup')

However when I do that I lose connection to many websites (poor example, but www.tab.co.nz).

If I change back to 1500 then these same websites come back to life.

I've als got a checkbox for "Enable IPv6 for this service", will enabling this and setting MTU at 1500 resolve my connectivity issues?

Any assistance appreciated and thanks in advance

Filter this topic showing only the reply marked as answer Create new topic
2802 posts

Uber Geek
+1 received by user: 298


  Reply # 807607 29-Apr-2013 18:43
Send private message

I discovered the same. A lot of web timeouts and especially HTTPS wouldn't work properly.

So back to 1500 it went

8027 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 807792 30-Apr-2013 04:55
Send private message

Ah MTU's the answer is "it's complicated"!

Generally you want to use 1500 for PPPoA connections and 1492 for PPPoE connections.

Most ADSL2+ connections in NZ are using PPPoA.


681 posts

Ultimate Geek
+1 received by user: 222

Trusted
Spark NZ

  Reply # 808300 30-Apr-2013 23:01
2 people support this post
Send private message

Hi HaggisKiwi, you should set this to 1500 if your modem supports this (which it would appear that your does not).

We recently made a change to the Telecom site to advise people to set it to 1500 rather than 1492 as we were running into issues where people had modems that did not support a feature known as MSS-clamping which you need to run an MTU smaller than 1500. So in terms of what we advise people to do, it does appear that no matter what we advise, people will have issues.

I assume by your comments that you had issues with 1500, and had to set it back to 1492 to get secure sites (and others) to work properly?

If that's the case, then you can leave it at 1492, and happily go about your day and not be materially worse for wear with this setting. If you would like some further detail, then read on!

Technical details follow!:

MTU (max transfer unit) is all about your modem advising to our Broadband Network Gateway (BNG) the largest sized packet that it supports. Our BNG supports a 1500 byte PPP MTU.

With the issue you are describing, there are two possibilities:
1) Our BNG is not behaving correctly with a 1500 byte negotiated MTU
2) Your modem is not behaving correctly with a 1500 byte negotiated MTU

The first one is highly unlikely due to the fact that that we have hundreds of thousands of modems up and going without issue with this setting. The second one is the more likely.

Based on your symptoms I'd guess that one of the two following possibilities are occurring:
a) You modem is correctly negotiating at 1500 byte MTU, but when it is receiving a 1500 byte packet, mistakenly believing it is too big and discarding it before your PC sees it .... OR
b) You modem is still telling our BNG that it wants 1492, but then failing to do something called MSS-clamping

I wouldn't like to speculate as to which of the two possibilities is actually occurring. There may be some further possibilities that I haven't thought of.

What can you do to get it working properly at 1500?
A few things you could try:

i) Is there an option to set the MRU (independently of the MTU)? If so, set them both to 1500.
ii) See if there are any firmware updates to your modem which may fix the issue you are having.

Any further questions, please ask!

BTW, we do support a 1500 byte MTU on PPPoE connections too (e.g. Telecom UFB).

Oh and, yes, I work for Telecom.




My views are my own, and may not necessarily represent those of my employer.

1948 posts

Uber Geek
+1 received by user: 469
Inactive user


  Reply # 809384 1-May-2013 09:55
Send private message

cbrpilot: Oh and, yes, I work for Telecom.


And he should know as he built a lot of it :)



64 posts

Master Geek
+1 received by user: 1


  Reply # 809744 1-May-2013 18:23
Send private message

Master Geek,

It's a Netcomm NB640N. I can't seen an option for MRU and seems to like 1492 as MTU.

Any clues if the "Enable IPv6" should be enabled?
The manual describes this as "Select to enable IPv6 support for the connection. This enables the NB604N to Request Prefix Delegation and request an IPv6 Address."

Thanks

681 posts

Ultimate Geek
+1 received by user: 222

Trusted
Spark NZ

  Reply # 809752 1-May-2013 19:16
Send private message

No need to enable IPv6.  Telecom does not yet support IPv6.

With no options to set the MRU separately (which doesn't make a huge amount of sense anyway, but I've seen it before), the only option to run the full MTU is to see if there is a firmware update for your modem, or try a different modem.

That said, if 1492 works for you, then it's unlikley there is too much benefit in doing anything further.  




My views are my own, and may not necessarily represent those of my employer.

5261 posts

Uber Geek
+1 received by user: 2277

Trusted
Lifetime subscriber

  Reply # 809767 1-May-2013 20:12
Send private message

Is there a Telnet option?




Chorus has spent $1.4 billion on making their xDSL broadband network faster. If your still stuck on ADSL or VDSL, why not spend from $150 on a master filter install to make sure you are getting the most out of your connection?
I install - Naked DSL, DSL Master Splitters, VoIP, data cabling and general computer support for home and small business.
Rural Broadband RBI installer for Ultimate Broadband and Full Flavour

 

Need help in Auckland, Waikato or BoP? Click my email button, or email me direct: [my user name] at geekzonemail dot com


Filter this topic showing only the reply marked as answer Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.