Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




74 posts

Master Geek


# 40738 2-Sep-2009 16:55
Send private message

Hi all, amongst other things I am a network administrator for a number of companies in NZ.

Like everyone else they send email, look at websites etc every day, nothing unusual about that. Most of them have their own MTA which performs faultlessly almost all of the time...

... however over the past few weeks I've had some problems with one site in particular, they've been trying to send email to another NZ company without success. After some messing around (traceroutes, pings, telnet etc) I determined that the problem occurred after their router.

Now these guys use Xtra as their ISP so you know the drill, call the helldesk & after several weeks (or days if you're lucky) you'll finally get to someone who knows something. It helps if you have an account manager as many of my clients do...

So after a lengthy discussion with an Xtra person (more telnets, traceroutes etc etc) and me logging into other clients to check things we determined that (1) Some Xtra customers had no route to the site, others did (2) No-one (that I checked) on other ISP's had a problem. There was a suggestion that the destination site could be blocking a range of IP numbers, or that there was a problem within Xtra... so I figured it'd be sorted in a few hours. Yeah right!

Subsequently they wanted logs from mail servers etc (like that was going to tell anyone a lot - 'no route to host', but we already knew that) & then topped it off with a suggestion that the fault could be within my client's server. Hmmmm. Incidentally before even calling I tried different DNS's etc in case there was a problem there but that made no difference.

Anyway a couple of days ago I tried accessing Ecan (http://www.ecan.govt.nz) to find the site was down. Never thought any more of it at the time as I figured they were doing something & it would be back up shortly. However I've now been contacted by my client who tells me they can't access Ecan either & I've checked again to find that's still the case for me - yeah I'm on Xtra too (long story!). A traceroute shows.... no route! Now for other reasons I'd be happy if Ecan were to drop off the face of the earth but for the present I'm thinking there's something dubious going on within Xtra.

I'd be interested to hear if anyone else has a similar problem - it's clear that it's not all Xtra customers, just some, but around 50% of my Xtra clients exhibit this issue & as it's been several weeks (although the Ecan thing could be more recent) I'm starting to get a bit grumpy, particularly as they keep suggesting to my client that it's possibly something up with them >:-(

Call me overly sensitive & inclined to see fire where there isn't but I'm wondering if there's a big experiment going on with this bl**dy net filtering sh1te & we've been caught up with it somehow or is it just some other stupid thing going on within Xtra (you may imagine I've had dealings with them before over some other issues in the past!)? I'm getting nowhere with Xtra & am more and more disinclined to believe things that are said - particularly if some $#%^@!! govt experiment is involved - so hence a call to fellow network Geeks to see if you've got problems or any ideas.

Ciao, P.




Create new topic
8035 posts

Uber Geek

Trusted

  # 252672 2-Sep-2009 17:21
Send private message

Looks like that ecan site is hosted by Snap, they have transit provided by both Telecom and Telstra, also they peer at APE.

http://noc.maxnet.net.nz/cgi-bin/trace?www.ecan.govt.nz
http://network-tools.com/default.asp?prog=trace&host=www.ecan.govt.nz

Tracing route to www.ecan.govt.nz [192.148.221.70] over a maximum of 30 hops:

  4    11 ms    11 ms    10 ms  gi-4-0-879.u22.telstraclear.net [218.101.61.142]
  5    12 ms    11 ms    13 ms  218.101.61.129
  6   159 ms    21 ms    17 ms  a12-3-23.u21.tar.telstraclear.net [203.98.23.34]
  7    95 ms   215 ms   215 ms  lnk-snap.g9-0-970.u21.tar.telstraclear.net [203.98.23.222]
  8    21 ms    20 ms    20 ms  102.114.124.202.static.snap.net.nz [202.124.114.102]
  9     *        *        *

It could be some weird routing issue between certain Telecom interfaces and Snap, is the company your sites are having trouble sending email too using Snap as their ISP?



74 posts

Master Geek


  # 252710 2-Sep-2009 19:20
Send private message

Hi, thanx for the info, no the mx for .co.nz domain resolves to an Australian IP# which is owned by the recipient company concerned. There was a thought that they may have been blocking a range of Xtra IP#'s but it's fairly unlikely.

Also now with the Ecan thing (still can't get them after a couple of days) I'm more and more of the view that something weird is going on in this country somewhere. Could be complete coincidence of course & be totally unrelated but it's frustrating to have it take so long to fix & it seems almost impossible to get to someone in the big X that can actually do something.

Cheers, P.

 
 
 
 


618 posts

Ultimate Geek


  # 252751 2-Sep-2009 21:20
Send private message

I just tried www.ecan.govt.nz from a couple of different Xtra connections and no issues with access.

Do you have the same issues with connecting to other Snap hosted networks? eg. www.ccc.govt.nz?

What IP address range is your clients site on? eg. 210.54.xxx.xxx

Phaedrus: A traceroute shows.... no route!


When you say "no route" are you getting something like "no route to host" coming back, or is it just timing out? www.ecan.govt.nz doesn't repond to ping packets, so pings and traceroutes will always timeout. Can you perhaps post a sample traceroute?



74 posts

Master Geek


  # 252781 2-Sep-2009 22:47
Send private message

Hi, CCC is ok, the problem occurs from:

210.86.x.x (Static)
222.155.x.x (Dynamic)
219.88.x.x (Static)

but not from

210.54.x.x (tried several in this range)

and I do get a successful traceroute to www.ecan.govt.nz and telnet (port 25) to the .co.nz mailserver on the 'good' IP's so would expect the same on the other (which just report 'Unable to connect to remote host: No route to host').

Here's a bad one:

traceroute to www.ecan.govt.nz (192.148.221.70), 30 hops max, 40 byte packets
 1  192.168.1.1 (192.168.1.1)  7.148 ms  7.869 ms  8.109 ms
 2  192.168.1.1 (192.168.1.1)  2964.476 ms !H  2964.693 ms !H  2964.690 ms !H


and same server type on a 'good' IP range:

traceroute to www.ecan.govt.nz (192.148.221.70), 30 hops max, 40 byte packets
 1  192.168.1.1 (192.168.1.1)  253.503 ms  253.728 ms  253.723 ms
 2  * 219-89-60-1.dialup.xtra.co.nz (219.89.60.1)  300.174 ms *
 3  * * *
 4  x6-0-0-v20.akcr10.global-gateway.net.nz (202.50.238.49)  300.143 ms  300.379 ms  300.375 ms
 5  g0-1-0-4.akcr8.global-gateway.net.nz (210.55.202.49)  300.369 ms  300.608 ms *
 6  * snap-dom.akcr8.global-gateway.net.nz (202.50.237.238)  287.530 ms  330.458 ms
 7  102.114.124.202.static.snap.net.nz (202.124.114.102)  330.461 ms  330.696 ms  330.692 ms

Oh bugger, I've just now had a successful traceroute to Ecan from 210.86.28.x (but not 210.86.26.x), the plot thickens!

P.


8035 posts

Uber Geek

Trusted

  # 252788 2-Sep-2009 23:49
Send private message

Phaedrus: Hi, CCC is ok, the problem occurs from:

traceroute to www.ecan.govt.nz (192.148.221.70), 30 hops max, 40 byte packets
 1  192.168.1.1 (192.168.1.1)  7.148 ms  7.869 ms  8.109 ms
 2  192.168.1.1 (192.168.1.1)  2964.476 ms !H  2964.693 ms !H  2964.690 ms !H



That looks like it's not even getting out of the clients internal network to the ISP/Xtra to me

618 posts

Ultimate Geek


  # 252798 3-Sep-2009 07:03
Send private message

Taking a stab here... you don't by any chance have a subnet mask of 255.0.0.0 set on your 192.168.1.1 router (first traceroute)?

As Ragnor points out, those packets for ecan.govt.nz don't even appear to be leaving your network.



74 posts

Master Geek


  # 252815 3-Sep-2009 07:58
Send private message

Hi, thanks for the suggestions, as luck would have it it's working this morning - I'm not sure whether to be pleased or not! :-)

I just had a play with the subnet mask on a couple of the routers, produces some interesting results. I need to sit down at some stage & think why it should affect some sites and not others. I'm sure it's obvious but my brain hurts already this morning...

Something I forgot to mention earlier on which should have been (3) in my original post is that Xtra was able to replicate the problem internally, this led me to believe further that the problem was less likely to be mine. Additionally the Ecan issue occurred only recently & I was definate that we'd made no changes so it kept pointing elsewhere.

I'm hoping that whatever it was doesn't come back, it would be nice from a tech's perspective to find out what changed but I'm guessing I'll be unlikely to hear... if I do and/or it packs up again I'll keep you posted.

Cheers, P.

 
 
 
 


618 posts

Ultimate Geek


  # 252827 3-Sep-2009 08:34
Send private message

Glad to hear that things are working again!

Phaedrus: I just had a play with the subnet mask on a couple of the routers, produces some interesting results. I need to sit down at some stage & think why it should affect some sites and not others. I'm sure it's obvious but my brain hurts already this morning...


As a general rule, most small networks shouldn't use any subnet mask other than 255.255.255.0.

The reason I pointed this out was the ecan website is hosted on a 192.x.x.x IP address. If your router was using, say, 255.0.0.0 as its subnet mask, it would see the ecan website as "local", ie on the same subnet as the router. This would mean packets destined for the ecan website wouldn't leave your network and you would end up with a traceroute like in your first example.

Create new topic



Switch your broadband provider now - compare prices


Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41


Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30


BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14


Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24


2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35


New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13


OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32


Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27


D-Link launches Wave 2 Unified Access Points
Posted 24-Oct-2019 15:07


LG Electronics begins distributing the G8X THINQ
Posted 24-Oct-2019 10:58



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.