Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


k1wi

476 posts

Ultimate Geek


#52670 5-Dec-2009 10:41
Send private message

Some users might be aware of folding@home, a distributed computing programme run by the Pande Group at Stanford University, which utilises spare CPU resources to fold proteins in the search for cures to a wide range of diseases & illness.

Users may not be aware of a new project by the Pande Group is seeking to utilise spare HDD capacity, called Storage@home. Information for this new project can be found here: http://en.fah-addict.net/articles/articles-6-20+the-plan-for-splitting-up-data-in-storage-hom.php

During the testing of S@H, I have been in communication with the developer of the project, because he's noticed my system hasn't been communicating properly. The project communicates via port 300, and ascertains connectivity via pings & pongs. Having shared my application and firewall logs with him, we've concluded that while my system is receiving the pings from Stanford University and has processed them properly, they are unable to be returned to the Stanford servers.

This has left us wondering whether there is an ISP level issue which is causing the data to not get returned to Stanford. Perhaps the data is being blocked, either because it is a ping, or because it is using port 300.


I would appreciate any help on the situation and I am willing to provide application and router logs, as well as my correspondence with the Project Designer. Folding@home and now Storage@home are the two main reasons why I've moved to Big Time; the use of bandwidth for a such a positive and legitimate purpose.

I understand that some Telecom staff members regularly look at these forums, so it'd be great and I'd greatly appreciate it if they could help get the ball rolling to see whether there is something they can do to facilitate improving connectivity to allow other Telecom users to participate in this project. I'd also like to share any information/advice with the project manager, so that it may help them in rolling the project out to users of other ISPs around the world.


Kind Regards,

k1wi

Edit: details about storage@home and how to participate/further info on how it works can be found here: http://foldingforum.org/viewforum.php?f=56, if that helps.

Create new topic
johnr
19282 posts

Uber Geek
Inactive user


  #279504 5-Dec-2009 10:45
Send private message

Have you tried to telnet to that port from your pc?

k1wi

476 posts

Ultimate Geek


  #279510 5-Dec-2009 11:06
Send private message

I haven't tried to Telnet from my Computer (Unfortunately atm I'm offsite & it's a win7 PC so I can't SSH to it.)

One specific log in my router firewall which is of particular interest is below:


---
FIREWALL icmp check (1 of 1): Protocol: ICMP Src ip: 171.67.108.22 Dst ip: 125.238.251.192 Type: Destination Unreachable Code: Communication with Destination Host is Administratively Prohibited
---

 
 
 
 


NealR
426 posts

Ultimate Geek

Trusted
Lifetime subscriber

  #279544 5-Dec-2009 13:48
Send private message

I've fired this post as an email around a couple of people I know within Telecom who maybe able to help. WIll let you know what I hear.




The comments I write on this forum do not necessarily reflect the views of my employer and as such cannot be taken as official statements of my employer.

k1wi

476 posts

Ultimate Geek


  #279545 5-Dec-2009 13:50
Send private message

Thanks Neal, I appreciate your quick assistance!

On a Saturday none-the-less!

ptinson
677 posts

Ultimate Geek

Trusted

  #279683 6-Dec-2009 08:49
Send private message

That firewall entry appears to be saying that ICMP packets are restricted inbound on your modem. The src is the stanford IP and the dst is a telecom broadband IP (yours at the time?). Is your modem setup to allow ICMP echo requests/replies from the internet?

Is that a requirement of S@H?

Paul




meat popsicle

k1wi

476 posts

Ultimate Geek


  #279695 6-Dec-2009 10:21
Send private message

I thought that that might be the case too, but the S@H developer told me that having looked at my logs the application was receiving the pings, just unable to get them back out.

Which has me wondering whether src means the origin on the ping request (to which my network/router is replying to...) It's counter intuitive, but I'm at the limit of my technical knowledge

Also, it could be that that firewall entry is a red herring as I understand all the trafic occurs over the 300 port.

ptinson
677 posts

Ultimate Geek

Trusted

  #281084 10-Dec-2009 06:02
Send private message

As a matter of interest i installed the monitor, opened the port on the firewall and got the same result as you.

I installed it on a centos5 server so its not the same as your environment but that should be fine.

To resolve mine not working all i had to do was modify my client firewall to allow UDP:300, as soon as i did this it worked fine.

I did a tcpdump and the ICMP pings are done in this case over port 300 so you are correct all traffic is over that port. These only show up in the firewall logs as dropped ICMP packets and dont say what port...

As far as i know the only filter in the network is for port 25, it doesnt mean there arent any though. But in this case there is no filter.

So all i can suggest at this point is that you check your machines firewall client and make sure its allowing UDP:300.
I think you are right about your firewall log as well, very counter intuitive.

Let us know if you get it working.




meat popsicle

Create new topic





News »

Vodafone enables 5G roaming - for when international travel comes
Posted 30-Oct-2020 15:03


Spark awards funding to Kiwi businesses in 5G funding initiative
Posted 30-Oct-2020 14:58


Huawei launches IdeaHub Pro in New Zealand
Posted 27-Oct-2020 16:41


Southland-based IT specialist providing virtual services worldwide
Posted 27-Oct-2020 15:55


NASA discovers water on sunlit surface of Moon
Posted 27-Oct-2020 08:30


Huawei introduces new features to Petal Search, Maps and Docs
Posted 26-Oct-2020 18:05


Nokia selected by NASA to build first ever cellular network on the Moon
Posted 21-Oct-2020 08:34


Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.