Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




149 posts

Master Geek


Topic # 68539 24-Sep-2010 10:33
Send private message

Has anyone run the OpenEtna Android 2.1 build on the Telecom XT GW620?

The instructions are pretty clear, but before I launch into it keen to see if anyone else has had any joy with this?

http://openetna.com/openetna/

Looking forward to hearing your war stories.

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2

oka

1 post

Wannabe Geek


  Reply # 385121 27-Sep-2010 19:28
Send private message

I am also interested  to this projekt!

screenshoots and videos and link´s to reviews was helpful!

BR 

25 posts

Geek


  Reply # 390695 11-Oct-2010 23:00
Send private message

Has anyone got this working ive rooted my phone. Just not sure if i trust Titanium backup, if i back it up does it back up all the sms and internet settings? 
Can i back up my telecom rom so i can return to it if say the battery life is terrible? 

 
 
 
 




149 posts

Master Geek


  Reply # 390771 12-Oct-2010 09:39
Send private message

If you want to do a full NAND / ROM backup you'll need to use Nandroid.  To use Nandroid you'll need a Linux machine, it doesn't run on WIndows.

As far as Titanium Backup, I haven't used this, so can't comment.

I have spoken to Telecom who will not supply the stock ROM.  So if you want to get back to the stock Telecom ROM after upgrading you'll need to get your hands on a Nandroid backup of the ROM or go and see Telegistics who will return the phone to stock for $55.

TO get the new 2.1 or the latest 2.2 RC ROM you first need to downgrade the firmware to an easrlier version so that you have access to Fastboot.  These instructions are all on the OpenEtna site, I still gone through the process yet, planning to in the next few weeks.


25 posts

Geek


  Reply # 390868 12-Oct-2010 12:17
Send private message

Yeah ive done a nandroid backup i hope it works properly. Titanium back up should back up all the settings and not so importantly the apps. The problem i am having at the moment its Ti Backup is freezing through the process.
Might be my version of busybox. All things going well i should have android 2.2 in the next couple of dazs



149 posts

Master Geek


  Reply # 391108 12-Oct-2010 22:27
Send private message

Just completed 5 mins ago, OpenEtna 6.0RC6 running Froyo 2.2 all good.  Still working through to see if everything is okay, but picked up all my settings off the SDcard and can receive call and so far internet ect is working, will keep playing tonight.

Woohoo!



149 posts

Master Geek


  Reply # 391738 14-Oct-2010 11:55
Send private message

Everything is still all good.  Here are the instructions I followed, with links to the original locations in case the instructions change.

All credit to the various authors who worked on this, I only followed their hard work, I claim no credit for myself.  If any of the links ask for donations, please donate as they have toiled many hours getting this running sweetly.

**READ THIS CAREFULLY BEFORE STARTING**

  1. Telecom do not release their firmware as a standalone file, if you brick the phone, you will need to go to Telegistics and pay $55 to return it to the Telecom Stock ROM.

  2. You cannot use Nandroid to do a full NAND backup prior to starting a Telecom ROM does not have fastboot capability.

  3. You will need to downgrade to Orange Mobile 10H ROM to start the process, if you leave your sdcard unformatted this will boot with all XT settings and work, it will simply have Orange branding, at this stage, you could use Nandroid and take a NAND backup (if you want to).

  4. Follow every step of the instructions, and be patient.

  5. The intial downgrade process is the only point of the process that modifies the 'radio' of the phone, i.e. what frequencies the phone can connect to, hence you need to use the 850 version :)

  6. There is a forum post on Open Etna running on XT here http://forum.openetna.com/index.php?topic=28.0

Onto the good stuff;

Recover Fastboot Functionality

Use this link for the latest version Open Etna Installation Page look for the section 'Recover Fastboot'

If you have installed LG official v10I, v10N or some other version that does not have fastboot, you should downgrade using LG Utils and LG Mobile Update. (google for it)
Image with fastboot for 850 Mhz 3G: http://csmg.lgmobile.com:9002/swdata/WEBSW/GW620/AORFBB/V10h_00/V10H_00.kdz

At this stage you could do a Nandroid Backup ... I didn't :)

Now the next step, I'm really not sure if you need to do, but I rooted the phone just in case I needed some permissions to right into the system area of the phone.

Rooting the GW620

Original Post here http://androidforums.com/eve-all-things-root/49587-lg-eve-gw620-rogers-rooting-guide-remove-rogers-apps.html

Getting started

First, get yourself a copy of Android SDK (it's completely free) from here: http://developer.android.com/sdk/index.html
Read the installation guide here: http://developer.android.com/sdk/installing.html
You only need to install the SDK, not the Eclipse plugin.

If you're using Windows, you'll also need the ADB (Android Debug Bridge) USB driver. Get it from here: http://developer.android.com/sdk/win-usb.html

Download the LG USB drivers from this link.
Linux and OSX users don't need a driver (lucky you!).

How to install the LG USB and ADB USB drivers on Windows.

This is the part that I had the most problems with, but that's mainly because I read the instructions wrong!
First, install the LG USB drivers from the link above.

Then, on the phone you need to enable USB debugging mode

Settings ---> Applications ---> Development ---> USB debugging (put a check mark here)
Connect the phone to your PC with the USB cable.

In Windows, you should hear the beep on a connected device and the LG drivers should find it OK. In Windows, open up Device Manager and you should see 2 devices with yellow exclamation marks beside it and the description "LG USB Modem" (I'm going from memory here, so that may not be 100% accurate).

Right click on the 2nd one, click "Update driver software", click "Browse my computer for driver software" then click "Let me pick from a list..." You should see "Android Phone" listed. Double click this and you should see a list of 3 options. Click on "Android ADB Interface" and click "Next". You'll probably see an "Update driver warning" box, so just click "Yes" to install it anyway.

If you don't see 3 options, click "Have Disk..." and select the Android USB driver (android_winusb.inf) you downloaded earlier.

After all this, you should now be able to get ADB shell access to your Eve. To check you have access follow these steps:
If you're on Windows, open a Command Prompt window but make sure you "Run as administrator" to get the privilegies needed. Linux users can use Terminal.

Navigate to your installed Android SDK (ie: "cd c:\SDK\tools\" if that's where you installed it).
Now type "adb devices" to see if your Eve is detected. If it is, you're good to go on.

Rooting (all credit to Zacpod)

Now onto the actual root. All this is taken from Zacpod's excellent post found here: http://androidnetwork.org/forum/viewtopic.php?f=22&t=143 I'll be copying it almost verbatim, and I hope he doesn't mind

  1. Download the Superuser Whitelist (http://koushikdutta.blurryfox.com/Superuser/Superuser.zip) and unzip it somewhere safe such as c:\SDK\tools\

  2. On the GW620 dial "3845#*620#" to get in to the secret menu

  3. Tap "Module Test" then tap "Stability Test" then tap "Enable Root Permission"

  4. Open a Command Prompt on Windows by pressing Windows Key + R, then type "cmd" in the empty field. Note, you should also run this with Administrator rights. Linux users can use Terminal.

Navigate to your installed Android SDK (ie: "cd c:\SDK\tools\").

  1. Type "adb shell"

  2. You should get a #. If you get a $ then something didn't work. Shutdown the phone and PC and try again. If you get a # then all is well. Type "exit" to return to your PCs command prompt.

  3. Type "adb remount" to remount the GW620's file system as read-write so we can make changes.

  4. Type "adb shell cat /system/xbin/su > /system/xbin/su.original" [Note: This step may give you a "could not find path" error. Just continue on with step 5 and the root will still work.]

  5. Type "adb push bin/su /system/xbin/su"

  6. Type "adb push bin/su /system/bin/su"

  7. Type "adb shell chmod 4755 /system/xbin/su"

  8. Type "adb shell chmod 4755 /system/bin/su"

  9. Type "adb install bin/Superuser.apk"


You will now have root access to your Eve.

Upgrading to 2.2 (this is the moment you've been waiting for)
Original Post is back at Open Etna again http://openetna.com/openetna/about/

Requirements

You will need:


  • LG GW620

  • Android SDK: http://developer.android.com/sdk/index.html

  • Note: For windows, you need to add this to your android_winusb.inf in the android sdk usb driver in the [Google.NTx86] section for x86 or in [Google.NTamd64] section for 64bit windows:



      ;LG eve
      %SingleAdbInterface%        = USB_Install, USB\VID_18D1&PID_D00D
      %CompositeAdbInterface%     = USB_Install, USB\VID_18D1&PID_D00D&MI_01





Install


  • Backup your data! (use software available from the market, or just sync with your google account, ...)

  • Get your phone in fastboot mode:



  1. Remove battery

  2. Slide out the keyboard

  3. Plug in USB connector (still with the battery removed)

  4. Press SPACE (or SPACE+MENU for newer firmwares) just when you see the screen slightly light up, untill the fastboot text appears on the screen.

  5. If you are unable to enter fastboot, your firmware may not support it. See section "Recover fastboot"



  • If you are flashing an 'OpenEtna' image for the first time, or if the ChangeLog says that you will have to do an wipe, issue the next commands (else skip this step). This will do something similar to a factory reset and remove all userdata. You can backup your apps and their data by the very fine app "Titanium Backup" (market). As root/admin, do:

      fastboot -w






  • Flash the images. As root/admin, do:

    1. Wait until the commands finished

    2. Unplug the usb

    3. Reinsert the battery

    4. Poweron the phone

    5. Wait (On the first boot, the applications are optimized. This can take up to 10 minutes)




      fastboot flash boot boot-versionXX-.img
      fastboot flash system system-versionYY-.img




Install Google Apps
Download gapps-mdpi-20100930-signed.zip (google for it), copy it to your sdcard by

adb push gapps-mdpi-20100930-signed.zip /sdcard/gapps-mdpi-20100930-signed.zip
and reboot.

That's it.  Good luck, best to ost your questions into the forum at OpenEtna, they are the guys who really knows how this works ;)



149 posts

Master Geek


  Reply # 391987 14-Oct-2010 21:44
Send private message

Open Etna guys have said you don't need to root before loading their build, I'll amend the orginal post I made.

25 posts

Geek


  Reply # 392025 14-Oct-2010 23:38
Send private message

ive got it all flashed just waiting for it to boot *fingers crossed*



149 posts

Master Geek


  Reply # 392058 15-Oct-2010 06:51
Send private message

Ha Ha the moment of truth!  Sheesh I was packing myself at that stage.  I see from the Open Etna forums that it all went well?

Did you get adb working again?

25 posts

Geek


  Reply # 392145 15-Oct-2010 10:45
Send private message

yeah all good now. working perfect. 
I had to flash it a couple of times because it would get stuck in a loop with the cyanogen mod for ever.
Fixed when i fastboot -w before and after flash.
Adb turn out to be me being stupid. It was the combination of the phone being recognised as a different phone so i had to reinstall the drivers and then it was also in mass storage mode i think.  

16 posts

Geek


  Reply # 393775 19-Oct-2010 20:32
Send private message

I had an unsuccessful attempt at upgrading to 2.2 a couple of weeks ago and managed to brick it for three days (I was browning myself as it's a work phone).

I have been successfully able to flash to a number of different firmwares and builds, but I just couldn't make it connect to XT... On some firmwares such as Rogers or Orange I could see Vodafone and 2o, and on others I couldnt see any networks at all (e.g. the Korean V10T firmware). It has been driving me nuts and I haven't yet gotten around to trying again as I need the phone to actually work. I am extremely glad someone has figured it out and will definitely try again this coming weekend!

Because I was blind tired when I tried it the first time sometime after midnight I didnt think to backup anything or consider it might not be easy to revert. After two days of serious googling and hacking, I finally managed to figure out the exact name and location of the stock V10E Telecom XT image on LG's website.

So you can now play away with glee and not worry about bricking it. You will be able to revert to the Telecom firmware using LG-Utils. If you can't get the below, msg me and I'll email it to you.

http://csmg.lgmobile.com:9002/swdata/WEBSW/GW620f/ATNZBB/V10e_00/V10E_00.kdz

Save your $50 :)



149 posts

Master Geek


  Reply # 393776 19-Oct-2010 20:37
Send private message

Thanks! I got it, that's awesome. Yeah if you use the LG Utils to downgrade but downgrade to one that doesn't use WCDMA 850, it actually modifies the Radio so it will only connect to whatever Freq the ROM is for.

I thankfully read that somewhere before starting out or I would have done the same thing.

Only the LG Utils will modify the radio, anything else leaves it as is and just blows away the system room.

Thanks for the link ;)

Eagerly waiting for their next release so I can get BLuetooth, Camera, In Call Volume back.

Set up the phone as a wireless AP today and shared it to my colleagues using Barnacle Tethering, worked a treat. On XT the data flies down.

16 posts

Geek


  Reply # 393791 19-Oct-2010 21:02
Send private message

Yeah I dont know what I did to it... I went through the Korean, Rogers, then Vodafone EU firmwares until I figured out there were two different radio firmwares. So much for reading the instructions properly huh?

I just checked and I definitely finally flashed the same Orange firmware you referenced, but I obviously bolloxed something up somewhere. I could connect to Telecom (it said Telecom in the pull down menu), but I could not get it to actually do anything on the network and couldnt see anything in the Mobile network settings menu

I even reentered all the APNs as per the correct Telecom settings. I'm convinced the issue was with it not seeing and being able to connect to HSDPA though, not the APN settings.

I didnt root it and then when I flashed to 2.2, I lost access to the secret menu. I did find when I returned to the Telecom 1.5 image, I had to go back to the secret menu and change the mobile radio settings options to make it pickup WCDMA again, so I suspect it might have been set on GSM or something by default due to all the messing around I had done. It just appeared to deny WCDMA existed.

Anyway I'm back to stock defaults at the moment. On the plus side, I've now worked out the process to find any firmware on the lgmobile website, just need to know the phone model number and the firmware version :)

4 posts

Wannabe Geek


  Reply # 394516 21-Oct-2010 20:24
Send private message


hello guys

i need help plz

i flashed my mob to android 2.2 succ.

bet now i want go back to my original sys.

so if any on have backed up orginal system.img and boot.img can upload it for me

i searched all over the web to find them but nothing !!!



149 posts

Master Geek


  Reply # 394580 21-Oct-2010 22:27
Send private message

Here mate, use this link

http://csmg.lgmobile.com:9002/swdata/WEBSW/GW620f/ATNZBB/V10e_00/V10E_00.kdz

As above this is the Telecom firmware.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.