Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




5 posts

Wannabe Geek


Topic # 110802 16-Oct-2012 14:50
Send private message

Hi

I have been using a VFX line connected to an Asterisk server for several months with no problems.  The Asterisk server has just failed so as a temporary measure I configured my VoIP Gateway - an ATCOM AG-188N - to connect directly to VFX so I can use the phone while it is fixed.

Everything appears OK, the gateway says that it is registered and I can make calls successfully, the problem is that I can only receive calls for about 60 seconds after the registration.  After this time incoming calls go straight to the World Exchange voice mail.

If I connect to the gateway control page using a browser and cause a re-registration (by hitting APPLY on the config page) I can again receive calls for about 60 seconds.

The gateway always says that it is registered, I called WxC and they said that the device was showing as registered even though I could not receive calls at the time.

My gateway is connected to Telstra broadband (static IP) via an Apple Airport Extreme, the gateway also has a fixed IP.  The hardware configuration has not changed since I moved from Asterisk to a direct registration.  The Asterisk server was located remotely, not within my network.

The SIP config is as follows:




Any suggestions about how I can receive calls would be great, is there a difference in the configuration needed between connection via Asterisk and a direct registration from my device ? - when the VFX line was set up I specified that the connection was via Asterisk.

Thanks

Bob


Create new topic
BDFL - Memuneh
59591 posts

Uber Geek
+1 received by user: 10764

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 702095 16-Oct-2012 14:54
Send private message

Was the Asterisk server connected through this same router before?

If yes, is there any port forward setting that should be changed to the new phone IP now?

If not, is SIP ALG disabled?






5 posts

Wannabe Geek


  Reply # 702107 16-Oct-2012 15:22
Send private message

Hi,  Thanks for responding so quickly 

  • Was the Asterisk server connected through this same router before? 
The Asterisk server was hosted externally and was accessed via the internet, I am now connecting directly to WxC using the same credentials as the Asterisk server used to use.
  • If yes, is there any port forward setting that should be changed to the new phone IP now? 
I did not set up any port forwarding on the router
  • If not, is SIP ALG disabled? 
 It is NOT disabled, my understanding is that is cannot be controlled on the Airport Extreme which uses a simple NAT based firewall.

Bob


 
 
 
 


334 posts

Ultimate Geek
+1 received by user: 3

Trusted
WorldxChange

  Reply # 702143 16-Oct-2012 16:26
Send private message

Definitely sounds like an issue which is SIP ALG related and it appears the Airport Extreme doesn't support turning it off.  Doing a quick google shows people with similar issues and completely different SIP providers/equipment. 

Best bet would be to try the device behind a different router and see if the same problem occurs. 







205 posts

Master Geek
+1 received by user: 1

Trusted
WorldxChange

  Reply # 702531 17-Oct-2012 14:36
Send private message

You can try port forwarding port 5060, although if you read the following link some users have had trouble doing this:

https://discussions.apple.com/thread/2442738?start=0&tstart=0

The other option is seeing if your device supports TCP as your signalling method, not UDP, that may help.

Cheers

Josh






5 posts

Wannabe Geek


  Reply # 702545 17-Oct-2012 15:02
Send private message

Hi,

I have configured the Airport Extreme to forward port 5060 and 5061 for both TCP and UDP directly to the device (rather than relying on the default) and this seems to have fixed the problem.

I don't know which bit fixed it, but now it is working I want to leave it alone :)

Thanks to everyone for you help with this.

Regards

Bob

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel reimagines data centre storage with new 3D NAND SSDs
Posted 16-Feb-2018 15:21


Ground-breaking business programme begins in Hamilton
Posted 16-Feb-2018 10:18


Government to continue search for first Chief Technology Officer
Posted 12-Feb-2018 20:30


Time to take Appleā€™s iPad Pro seriously
Posted 12-Feb-2018 16:54


New Fujifilm X-A5 brings selfie features to mirrorless camera
Posted 9-Feb-2018 09:12


D-Link ANZ expands connected smart home with new HD Wi-Fi cameras
Posted 9-Feb-2018 09:01


Dragon Professional for Mac V6: Near perfect dictation
Posted 9-Feb-2018 08:26


OPPO announces R11s with claims to be the picture perfect smartphone
Posted 2-Feb-2018 13:28


Vocus Communications wins a place on the TaaS panel
Posted 26-Jan-2018 15:16


SwipedOn raises $1 million capital
Posted 26-Jan-2018 15:15


Slingshot offers unlimited gigabit fibre for under a ton
Posted 25-Jan-2018 13:51


Spark doubles down on wireless broadband
Posted 24-Jan-2018 15:44


New Zealand's IT industry in 2018 and beyond
Posted 22-Jan-2018 12:50


Introducing your new workplace headache: Gen Z
Posted 22-Jan-2018 12:45


Jucy set to introduce electric campervan fleet
Posted 22-Jan-2018 12:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.