Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




68 posts

Master Geek


#114324 15-Feb-2013 19:05
Send private message

Well, me again . I think you will be sick and tired of me by now... :)

I have been having this strange problem for a while, but because I wasn't too fussed about it I never bothered asking. I have an Elastix Box (Ver 2.3.0) on which I now have 3 VfX lines. (Getting more and more! )

The problem is that, although all can receive calls, only one can make calls. I use the same settings in all of them, but only my oldest number 9950xxx2 is able to make calls.
I have port 5060 forwarded to my machine (yes I am running IPTABLES with Fail2Ban). I juggle the outgoing routes to force calls out of the other channels and I always get "all circuits are busy" . As soon as I try changing the port from 5060 to 5061 in the trunk settings, it tries to connect for a while but then fails again. 
So upon running 3 vfx lines on the same machine, do I need each line to be forwarded to a separate port? (and maybe I am not forwarding correctly)? Or what other reason could make 1 line able to make calls and the other two not, when they have EXACTLY the same settings?

Here are the settings that work

username=user
type=peer
secret=pass
regseconds=180
registertimeout=20
port=5060
host=pan.wxnz.net
dtmfmode=rfc2833
disallow=all
allow=g729&ulaw&alaw
User context : 9950xxxx

username=usr
type=peer
secret=pass
nat=no
insecure=invite,port
host=pan.wxnz.net
fromuser=9950xxxx
context=from-trunk
canreinvite=no

Create new topic
29028 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #763340 16-Feb-2013 09:10
Send private message

What G729 codec do you have installed? If it's the Digium one how many channels are you licenced for?





68 posts

Master Geek


  #763342 16-Feb-2013 09:16
Send private message

Good question... I have not licenced any g729 codecs. Could that be the issue?

 
 
 
 


4542 posts

Uber Geek

Trusted

  #763353 16-Feb-2013 10:11
Send private message

G729 is licensed so if you havent paid for and applied a license your asterisk box cant use it. In saying that though I thought it would just negotiate for 711 instead.



68 posts

Master Geek


  #763573 16-Feb-2013 20:31
Send private message

Yep, tried using only ulaw and alaw, .... Same result :(

29028 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #763609 16-Feb-2013 22:28
Send private message

Could be any number of things, the only way to tell is to see Asterisk and SIP debugging of the issue to see why it's happening.

If you don't have a G.729 codec installed on your box you shouldn't be specifying it in your invite messages.



68 posts

Master Geek


  #765651 19-Feb-2013 11:27
Send private message

After a LOT of trial and error and some very useful tips from Josh I managed to find what was wrong...

It appears that Elastix does not like numbers as trunk names. I had 2 trunks, one called 0800 (my 0800 Nr) and another named after my business. Both had same settings, but only the second one worked. So the only thing different was the name. Changed it to "Freephone" and VOILA, everything is working as expected.

Managed to learn a couple of things in the process too, which is always a god thing :)

Thnx WxC!

Create new topic





Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

National Institute for Health Innovation develops treatment app for gambling
Posted 6-Jul-2020 16:25


Nokia 2.3 to be available in New Zealand
Posted 6-Jul-2020 12:30


Menulog change colours as parent company merges with Dutch food delivery service
Posted 2-Jul-2020 07:53


Techweek2020 goes digital to make it easier for Kiwis to connect and learn
Posted 2-Jul-2020 07:48


Catalyst Cloud launches new Solutions Hub to support their kiwi Partners and Customers
Posted 2-Jul-2020 07:44


Microsoft to help New Zealand job seekers acquire new digital skills needed for the COVID-19 economy
Posted 2-Jul-2020 07:41


Hewlett Packard Enterprise introduces new HPE GreenLake cloud services
Posted 24-Jun-2020 08:07


New cloud data protection services from Hewlett Packard Enterprise
Posted 24-Jun-2020 07:58


Hewlett Packard Enterprise unveils HPE Ezmeral, new software portfolio and brand
Posted 24-Jun-2020 07:10


Apple reveals new developer technologies to foster the next generation of apps
Posted 23-Jun-2020 15:30


Poly introduces solutions for Microsoft Teams Rooms
Posted 23-Jun-2020 15:14


Lenovo launches new ThinkPad P Series mobile workstations
Posted 23-Jun-2020 09:17


Lenovo brings Linux certification to ThinkPad and ThinkStation Workstation portfolio
Posted 23-Jun-2020 08:56


Apple introduces new features for iPhone iOS14 and iPadOS 14
Posted 23-Jun-2020 08:28


Apple announces Mac transition to Apple silicon
Posted 23-Jun-2020 08:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.