Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


13 posts

Geek


Topic # 13757 28-May-2007 10:34
Send private message

Hi all - I am a total noob to IP telephony but very keen to get upskilled.

I have purchased a SPA2102 with a view to set up a home telephony network. I want to use the worldxchange Xnet/VFX service and I am in the process of setting up an account. I have not received the account details yet so not sure whether that is an issue here.

I have a Belkin DSL modem, a DLink Wifi access point and CNET router. The Belkin modem provides DHCP service for the network (DLink DHCP service is swithched off)

I received my SPA2102 the other day and followed the instructions to install and setup. I wasnt able to get anythingl - couldnt get access to the SPA2102 setup at all.

As the instructions directed

1. connected SPA2102 ethernet port to my laptop
2. connected SPA2102 internet port to my modem
3. Didn't connect phone to SP2102 phone 1 port (not phone with RJ45 plug - all BT connections)
4. Opened browser to 192.168.0.1/admin/advanced

Didn't get any connection to the SPA2102 - the browser just timed out

My laptop is set to get IP dynamically so I went and changed that to the same network as SPA2102 - set the laptop to 192.168.0.49 (just to make sure it didnt clash with anything). Also disconnected the modem assuming the DHCP server might be causing a problem

This time I got an error message - server error 501

Tried swapping to Internet/Wan port on SPA2102 - still nothing

Tried connecting SPA2102 ethernet port to my CNET router and my laptop to the router as well. The modem DHCP server identified the SPA2102 and assigned it 192.168.0.12. I tried going to 192.168.0.12/admin/advanced - still nothing.


Am I missing something here? I tried swapping to another laptop just to make sure there was not some issue with my laptop since I have virtual VMnet adapters running as a result of using VMware player. I thought that could be a problem.

I am just wanting to make sure the problem is just me and not the device

Look forward to any help

Thank you





View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
3539 posts

Uber Geek
+1 received by user: 125

Trusted

  Reply # 72485 28-May-2007 10:55
Send private message

The SPA2102 is a tricky beast to initially get going, but once you have it sorted, it's brilliant.

Dynamicus: Tried connecting SPA2102 ethernet port to my CNET router and my laptop to the router as well. The modem DHCP server identified the SPA2102 and assigned it 192.168.0.12. I tried going to 192.168.0.12/admin/advanced - still nothing.

This sequence of events indicates that your CNET router is also using the 192.168.0.x range, which is going to cause problems with the Ethernet (LAN) port of your SPA2102.  Also, the DHCP server inside the SPA2102 is going to clash with the DHCP server in your CNET router.  You need to disable ONE of them.

I know, I know, how can you do that, when you can't login to the router?

Following this set of steps, as you have already done, SHOULD have worked:
=========================================================
1. connected SPA2102 ethernet port to my laptop
2. connected SPA2102 internet port to my modem
3. Didn't connect phone to SP2102 phone 1 port (not phone with RJ45 plug - all BT connections)
4. Opened browser to 192.168.0.1/admin/advanced

Didn't get any connection to the SPA2102 - the browser just timed out

My laptop is set to get IP dynamically so I went and changed that to the same network as SPA2102 - set the laptop to 192.168.0.49 (just to make sure it didnt clash with anything). Also disconnected the modem assuming the DHCP server might be causing a problem
=========================================================
However, there are a couple of things you could do differently, and see if they help:

a)  DON'T connect the Internet (WAN) port until you have things working with your laptop
b)  Make sure your laptop has the following settings in TCPIP properties:

Subnet Mask 255.255.255.0
Gateway address 192.168.0.1


Make those changes and see if you can login from your laptop.

Failing that, you would be best to get hold of a phone with RJ11 cable and reset to Factory Defaults via the IVR.  It is possible that someone has played around with your unit and stuffed up the settings.

I had much the same problems when initially getting my SPA2102 working.  For simplicity of setup, you can't beat the PAP2T which is very similar but doesn't have the Ethernet (WAN) port.  Having this extra port really complicates things because they have to be on different subnets or you are in for all sorts of problems.

If you don't ever intend to send any faxes, I would say the PAP2T is a much better buy.

I hope some of those suggestions may point you in the right direction.  Let me know how it goes.

P.S.  Welcome to Geekzone Smile

Cheers,
Grant.

3594 posts

Uber Geek
+1 received by user: 79

Trusted
WorldxChange

  Reply # 72488 28-May-2007 10:55
Send private message

Hi

The issue I think you will find is that your Router and Lan port on the SPA2102 are actualling using the same subnet
192.168.0.x,   so what you can do is disconnect the Internet side of the SPA210 and then go into the 2102 and change the subnet of the LAN port to something else, 192.168.10.x maybe, I think you will then find you will be able to logon into the device when it connects up to your router.

Once you have done this all you need to do put this line in the Voice / admin/ advanced/ provisioning setting under profile rule...if may be there already, repower the box after that. once you get an EMail from us saying your device is ready all you need to do is to repower it again and within a couple of minutes you should be good to go

http://58.28.20.69/configs/default/default$MA.cfg





Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications



13 posts

Geek


  Reply # 72536 28-May-2007 16:03
Send private message

Thanks guys for the fast replies - whew - ok will give this a go.

Also, while I was setting up the account at Xnet VFX I spoke to Aaron in the tech section and he suggested I hook up a phone to the phone port on SPA2102 then push * four times then 110#. He said that will give a readout of the actual ip address of the device.

So I am gonna have a play with all these suggestions and see how I go.

BTW grant, I wasn't sure whether to go with PAP2T, or SPA2102. I read some stuff earlier about problems with PAP2 which I understand relate unlocked US versions.

This SPA2102 is unlocked - I bought it from C1 Mall. I am just hoping it is an ok model. In any case I have also purchased a SPA3102 from Nicegear (on its way soon I hope). I just wanted to play around with these and see whether I could get a good system going here. The thing that got me looking at the SPA3102 was the FXO port.

I didnt really understand that but I am now figuring it means I can hook up directly to the wall jack - whereas the FXS ports will only hook up to a phone which then goes out over VoIP. Have I got that right?

Anyway I am assuming that this means my POTS phone can still work even if net is down?

Thanks very much guys for the terrific responses

ciao for now

Will



13 posts

Geek


  Reply # 72539 28-May-2007 16:08
Send private message

Maverick:

Once you have done this all you need to do put this line in the Voice / admin/ advanced/ provisioning setting under profile rule...if may be there already, repower the box after that. once you get an EMail from us saying your device is ready all you need to do is to repower it again and within a couple of minutes you should be good to go

http://58.28.20.69/configs/default/default$MA.cfg



Hey Maverick - link doesnt seem to work? Surprised

Cheers

Will


3267 posts

Uber Geek
+1 received by user: 77

Trusted

  Reply # 72547 28-May-2007 16:32
Send private message

The link does not work in your browser, but it does work in your VoIP config screen.  It is not a browsable web page, it is a system config address.




You can never have enough Volvos!


3539 posts

Uber Geek
+1 received by user: 125

Trusted

  Reply # 72554 28-May-2007 18:14
Send private message

Dynamicus: I read some stuff earlier about problems with PAP2 which I understand relate unlocked US versions.

Yes, that's correct.  PAP2 and PAP2-NA (US version) will not work with VFX.  PAP2T is the correct model for NZ.

Dynamicus: This SPA2102 is unlocked - I bought it from C1 Mall.

That may be why you've had problems.  Someone else has been in there playing around.  Remember you can reset to factory defaults after pressing **** from the IVR menu using a phone.  Enter 73738# (RESET) and then press 1 to confirm.

Dynamicus: ...The thing that got me looking at the SPA3102 was the FXO port.  I didnt really understand that but I am now figuring it means I can hook up directly to the wall jack - whereas the FXS ports will only hook up to a phone which then goes out over VoIP. Have I got that right?

Yes, exactly.

Dynamicus: Anyway I am assuming that this means my POTS phone can still work even if net is down?

Once again, right on the nail Smile

Good Luck and let me know how it goes.



13 posts

Geek


  Reply # 72597 28-May-2007 22:29
Send private message

Hey again,

I made some progress but still no resolution.

I hooked up a phone to the SPA2101 phone port.

I was able to access the IVR and checked IP address, subnet and gateway were all set to 0.0.0.0

I had to change the connection type to static then I was able to set the IP address subnet and gateway.

ip address to 192.168.0.1
subnet 255.255.255.0
gateway 192.168.0.1

I then set my laptop to

ip address of 192,168.0.2
subnet 255.255.255.0
gateway 192.168.0.1

Still cannot access the device tho. So not sure what next

Look forward to any ideas

Cheers

Will

3539 posts

Uber Geek
+1 received by user: 125

Trusted

  Reply # 72599 28-May-2007 22:43
Send private message

Don't worry Will, you are making progress...

The problem is that you can only set the WAN (Internet) port address from the IVR.

Now what you need to do is use Function 7932 to enable access to the Web Server from the WAN (Internet) port.

Then use function 210 to check your Local IP address (Ethernet port).

If it is also set to 192.168.0.1, you have a problem and need to set the WAN (Internet) port to a different subnet.  I used 192.168.1.x for my WAN port.

Finally, plug your laptop into the WAN port (set to whatever subnet you have used) and you should be able to access the web-based setup Cool

P.S.  One last thing:  NEVER use Bridge mode, only Router/NAT mode (function 201).  Try as I might, after many hours wasted I still could not make Bridge mode work.



13 posts

Geek


  Reply # 72610 29-May-2007 00:48
Send private message

Grant17: Don't worry Will, you are making progress...

The problem is that you can only set the WAN (Internet) port address from the IVR.

Now what you need to do is use Function 7932 to enable access to the Web Server from the WAN (Internet) port.

Then use function 210 to check your Local IP address (Ethernet port).

If it is also set to 192.168.0.1, you have a problem and need to set the WAN (Internet) port to a different subnet. I used 192.168.1.x for my WAN port.

Finally, plug your laptop into the WAN port (set to whatever subnet you have used) and you should be able to access the web-based setup Cool

P.S. One last thing: NEVER use Bridge mode, only Router/NAT mode (function 201). Try as I might, after many hours wasted I still could not make Bridge mode work.


Well folks I got in - yay!!!

Thanks very much here Grant - I used the phone to get in to the WAN side and enabled the web server using the IVR function 7932.

I then checked out the local ip address using IVR function 210 and got the address - 192.168.1.1

I then plugged my ethernet connection from my laptop to the WAN/internet port side - typed in the address 192.168.1.1/admin/advanced hey presto whammo got the Configuration page.

I should mention too that my laptop was set to

ip address 192.168.1.2
subnet 255.255.255.0
gateway 192.168.0.1

BTW it is 12:45am so I am gonna go to bed.

Next I will try and make sense of the configuration page but at least I can see it now.

THanks again all for your great support


Cheers

Will





13 posts

Geek


  Reply # 72621 29-May-2007 08:53
Send private message

Niel: The link does not work in your browser, but it does work in your VoIP config screen. It is not a browsable web page, it is a system config address.


Doh! - Okee dokee then Smile

Thanks Niel



13 posts

Geek


  Reply # 72626 29-May-2007 09:16
Send private message

maverick: Hi

Once you have done this all you need to do put this line in the Voice / admin/ advanced/ provisioning setting under profile rule...if may be there already, repower the box after that. once you get an EMail from us saying your device is ready all you need to do is to repower it again and within a couple of minutes you should be good to go

http://58.28.20.69/configs/default/default$MA.cfg



Hey Maverick,

I have been to the provisioning and profile rule and it has this already there

/spa$PSN.cfg

I take it I just copy the above link straight over it?


Also, do I hook the whole thing up as per the initial instructions, power it on just to see if it hooks up, then wait for the email then power it up?

One point I am unsure of.

My Belkin modem goes in to the WAN/Internet port of the SPA2102?
The phone goes in to the phone 1 port (obviously)
Does the ethernet port go to my CNET network router?

I thought I read somewhere that the latter doesnt work. If not, how does my internal network get out to the net?

Look forward to hearing

Cheers

3594 posts

Uber Geek
+1 received by user: 79

Trusted
WorldxChange

  Reply # 72628 29-May-2007 09:24
Send private message

Hi Will,

You can copy that link in now and repower the device, and when you get the email from us you can just restart it again, give it a few minutes and you should be good to go.

You can just Plug your SPA2102 WAN port into your router and and the Phone into port 1 and you should be good to go , I would also suggest once your setup giving your SPA2102 a fixed IP address off your Router, you will need to make sure you set the dns entry as well to be your router IP address, this just makes it a more dedicated network with out relying on DHCP.

I would think you would be getting a EMail somtime this morning as well as I believe your order is being processed




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications

3539 posts

Uber Geek
+1 received by user: 125

Trusted

  Reply # 72629 29-May-2007 09:29
Send private message

You're on the home straight now Will...

Dynamicus: ...I have been to the provisioning and profile rule and it has this already there

/spa$PSN.cfg

I take it I just copy the above link straight over it?

Yes, that's right.

Dynamicus: Also, do I hook the whole thing up as per the initial instructions, power it on just to see if it hooks up, then wait for the email then power it up?

You don't need to wait for the e-mail.  If WxC haven't got you set up at their end, the SPA2102 just won't be able to register, so the LINE 1 LED won't come on and you won't get any dial tone.  No harm will be done.

Dynamicus: My Belkin modem goes in to the WAN/Internet port of the SPA2102?
The phone goes in to the phone 1 port (obviously)
Does the ethernet port go to my CNET network router?

Here is how it hooks up:

MODEM <--> ROUTER <--> SPA2102 (WAN port)

The LAN port of your SPA2102 won't be used in this mode.  If you wish, you could dispense with your CNET router and use the SPA2102's router functions, but my impression was that they aren't particularly flash, and the SPA2102 doesn't have a huge amount of grunt to handy heavy-duty downloads.  The Tech. Support guys at WxC suggested that it was best to just use the SPA2102 as an ATA (as I have suggested above), rather than trying to use its router functions as well.

You should be up and running in no time now Smile

Cheers,
Grant.



13 posts

Geek


  Reply # 72630 29-May-2007 09:34
Send private message

Just some additoinal points for anyone else who may encounter this same problem.

I noticed when I accessed the device through the web browser interface that the LAN side had a DHCP service set to yes.

I have been able to stay connected to my internet wirelessly on my laptop and also access the SPA2102 at the same time. Now I am wondering. If I had just known the device ip was 192.168.1.1 (which I could have gotten by IVR function 210) then could I have just entered the address directly in to my browser as 192.168.1.1/admin/advanced?

Ah well hope that helps someone.

Cheers

Will

3594 posts

Uber Geek
+1 received by user: 79

Trusted
WorldxChange

  Reply # 72631 29-May-2007 09:45
Send private message

You should have an email now....saw a notification from my provisioning team so you should be good to go




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.