Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




2 posts

Wannabe Geek


#191232 28-Jan-2016 17:20
Send private message

I'm trying to get CSipSimple configured for VFX.

 

Here's how I attempted to set it up:

 

There's an "XNet" setup wizard built into CSipSimple, which asks for:

 

- "Phone number" - set to "UserID" from the sign up email (which is my phone number)

 

- "User name" - set to "AuthUser" from the sign up email

 

- "Password" - set to "AuthPassword" from the sign up email

 

Which seems very helpful, but after this CSipSimple fails to register with "Not found".

 

Then I did a long press on the XNet account entry in the list, and "Choose wizard", then selected the "Advanced" wizard (under generic wizards).

 

Tap on the XNet account entry, tap on "Proxy", and delete the currently set value of pan.wxnz.net, "OK" and "Save" - I did this based on reading a few posts here which suggested that you didn't want an outgoing proxy set. I'll file a bug to try to get the XNet wizard corrected, once I'm more confident that it's actually wrong.

 

Now CSipSimple registers OK and:

 

- Incoming calls work.

 

- Outgoing calls fail across the ADSL (which has a router doing NAT) with "408 / Request Timeout" (tested mostly with 0800 123456, the wxc number).

 

- Outgoing calls seem to work using mobile data (though the quality seems a bit patchy, perhaps due to the mobile reception here).

 

Given outgoing calls work using mobile data, it seems this is due to the NAT.  I've attempted to port forward the relevant ports to the phone, but that doesn't seem to help (possibly I'm not forwarding the correct ports though).

 

Interestingly, while trying a linux soft-phone I had ports forwarded to my PC, and managed to successfully make an outgoing call from the phone.  Frustratingly I've not managed to reproduce this at all since.

 

Any hints as to what I need to do to get this working?

 

 


Filter this topic showing only the reply marked as answer Create new topic
29027 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #1480864 28-Jan-2016 19:35
Send private message

You should never ever need to port forward any ports for VoIP to work, and while it's probably not a risk on a phone, port forwards to something such as a Cisco SPA on port 5060 are a guaranteed way create issues for yourself as every SIP bot in the world tries to compromise your device. Do you have a SIP ALG enabled in your router? This is probably the most common cause of VoIP issues.

 

I've never used CSipSimple, Bria is the best softphone solution IMHO for Android and iOS, but if you're not wanting to buy that is there a reason why you're not just using the built in Android SIP stack? The beauty of this is seamless integration with the phone dialler.




2 posts

Wannabe Geek


  #1481081 29-Jan-2016 10:11
Send private message

Yeah, the port forwarding was really just an attempt to work out what the problem was.

 

SIP ALG indeed turns out to be the issue here - I had previously combed the config menus on the router looking for anything related to SIP or the SIP ports and found nothing.  But thanks to your comment I tried searching for the model number along with SIP ALG, and it seems that some dlink routers have SIP ALG you apparently can't turn off.

 

However, it seems (at least in my case) you just can't turn it off via the web UI - I saved the router config to local disk, opened that in a text editor and found the line which mentioned "sip" and "alg" and deleted it.  Then reloaded the modified config and rebooted the router, and outgoing calls now work too.  If you try this at home, beware that the config file as saved has no newline after the final END, and if your editor adds one the router refuses to load the file with a generic error message giving no clue to the issue.  I suspect it's probably fussy about the type of line endings too.

 

I hadn't tried the Android SIP stack as I'd read comments in this forum saying it didn't support AuthID, but actually it now does and that works too.

 

I'm already using (and happy with) CSipSimple for other SIP calling, and I had seen it had an XNet wizard, so that's why I picked that for this job.  And philosophically I prefer a FOSS solution, but bria appears to be proprietary.

 

Anyway, many thanks for the reply, especially the pointer to SIP ALG - I'd read about it in older forum posts, but falsely ruled it out as not a factor here.


Filter this topic showing only the reply marked as answer Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

National Institute for Health Innovation develops treatment app for gambling
Posted 6-Jul-2020 16:25


Nokia 2.3 to be available in New Zealand
Posted 6-Jul-2020 12:30


Menulog change colours as parent company merges with Dutch food delivery service
Posted 2-Jul-2020 07:53


Techweek2020 goes digital to make it easier for Kiwis to connect and learn
Posted 2-Jul-2020 07:48


Catalyst Cloud launches new Solutions Hub to support their kiwi Partners and Customers
Posted 2-Jul-2020 07:44


Microsoft to help New Zealand job seekers acquire new digital skills needed for the COVID-19 economy
Posted 2-Jul-2020 07:41


Hewlett Packard Enterprise introduces new HPE GreenLake cloud services
Posted 24-Jun-2020 08:07


New cloud data protection services from Hewlett Packard Enterprise
Posted 24-Jun-2020 07:58


Hewlett Packard Enterprise unveils HPE Ezmeral, new software portfolio and brand
Posted 24-Jun-2020 07:10


Apple reveals new developer technologies to foster the next generation of apps
Posted 23-Jun-2020 15:30


Poly introduces solutions for Microsoft Teams Rooms
Posted 23-Jun-2020 15:14


Lenovo launches new ThinkPad P Series mobile workstations
Posted 23-Jun-2020 09:17


Lenovo brings Linux certification to ThinkPad and ThinkStation Workstation portfolio
Posted 23-Jun-2020 08:56


Apple introduces new features for iPhone iOS14 and iPadOS 14
Posted 23-Jun-2020 08:28


Apple announces Mac transition to Apple silicon
Posted 23-Jun-2020 08:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.