Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


bj99

139 posts

Master Geek


#195978 14-May-2016 16:03
Send private message

Any Mikrotik / Vodafone UFB users out there who can offer some advice?

 

I'm trying to setup my Mikrotik RB951G-2HnD router with Vodafone UFB. I understand that Vodafone does not require PPOE authentication but does require VLan tagging. Other than that I expected the exercise to be fairly straightforward...

 

Unfortunately the Mikrotik fails to connect.  I still have my vodafone issued HG659 which works perfectly.

 

My quickset screen is as follows:-

 

Click to see full size

 

My vlan settings are as follows:-

 

Click to see full size

 

My interfaces are are follows:-

 

Click to see full size

 

I must have missed something...

 

Thanks

 

 


Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
phantomdb
553 posts

Ultimate Geek

Lifetime subscriber

  #1552696 14-May-2016 17:40
Send private message

just log into the vodafone router and copy out the info.

 

------------------------------------- http://www.geekzone.co.nz/forums.asp?forumid=40&topicid=151715

 

Managed to get things working, no PPPoE config required (hence no PAP authentication).
All I needed was to get my VLAN 10 interface to request it's IP / Default GW via DHCP and its working happily!!
So must be using DHCP option 82 in my case?




[ SIGNATURE HERE ]


bj99

139 posts

Master Geek


  #1552730 14-May-2016 18:00
Send private message

phantomdb:

 

just log into the vodafone router and copy out the info.

 

------------------------------------- http://www.geekzone.co.nz/forums.asp?forumid=40&topicid=151715

 

Managed to get things working, no PPPoE config required (hence no PAP authentication).
All I needed was to get my VLAN 10 interface to request it's IP / Default GW via DHCP and its working happily!!
So must be using DHCP option 82 in my case?

 

I believe that I've already done that.


 
 
 
 


LostBoy
29 posts

Geek


  #1552732 14-May-2016 18:04
Send private message

Check your actually getting a dhcp address under dhcp client.

I would have thought it should have shown you what the address is in your quick set menu and it looked blank. I haven't ever used that for setting one up so don't know for sure though.

bj99

139 posts

Master Geek


  #1552733 14-May-2016 18:08
Send private message

LostBoy: Check your actually getting a dhcp address under dhcp client.

I would have thought it should have shown you what the address is in your quick set menu and it looked blank. I haven't ever used that for setting one up so don't know for sure though.

 

When I connect the Mikrotik to another router, it receives the DHCP settings immediately.


MadEngineer
2198 posts

Uber Geek

Trusted

  #1552749 14-May-2016 19:33
Send private message

You can't use quickset with vlan as quickset places DHCP on the port interface, not the vlan interface. You'll also find that even after setting the DHCP client to the correct port it will still fail (I didn't look at why, but possibly due to firewall). Wipe configuration and follow instructions from other threads on this.

MadEngineer
2198 posts

Uber Geek

Trusted

  #1552750 14-May-2016 19:36
Send private message

bj99:

LostBoy: Check your actually getting a dhcp address under dhcp client.

I would have thought it should have shown you what the address is in your quick set menu and it looked blank. I haven't ever used that for setting one up so don't know for sure though.


When I connect the Mikrotik to another router, it receives the DHCP settings immediately.

because the other router isn't vlan tagging the network with a DHCP server.

nitrotech
1259 posts

Uber Geek


  #1552755 14-May-2016 20:02
Send private message

bj99:

LostBoy: Check your actually getting a dhcp address under dhcp client.

I would have thought it should have shown you what the address is in your quick set menu and it looked blank. I haven't ever used that for setting one up so don't know for sure though.


When I connect the Mikrotik to another router, it receives the DHCP settings immediately.



If it does that then your problem is that your dhcp client is on ether1 it should be on vlan10 interface

That's only the start you need to update you masquerade rule and last drop rule on the firewall too

 
 
 
 


r2b2
566 posts

Ultimate Geek


  #1553062 15-May-2016 14:36
Send private message

Have you seen http://www.geekzone.co.nz/forums.asp?forumid=66&topicid=161676 which documents how to set it up?


bj99

139 posts

Master Geek


  #1553065 15-May-2016 14:52
Send private message

r2b2:

 

Have you seen http://www.geekzone.co.nz/forums.asp?forumid=66&topicid=161676 which documents how to set it up?

 

 

Yes, I followed michaelmurphy's instructions but unlike Spark, Vodafone use DHCP rather than PPOE.


nitrotech
1259 posts

Uber Geek


  #1553140 15-May-2016 16:40
Send private message

Not quite sure how to take your comments, we set these things up every day for all sorts of providers using PPPoE and dhcp

I stand by my original comment check the dhcp client is on the vlan10 interface not ether1 you also need to check the masquerade and firewall drop are also on vlan10

bj99

139 posts

Master Geek


  #1553187 15-May-2016 18:05
Send private message

nitrotech: Not quite sure how to take your comments, we set these things up every day for all sorts of providers using PPPoE and dhcp

I stand by my original comment check the dhcp client is on the vlan10 interface not ether1 you also need to check the masquerade and firewall drop are also on vlan10

 

Your suggestion is very helpful, thanks. I just haven't had a chance to give it a try yet. I am also a bit of a noob so need to research how to apply the dhcp client to the vlan interface.


MadEngineer
2198 posts

Uber Geek

Trusted

  #1553299 15-May-2016 20:09
Send private message


bj99

139 posts

Master Geek


  #1553314 15-May-2016 21:11
Send private message

Thanks MadEngineer. I must be missing something. When I try the add option in the interface window I don't see the DHCP client option. I have upgraded to the latest firmware.

 

Click to see full size

 

 


Jase2985
9950 posts

Uber Geek

Lifetime subscriber

  #1553317 15-May-2016 21:23
Send private message

your setup looks different to mad engineers

 

he has a VLAN10 under ether1 and under that is WAN which looks like that one which has the DHCP applied on

 

yours doesnt looks like that


nitrotech
1259 posts

Uber Geek


  #1553318 15-May-2016 21:31
Send private message

go down the left hand panel to ip - then click dhcp client - douple click the only entry that's there and change from ether1 to vlan1 - if you don't change the masquerade rule you still won't have internet even though it will be connected - if you don't change the drop rule then you'll be hacked


 1 | 2
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic




News »

Amazon introduces new Echo devices
Posted 25-Sep-2020 11:56


Mad Catz introduces new S.T.R.I.K.E. 13 Mechanical Gaming Keyboard
Posted 25-Sep-2020 11:34


Vodafone NZ upgrades international submarine network
Posted 25-Sep-2020 09:09


Jabra announces wireless noise-cancelling airbuds, upgrade existing model
Posted 24-Sep-2020 14:43


Nokia 3.4 to be available in New Zealand
Posted 24-Sep-2020 14:34


HP announces new HP ENVY laptops aimed at content creators
Posted 24-Sep-2020 14:02


Logitech introduce MX Anywhere 3
Posted 21-Sep-2020 21:17


Countdown unveils contactless shopping with new Scan&Go tech
Posted 21-Sep-2020 09:48


HP unveils new innovations for businesses adapting to rapidly evolving workstyles and workforces
Posted 17-Sep-2020 15:36


GoPro launches new HERO9 Black camera
Posted 17-Sep-2020 09:45


Telecommunications industry launches new 5G Facts website
Posted 17-Sep-2020 07:56


New Zealand ranks 3rd in world in GSMA index
Posted 15-Sep-2020 10:13


Trend Micro Security Suite adds web monitoring to prevent identity theft
Posted 14-Sep-2020 15:37


NVIDIA to acquire Arm for US$ 40 billion
Posted 14-Sep-2020 12:27


Epson launches its next gen A3+ colour EcoTank multi-function printer
Posted 10-Sep-2020 16:08



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.