I discovered the xnet usage monitor plugin can be run on Firefox 3 with a couple of small tweaks...

1. Download the exention, rather than installing it.  
2. Rename the .xpi file to .zip
3. Open and edit the Install.rdf file, change the MaxVersion to 3.*
4. Rename the .zip back to .xpi
5. Open about:config and create this preference if it doesn't already exist. 
    extensions.checkUpdateSecurity=false
    nb: It seams to update itself back to true whenever you restart firefox, but allows the installation to go ahead.
6. In firefox open the new .xpi file, and install away....