Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


8 posts

Wannabe Geek


Topic # 22789 8-Jun-2008 16:09
Send private message

I'm using asterisk with VFX. Everything seems to work ok except that when people call they hear no ringing on their end.
[edit: once the call is connected they get audio and the call proceeds normally.]

Any ideas what might be causing this?

My sip.conf matches the config recommended in this forum.
Extensions.conf has a 'from-sip' context that goes straight to a Dial command. I've tried adding the 'r' option with no success.

Cheers
Hauptmech

Create new topic
26613 posts

Uber Geek
+1 received by user: 6103

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 136447 8-Jun-2008 16:11
Send private message

Do they get audio when the call is actually connected?



8 posts

Wannabe Geek


  Reply # 136456 8-Jun-2008 17:01
Send private message

Yes, they get audio. There's just silence between the time they dial and when I pick up.

I have a softphone (eyebeam) and a patton M-ATA if that info helps; but I'm guessing that ring feedback for the caller is done by either xnet or my asterisk box. 


26613 posts

Uber Geek
+1 received by user: 6103

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 136465 8-Jun-2008 17:15
Send private message

Are you are answering the call within Asterisk and then transferring it to an extension?




8 posts

Wannabe Geek


  Reply # 136469 8-Jun-2008 17:24
Send private message

Not sure, I don't think so.

my extensions.conf
------
[globals]
VFXNUMBER = 49998888

[dialout]
exten => _X.,1,Dial(SIP/VFX/${EXTEN:0})
exten => _X.,2,Hangup

[from-sip]
exten => ${VFXNUMBER},1,Dial(SIP/potsphone&SIP/softphone,30,Ttrm)
exten => ${VFXNUMBER},2,Hangup

[default]
include => dialout
include => from-sip
------

my sip.conf entry for VFX belongs to the 'from-sip' context.

205 posts

Master Geek
+1 received by user: 1

Trusted
WorldxChange

  Reply # 136606 9-Jun-2008 09:04
Send private message

try running a trace on your machine to see if you are sending out ringing (180/183) messages.. you can do this by doing something like:

ngrep -d eth0 port 5060 and host 58.28.20.150

where eth0 is your ethernet card..

this will give you all of the information being passed out from your box on port 5060, you should see from the sip messaging if you are sending out ringing.. dependant on how things are setup as said above you could be answering straight away and not producing ringing..

PM me your number too so I can have a look from our end to see what you are sending out..

Cheers

Josh






8 posts

Wannabe Geek


Reply # 137285 11-Jun-2008 12:04
Send private message

Problem solved!

It turns out that the 'm' option in the dial command tells asterisk to play on-hold music (or silence in my case since none was queued up). I removed that option and now outside callers hear the normal ringing.

My bad for implementing an example config file and not RTFMing.

A big thanks to Josh for holding my hand on this.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft Dynamics 365 Business Central launches
Posted 10-Jul-2018 10:40


Spark completes first milestone in voice platform upgrade
Posted 10-Jul-2018 09:36


Microsoft ices heated developers
Posted 6-Jul-2018 20:16


PB Technologies charged for its extended warranties and warned for bait advertising
Posted 3-Jul-2018 15:45


Almost 20,000 people claim credits from Spark
Posted 29-Jun-2018 10:40


Cove sells NZ's first insurance policy via chatbot
Posted 25-Jun-2018 10:04


N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.