Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


3 posts

Wannabe Geek


Topic # 240079 19-Aug-2018 15:49
Send private message quote this post

Hi

 

First post here. I hope someone could help me out.

 

I've just got a Fibre connection through Vodafone (900MBps/450MBps).
All is well if I use the provided HG659 router.

We already have a Draytek Vigor 2960 and would like to use this as our router instead of the HG659.
When I configure the WAN interface on the Draytek for the Vodafone fibe (DHCP, VLAN 10) I only get a pathetic 2Mbps download on speedtest.net
This same router has been previously used with a 2talk fibre connection (100Mbps/100Mbps) and was working fine.

 

To troubleshoot a bit further I would like to use the provided HG659 as a bridge and connect it to the WAN interface of the Draytek 2960.

 

I managed to login as admin into the HG659 and set the Ethernet WAN connection to bridge mode, leaving VLAN 10 and DHCP and the WAN interface.
I also disabled DHCP on the LAN interfaces, the firewall, wifi and UPNP.
I set the HG659 LAN interface with a static ip 192.168.200.200

Now I'm not sure how to configure the Draytek's WAN interface.

 

I tried to configure the WAN interface with an IP in the same subnet as the HG659 (like 192.168.200.201) and use the HG659 IP as the default gateway.
I tried with VLAN set to 10 and VLAN disabled.

I also tried to configure the Draytek WAN interface with DHCP thinking that DHCP settings from Vodafone would make their way through the bridge.

 

To make a long story short, none of my attempts resulted in a working bridged internet connection.
What am I doing wrong?

Is it possible that only a specific LAN interface can be used as a bridge? All my tests were done with LAN1 from HG659 connected to Draytek WAN.

The Vodafone instructions on configuring bridge mode stop at the HG659, they don't tell you the settings on the third-party router.
Spark instruction for bridging the HG659 says to disable VLAN on the third-party router but they use PPPoE and not WAN DHCP.

 

Any help would be greatly appreciated.

 

Thanks!

 

Raf


Create new topic
5148 posts

Uber Geek
+1 received by user: 1672


  Reply # 2075846 19-Aug-2018 16:11
One person supports this post
Send private message quote this post

Far far better to establish why the Draytek is under performing than have the HG659 bridging the connection.


28 posts

Geek
+1 received by user: 13

Trusted
Vodafone

  Reply # 2075847 19-Aug-2018 16:14
Send private message quote this post

Hi Rafw,

 

Awesome post with awesome details :).

 

My recommendation would be to take the HG659 back to default and all you will need to do is change the LAN IP to 192.168.200.1, leaving DHCP still on just in case you want to attach anything direct to the HG659 in future so you can keep testing the speed :).

 

Next is to set the Draytek's WAN port to DHCP without VLAN tagging (the HG659 does not have traffic tagged to VLAN 10 on the LAN, only on WAN port. This is to talk to the ONT's LAN port) and make sure the Draytek's Lan IP subnet is not 192.186.200.1-254.

 

No PPPOE or anything needed on the draytek, just DHCP.

 

Test this with a PC direct to the HG659 first to confirm service flow and speed, then test the Draytek and see how this goes.

 

Shaun.


27120 posts

Uber Geek
+1 received by user: 6562

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 2075853 19-Aug-2018 16:37
One person supports this post
Send private message quote this post

Sticking a HG659b in between the ONT and the Draytek is an illogical thing to do. There is no reason why you would want to do this. The Draytek will work fine with UFB, so you need to poinpoint what you're doing wrong.

 

The HG659b can't bridge the connection the way you want it to do - if you want that device in between your best solution is to use it with double NAT (which once again is illogical as well).

 

Secondly I hope you aware you won't get anywhere close to 900Mbps on that Draytek? While the HG659b will happily route full speed Gigabit the that Draytek won't get anywhere near that.

 

 




3 posts

Wannabe Geek


  Reply # 2076001 20-Aug-2018 09:05
Send private message quote this post

Thanks to everyone for your quick reply. What an awesome community.

 

Bridging the HG659 is only part of my troubleshooting.

Please understand that because of the nature of the "fault" I am stuck between a rock and a hard place.
Draytek is likely to point the finger at Vodafone and Vodafone at Draytek.

 

I have already raised a support ticket with Draytek and was told to upgrade to their latest and greatest firmware and factory reset the router.
None of these made a difference.

Oddly, I get the full 950Mbps on Draytek 2860L which is supposedly a less performing router than the Draytek 2960.
I been installing and supporting Draytek routers for years, but this is the first model 2960 I use and maybe I have a dud.

I'm about to get in touch with Vodafone about this issue. But I'm not holding my breath since the connection is going full speed when using a Draytek 2860L or an Edgerouter X.

What else do you suggest I try to troubleshoot the slow speed I'm getting on Vodafone fibre and the Draytek 2960?
Download is stuck at 2Mbps but upload is the 250Mbps.

Thanks again for the help, this is greatly appreciated.


3682 posts

Uber Geek
+1 received by user: 2128

Trusted
Lifetime subscriber

  Reply # 2076004 20-Aug-2018 09:12
One person supports this post
Send private message quote this post

No need to contact Vodafone the connection is working as it should

 

John





Ex JohnR VodafoneNZ 17 years 4 days



3 posts

Wannabe Geek


  Reply # 2076007 20-Aug-2018 09:14
Send private message quote this post

Except it is not working on the Draytek 2960. My current 2talk fibre connection is working ok on the 2960.
So something is up but what?


2063 posts

Uber Geek
+1 received by user: 342

Lifetime subscriber

  Reply # 2076029 20-Aug-2018 09:42
One person supports this post
Send private message quote this post

Simply because its not a Vodafone issue so how could they help.


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.