Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


10 posts

Wannabe Geek


Topic # 28507 2-Dec-2008 15:33
Send private message

Hi all,

I have been trying to get the Gmail java app working on my W910i phone, but have been unable to get it working. I have used the vodafone "Internet" profile for it to connect (as mentioned on a topic here somewhere), and I can sign in, but once I start to retrieve the emails I get an "sorry, gmail for mobile will not work on your phone. your phone doesn't have the appropriate certificate to communicate with the server. try accessing gmail for mobile on your mobile browser at http://mail.google.com"

I had read that this relates to the security certs on the phone (surprise surprise), but I checked and I have the correct Verisign cert installed under Java certs.

When I try to browse to the mail.google.com page I get a "communication failure. secure connection failed". I am not sure how to get past this error, but I believe it relates to not being able to use SSL on the phone, or vodafone not allowing SSL.

I haven't been able to find much info on vodafone's forums with regards to SSL or secure connection errors.

So, anyone have any ideas?

Is the cert error an indicator of something else wrong?

Has anyone with a vodafone phone been able to use the gmail app or get to the gmail site? Or connect to a secure site for that matter?

Create new topic
19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  Reply # 181591 2-Dec-2008 15:44
Send private message

I use it 20+ times a day on my Nokia 6121



10 posts

Wannabe Geek


  Reply # 181593 2-Dec-2008 15:48
Send private message

Fair enuff,

So do you use the "internet" APN for the app?

Are there any special settings to enable SSL for vodafone? So I can at least get the mail.google.com page working?

19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  Reply # 181604 2-Dec-2008 16:11
Send private message

The access point i use is vfnz internet with the apn www.vodafone.net.nz

1780 posts

Uber Geek
+1 received by user: 35

Trusted

  Reply # 181606 2-Dec-2008 16:15
Send private message

are you able to access other sites ... if you are able to then those certs would indicate that you need to do update on your java engine and gmail app, think it is 1.5 something.



10 posts

Wannabe Geek


  Reply # 181608 2-Dec-2008 16:26
Send private message

I have got gmail app version 2.0.6, which is the latest (I think).

I also use the www.vodafone.net.nz apn

What is another secure site that I could try with my phone that others know works?


1780 posts

Uber Geek
+1 received by user: 35

Trusted

  Reply # 181609 2-Dec-2008 16:27
Send private message

try internet banking?



10 posts

Wannabe Geek


  Reply # 181610 2-Dec-2008 16:36
Send private message

Nope, tried to get to the login page (https) and got the same "communication failure. secure connection failed" error.

So it seems it is deeper than just the gmail page. (I should have checked that before)

So, how am i meant to get to secure pages from my phone? I have looked around my phone settings, but haven't seen anything that I should be turning on. Any hints?

2 posts

Wannabe Geek


  Reply # 181955 4-Dec-2008 10:25
Send private message

Im having the same problem with my nokia 6234

the old version of gmail app worked fine and still does but the new version (2.0.6) cant find an active data connection. also tried using google maps for mobile with the same problem.

anyone got any ideas

2669 posts

Uber Geek
+1 received by user: 335

Trusted
Lifetime subscriber

  Reply # 181976 4-Dec-2008 11:32
Send private message

I have version 2.0.6 working fine on my Nokia 6234. My configuration:

Settings -> Configuration -> Preferred Access Point -> My Access Point (www.vodafone.net.nz).

My access point was created in:

Settings - > Configuration -> Personal Config Settings -> Options -> Add New -> Access Point -> Access Point Settings -> Bearer Settings -> Packet Data Access Point -> www.vodafone.net.nz.

Hopefully this helps.

Cheers,

Matt.




My views (except when I am looking out their windows) are not those of my employer.

750 posts

Ultimate Geek
+1 received by user: 135

Trusted

  Reply # 181981 4-Dec-2008 11:52
Send private message

This is more a certificate problem than an APN issue. Are you sure the date and time are correctly set on your phone? SSL is dependant on these. (they don't have to be exact)




 




10 posts

Wannabe Geek


  Reply # 182003 4-Dec-2008 13:04
Send private message

Yep, I've had a double check and have got the correct date.

I am thinking it might be worthwhile to reinstall the certs, but how do I go about that?

BDFL - Memuneh
60322 posts

Uber Geek
+1 received by user: 11358

Administrator
Trusted
Geekzone
Lifetime subscriber

Reply # 182009 4-Dec-2008 13:41
Send private message

Could it be that Vodafone is using a transparent proxy on this connection and the proxy itself is not working correctly?

Is johnr reading this to check?




19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  Reply # 182011 4-Dec-2008 13:45
Send private message

freitasm: Could it be that Vodafone is using a transparent proxy on this connection and the proxy itself is not working correctly?

Is johnr reading this to check?


The only traffic that goes through that proxy now is when APN is set to opt.vodafone.net.nz

John

2 posts

Wannabe Geek


  Reply # 182014 4-Dec-2008 14:03
Send private message

Found this about installing certs.

deleted the one of my phone then reinstalled using the link but still no go



http://www.google.com/support/mobile/bin/answer.py?hl=en-ca&answer=78526

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41


Exhibition to showcase digital artwork from across the globe
Posted 23-May-2018 16:44


Auckland tops list of most vulnerable cities in a zombie apocalypse
Posted 23-May-2018 12:52


ASB first bank in New Zealand to step out with Garmin Pay
Posted 23-May-2018 00:10


Umbrellar becomes Microsoft Cloud Solution Provider
Posted 22-May-2018 15:43


Three New Zealand projects shortlisted in IDC Asia Pacific Smart Cities Awards
Posted 22-May-2018 15:14


UpStarters - the New Zealand tech and innovation story
Posted 21-May-2018 09:55


Lightbox updates platform with new streaming options
Posted 17-May-2018 13:09


Norton Core router launches with high-performance, IoT security in New Zealand
Posted 16-May-2018 02:00


D-Link ANZ launches new 4G LTE Dual SIM M2M VPN Router
Posted 15-May-2018 19:30


New Panasonic LUMIX FT7 ideal for outdoor: waterproof, dustproof
Posted 15-May-2018 19:17


Ryanair Goes All-In on AWS
Posted 15-May-2018 19:14


Te Papa and EQC Minecraft Mod shakes up earthquake education
Posted 15-May-2018 19:12



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.