Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


90 posts

Master Geek
+1 received by user: 5


Topic # 28921 16-Dec-2008 12:39
Send private message

I've been hooked up today with cable (yay!) which works fine when the cable modem is plugged directly into the pc (running Vista x64 SP1), but for some reason I just can't get it to play nice with my shiny new WRT54GL (with the latest Tomato firmware, connected via cable).  I can access the WRT to change settings fine, and the pc appears in the device list, but that's about all that works.

 

The plan was to have my pc and xnet VoIP adapter allocated fixed addresses in the network (I'm postponing working on the phone adapter for now, and when that works I can see about getting my DS to play nice with the wireless, but that's still a bit further down the track).  Unfortunately my inexperience is shining through (all I've had to setup previously was a adsl modem with built-in 4-port router), as I don't know where to start troubleshooting, besides double-checking I've entered the right numbers in the right places, and plugged the right cables in the right ports.

 

The network (as best I planned it) consists atm of:

Cable modem => WRT (192.168.0.1) => PC (192.168.0.2)

 

In the WRT, I set the connection type to 'Static', entered the IP address, subnet mask, gateway IP, and DNS servers as written down by the tech who installed it, but the pc was unable to access the 'net.  (I tried this both with a static IP on the PC, and with automatically allocated addresses)

 

What should I try next?


Create new topic
2652 posts

Uber Geek
+1 received by user: 222

Trusted

  Reply # 184500 16-Dec-2008 13:05
Send private message

Hi Kiwired23,

You need to input the settings, which were put into your NIC settings on the PC into the GUI on your router.
Namely your assigned IP, Gateway, etc...  Would pay to also have your router copy the mac from your computer network card.
Then set your PC's network card to DHCP (or set an internal static IP).

Hope this helps.

Cheers,
Grant

537 posts

Ultimate Geek
+1 received by user: 37


  Reply # 184502 16-Dec-2008 13:08
Send private message

Have you tried a "powercycle" (turning everything off then back on) after entering your settings.  When I was on cable the cable modem didn't like being connected to a new device before being through a powercycle



90 posts

Master Geek
+1 received by user: 5


  Reply # 184504 16-Dec-2008 13:13
Send private message

When I tried using the router I entered the cable settings into the router correctly (I think, anyway), and changed the pc settings to the address I'd selected with the router as the gameway, but with no success.  Changing the pc to use an automatically assigned address also failed to work.  I also tried having the router copy the pc's MAC address, but when I did that the pc wasn't showing up in the device list (should it just broadcast the MAC address to the cable modem somehow?).

 

And yes, I tried power-cycling the modem and router (and rebooting the pc) when changing settings.




90 posts

Master Geek
+1 received by user: 5


  Reply # 184557 16-Dec-2008 15:34
Send private message

Aha, thought it would be something small I broke with my fiddling - under Advanced/Routing I had it set to Router mode.  Changing that to Gateway fixed it.  All works now (including the DS and the PAP2T).

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07


All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21


Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54


Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15


IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.