Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




8 posts

Wannabe Geek


# 40703 2-Sep-2009 12:08
Send private message

Hi All,

I have been having on going problems with VFX and my trixbox. My incoming calls do not always get through.

My trixbox says it's registered and sometimes to call we get to my server.

I have tried the following
- Moved away from the ADSL XNet fusion connection to a TelstraClear cable connection.
- Turned off all voicemail and diverts at WorldxChange.

My installation has been working relatively well for many years without modification. It really has been of late that this has been happening.

Has anyone experience this too? Of course I emailed XNet but I got the "We do not support Asterisk" But they did say they can see the registeration at their end.

Any help would be great.

Thanks in advance

Craig

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3
27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 252524 2-Sep-2009 12:13
Send private message

How often does this happen? What happens when your box isn't connected?

There have been some random issues with Asterisk failing to reregister correctly with VFX.

Doing a "sip show registry" from the command line will show the current status of your connections. "sip reload" should fix the issue when it does happen.



8 posts

Wannabe Geek


  # 252530 2-Sep-2009 12:27
Send private message

Hi,

Thank you for replying so quick!

It seems to happen through out the day randomly. Usually when it's not connected it just goes to Voicemail.

Yep the sip show registry command shows it's registered ok.

It's weird because one minute it will be working the next it won't be.

My Cable connection is up all the time.

I am using NAT on a pfsense box as my firewall. Do I need to have pinholes through to my Trixbox?

Recently have I changed the registerattempt to 0 and registertimeout = 60 but that does not seem to make much different.

I am thinking tonight I might install Trixbox 2.8 and try that. Currently I'm using Trixbox 2.6.

Craig


 
 
 
 


27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 252534 2-Sep-2009 12:40
Send private message

Having port 5060 open is recommended but shouldn't be essential.

If you can perform a sip show registry and it shows as connected but inbound calls are failing then it's not the issue I described above. That's something that's happened to a few people on here maybe once every couple of months.




8 posts

Wannabe Geek


  # 252537 2-Sep-2009 12:47
Send private message

It's certainly weird. Is there extra logging options I can turn on in Trixbox, so I can see if it's trying to connect?

I will give the Trixbox 2.8 install a go and see if that helps. I will also put the pinholes through for port 5060. I assume they will have to be TCP and UDP?

Btw, Thank you for spending the time to reply to me.




8 posts

Wannabe Geek


  # 252538 2-Sep-2009 12:49
Send private message

Oh also, I have call notify to email on and I just got about 5 emails when I tried to call my number . It's like Worldxchange is trying to connect and then retrying.



27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 252548 2-Sep-2009 13:02
Send private message

If sip show registry shows as registered then it's possible that your firewall is blocking inbound traffic.

All SIP traffic using Asterisk is UDP only so only port UDP/5060 needs to be opened.

Once you have done that I'd be interested so know what happens. What configuration settings are you using? Have you added anything extra to your conf files such as externip= and if so is it correct?



8 posts

Wannabe Geek


  # 252587 2-Sep-2009 14:44
Send private message

I have added a NAT rule for port 5060 UDP to pinhole to my Trixbox and the last few phone calls seem to work.

Here is some of my config


[VFX2]
username=*my username*
type=peer
secret=*secret*
nat=yes
insecure=invite,port
host=as.wxcnz.net
fromuser=37411237
fromdomain=as.wxcnz.net
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=no
allow=ulaw
allow=alaw


 
 
 
 




8 posts

Wannabe Geek


  # 252927 3-Sep-2009 15:30
Send private message

Things seem to be better today with the incoming NAT rule in place. I haven't changed to 2.8 that will be a Friday mission I'm guessing.

Have a look at this screenshot. This is why I moved to TelstraClear Cable for my VOIP. It is usually 2400 down.





27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 252934 3-Sep-2009 16:01
Send private message

There is no real need to move away from 2.6 unless you want to move to Asterisk 1.6

The problem would occur regardless of what version you use since it was more than likely your firewall causing the issue.

Just one other small thing, you can now use pan.wxnz.net as the VFX server, you also don't need to add this to your hosts file.





8 posts

Wannabe Geek


  # 252995 3-Sep-2009 19:40
Send private message

Cool cheers..

I will when I get a chance put a log on incoming UDP port 5060 connections. I looked out my old firewall and it didn't have such rule and it worked for years until recently.

Maybe WorldxChange do a lookup UDP port 5060 on incoming call now to see if the asterisk server is there or something.

Anyway thank you for your advice.

27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 253000 3-Sep-2009 19:52
Send private message

rcgcreations: Cool cheers..

I will when I get a chance put a log on incoming UDP port 5060 connections. I looked out my old firewall and it didn't have such rule and it worked for years until recently.

Maybe WorldxChange do a lookup UDP port 5060 on incoming call now to see if the asterisk server is there or something.

Anyway thank you for your advice.


Were you using pfsence before?

Different firewalls can do slightly different things. Opening port 5060 is recommended but isn't always necessary.



8 posts

Wannabe Geek


  # 253009 3-Sep-2009 20:02
Send private message

No I was using a Linksys WAG54GP2 Adsl router with DMZ back to a Debian box (2.4 kernel) with shorewall. But the trixbox was on the WAN side(ie using the linksys as its gateway) so it had NAT directly through the Linksys router.


22263 posts

Uber Geek
+1 received by user: 4785

Trusted
Subscriber

  # 253616 6-Sep-2009 20:14
Send private message

I had no end of problems with incoming calls even with a portfoward. Putting my asterisk box as the DMZ has sorted it out mostly, but I think there were still occasions when the ports are used by other outgoing UDP which is why I got no audio some times.

I was going to try limiting the RTP port range on asterisk and fowarding that specofically to the asterisk machine but I consolodated and made it into the nat machine as well so its still a DMZ and no audio is very very rare now.

UDP is a prick thru nat IMO.




Richard rich.ms

96 posts

Master Geek
+1 received by user: 1


  # 253695 7-Sep-2009 10:57
Send private message

I have had the same problem, with three different sites recently. I have Trix 2.6, working on a DMZ, and at least once a week on all three sites, I have to reload Asterisk to re - register the trunk.
Incoming calls will get dealt with by the WxC voicemail, instead of the forwarding to the TRix. Outgoing calls work fine, so everyone thinks it is working fine... :(
Any other ideas?

27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 253703 7-Sep-2009 11:16
Send private message

Problems like this happening on a continual basis are obviously something to do with your setup. What type of router are you using?

The changes I posted the other day that are also in my blog will get around the issue you are having by forcing a SIP reload but aren't a proper fix for whatever problems you are having.

Lack of audio is typically an issue with poor quality routers or incorrectly forwarded ports.. I've never had an issue with any audio loss with VFX on any device. Just make sure your rtp.conf is modified and you're opening these ports up.

Are these trixbox installs on three different sites zimbonz? PM me if you need any help looking at the setup.

 1 | 2 | 3
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21


Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36


Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57


Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48


New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.