Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


3 posts

Wannabe Geek


Topic # 84764 7-Jun-2011 22:05
Send private message

Ahoy'hoy!

I'm having a problem setting up my Siemens Gigaset A580 IP phone with XNet VFX. The wierd thing is that incoming calls are working and I can make outgoing calls from my Android phone using the same account on the same network. The phone reports itself as registered and my account shows the registration in the MyVFX control panel, however when I try to make a call I get the message 'Not Available' on the handset accompanied by a 3-note tone.

I've also opened the following ports on my router (a WRT54GL running OpenWRT Backfire);

5060 TCP/UDP
5004-5020 UDP
10000-10100 UDP (not sure if these are necessary)

Has anyone experienced the same problem? It must be some configuration for the phone that I'm missing given that other things are working.

Thanks in advance,

Cheers,

Rob Connolly

Create new topic
854 posts

Ultimate Geek
+1 received by user: 52

Subscriber

  Reply # 478980 8-Jun-2011 15:08
Send private message

Hi Rob,

If possible I would run wireshark on it somehow? (if your router will port mirror the traffic, or perhaps you can run some sort of SIP proxy between the gigaset and VFX/Xnet so you can look at what call info your handing to WXC. Probably something simple like munged callerid.



3 posts

Wannabe Geek


  Reply # 479058 8-Jun-2011 18:11
Send private message

Hi,

I've tried Wireshark, but I'm not seeing any SIP packets. I assume I do need the port mirroring or a proxy as you said, however i have no idea how too set either of these up!

After a firmware update this morning the handset now reports a 404 error. Looking this up in the manual it says I have the wrong number, however no numbers that I try work. I have checked the default services for outgoing calls and it is definately set to use VFX.

Cheers,

Rob

26469 posts

Uber Geek
+1 received by user: 6025

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 479100 8-Jun-2011 20:58
Send private message

Might pay to post you're settings as you obviously have something configured incorrectly.



3 posts

Wannabe Geek


  Reply # 479101 8-Jun-2011 21:04
Send private message

Hi,

OK settings are as follows:

Authentication Name:  auth name as provided
Authentication Password: auth pass as provided
Username: 9950**** (i.e. the phone number without the leading zero)
Display name: as username

Domain: xport.co.nz
Proxy server address: pan.wxnz.net
Proxy server port: 5060
Registrar server: pan.wxnz.net
Registrar server port: 5060

STUN disabled.
Outbound proxy disabled.

As I said the connection was being registered and inbound calls were working, although further fiddling tonight seems to have broken that.

Cheers,

Rob

EDIT: Removing the funky firewall settings I was playing with for a SIP proxy and restarting everything has fixed it so I can register again. Still getting a 404 on outbound calls though.

205 posts

Master Geek
+1 received by user: 1

Trusted
WorldxChange

  Reply # 479658 10-Jun-2011 11:15
Send private message

For others that read this thread, the issue was fixed by setting the domain to pan.wxnz.net :)

Cheers

Josh 




Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07


All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21


Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54


Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15


IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.